Install Shield error: iKernel.exe

“The InstallShield Engine (iKernel.exe) could not be launched.
Error loading type library/DLL.”

Do I have a file association problem here?

This error has just started up in the past month. First I was unable to uninstall software. Now I can’t install it either.
Hard to believe, but my system was damn near perfect until this started !

Uninstalling software manually was a minor problem. But I’m comfortable with regedit.exe and safe mode.

I’m getting this error with ALL install shield software. nVidia drivers & Logitech software for my keyboard.
I’ve tried to download it again. Didn’t work. Install the older version from CD? Same error.

Any ideas ladies & gentlemen?

Here’s my system:
Abit VT6X4 Mother Board (VIA Chipset)
Win98 SE
P3 1ghz (not overclocked)
256mb PC133 (not over clocked)
Promise ATA66 PCI Card
20gb 7200 rpm IBM ATA66 (Primary Master on MB)
40gb 5400 rpm Maxtor ATA 66 (Primary Master on Promise Card)
4.3 gb Maxtor 5400 rpm PIO 4 (Secondary Master on MB)
nVidia GeForce 2 (AGP2.0) 32mb ram
LG GCE-8160B (Secondary Slave on MB)
Creative Labs 6X DVD (Secondary Master on Promise Card)
Logitech Deluxe Access 104 Keyboard PS2 connector
SB Live! Value
Microsoft DSS-80 Speakers (cable from SB & USB Volume Controls)
Umax Astra 610s scanner (SCSI connector)

I’ve read somewhere that upgrading from Internet Explorer 5.5 to 6.0 could cause this. So I fully installed 6.0 again. Didn’t work.
I thought it may have been a Visual Basic file was needed, so i installed VB 6.0 Runtime files. Didn’t work.

I have added some software, but this was going on BEFORE I added it.

I added:
Nero 5.5.8.0
CloneCD 4
Adaptec ASPI 4.70 ( to get CD-R ID 1.63 to work again).

I’ve been able to use Win Zip 8.0 to open the .exe and extract the contents to a folder. I was able to get the nVidia Drivers that way. BUT I still can’t get the full software package. I have only the drivers.

Any help or ideas are appreciated.

Thanks,

Spazmogen

perhaps you can try to install the microsoft installer called MSI

i do not know if it works but perhaps it fixes the broken dll
(you got nothing to loose)

look for it at the microsoft webside

Thanks for the quick reply.

I’m confused now. That didn’t work either.
The origina; error is a failure to load a DLL. I wonder: do I have a file association problem?

Any other ideas?

Try this

Mr. Belvedere:
Thanks! The cure was in the link you provided.

I installed dcom98.exe and it cured it !

I had been to installshield.com. but all I had located was commercial user information.

Thanks guys.

Hi all ,

I have the same errors and problems , is there a fix for it for windows xp? the link above isn’t working .
Thanks in advance. :slight_smile:

For Windows XP this is what you need to do-
http://kb.flexerasoftware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=Q105097&sliceId=

I had all sorts of these errors while trying installers until I did the above.