Insert correct disc

vbimport

#1

Hi all, i don’t know if this is that place to ask but i have some problems.
I bought a couple games, Battlefield2 and Devastation(Different times, about 8 months apart) there not pirated either there original.
I installed bf2 and when i try and run it i get this message saying something on the lines of “Please insert the battlefield 2 installation disk and click OK and restart the application” so i do so, click OK, and try running it again and it does the same thing. I then found my old copy of devastation and installed it and it does the exact same thing when i run it.
Now my Roms are 2 lit-eons, “DVDRW SOHW-1653S” and the “DVDRW SOHW-832S” and i don’t think there is nothing wrong with them but i might be wrong.
Please help, i want to play bf2 badly!! :sad:


#2

have you installed any virtual drives along with alcohol 120% or clonecd ? i recall reading that some games are now throwing that error if these apps are present


#3

Indeed, several new games (including BF2) will throw that error at you, and you will have to disable emulation in order for them to work. :iagree:


#4

how do i disable emulation?


#5

You have to say what burning programs your use so we can help you. :confused:


#6

If Alcohol 120% is on the machine:

Start Alcohol and go to the Emulation Options.
Select Emulation from the options tree. Uncheck the Ignore Media Types box to turn off the media type emulation, exit Alcohol 120% and restart the game application.
Select Extra Emulation from the options tree. Uncheck the BAD Sectors Emulation to turn off this type of emulation, exit Alcohol 120% and restart the game.

If CloneCD is on the machine:

  Look on your task bar at the bottom right of your screen (next to the clock). Locate the CloneCD tray icon, which can be a picture of two CD-ROMs; or of a sheeps head . Right Click on the icon and make sure Hide CD-R media is un-ticked. Restart the game application.

If Daemon Tools is on the machine:

  Select the icon at the bottom of the status bar of windows.
  Find the Daemon Tools Icon
  Right Click on the Daemon Tools icon in the Task Bar.
  Select the Emulation tab.
  Deselect SafeDisc.

#7

I havnt got any of those, i think i might of had alcohol and clonecd on ages ago but have removed them.


#8

I give up then, but wish you good luck! :iagree:


#9

If you havent reinstalled Windows since you removed the programs, you may have to run a registry cleaning program because sometimes there may be registry keys left behind that the games are recognizing. As long as those keys are there, the games think the programs are still installed. You can get a free one here:http://personal.inet.fi/business/toniarts/ecleane.htmThis is where i discovered this program http://www.techsupportalert.com/best_46_free_utilities.htm