Ink Systems

Hello, I have two espon R220’s and ink systems in both. And guess what… they both have problems.

First one -

My magneta cartridge is not being recognised as a valid cart. I bought a chip resetter which worked when my black cart went funny but it does not work on this one for some reason. So the only thing I can think of doing is getting a new chip for it. But I have no idea where to get one from… Looked everywhere! Any suggestions? Would be massivly appreciated.

Second -

Whenever I print with this ink system i get blobs of ink all over the page, here is a pic to make it more understandable.

I’ve tried doing head cleaning and stuff but still blobs all over the pages… again appreciate any help.

Thanks,
Brett.

P.S. Note I am in the UK.

I’ve heard Epson keeps changing the chip code overtime, so if you got newer R220, your old CIS chip probably doesnt compatible with the new one.

The big blobs may be caused by the head clog or wrong installation of the cartridge.

If you still cannot solve the problem, I suggest you switch to different CIS.
InkRepublic is the one I’ve been using for a while. It appears to be a very solid and cheaper CIS in the market.
http://www.inkrepublic.com/ProductDetail.asp?item=R200

i’ve only rescently started having problems though they both have been fine for months.

I even took the magnetta chip off one CIS and put it on another and computer is still telling me the magnetta chip needs to be replaced…

try to reset the chipset?
http://www.inkrepublic.com/KnowledgeBase/ResetCounter.asp

i have tried using this system before however the program is not detecting my printer. it is detecting the printed that is over flowing with ink but not the one with the dogey chip lol.