Incredibly slow read speeds on LG's new GSA-H42L

vbimport

#1

I bought LG’s new GSA-H42L yesterday at Best Buy.

It burns very well. It reliably burns 16x DVD+R’s at 18x and 2.4x DVD+R DL’s at 4x. The LightScribe B&W contrast leaves more to be desired, though. Worst of all, the drive only reads DVD-ROM’s at 4x tops.

My ancient OEM Compaq ODD from the internet bubble era reads faster than this thing (~8x). I’ve got the LG running in UDMA 4 mode on the secondary master IDE channel. Currently, my storage HDD is on the primary (boot disk is SATA). Would switching the ODD’s to the primary IDE channel help anything? Any other suggestions?

One more thing, why is LG’s support website so atrocious? This model isn’t even listed on their site. Even for the models that are listed, NOTHING shows up. It’s blank. I’ve seen highschoolers make websites more coherent.


#2

You can use Media Code Speed Edit to have the drive read faster than 4x spd.

http://club.cdfreaks.com/showthread.php?t=133858&page=22&pp=25

http://ala42.cdfreaks.com/MCSE/


#3

That’s the only solution? That’s obnoxious. I have to hack my firmware in order to achieve the advertised read speeds?

Also, I can only update the firmware with their program at the moment. LG’s website doesn’t mention my model ANYWHERE on the website. I guess actual product support comes second to rushing it out the door.


#4

If LG hasn’t released the firmware separately, then MCSE cannot do the speed patch. There’s currently no known way to dump the firmware from an LG.


#5

Welcome to the Forum adre, clintb is correct , unless there is firmware that is released to the public there is no way to use MCSE or any other tool to " Hack " your firmware. There is no known way to dump LG Firmware.:disagree:


#6

:o Sorry for giving the wrong info. I didn’t read well that the LGH42 drive isn’t supported by mcse. I don’t use mcse. :wink:


#7

Download and run the “Extended Label Contast Utility” from lightscribe.com to increase contrast.


#8

Wow! The contrast is at least 3x better with this thing. Granted, the process takes, like, 30 minutes, but I’ll be damned if the result isn’t beautiful. I wish I would’ve heard of this sooner. Thanks!


#9

I am just about to go to BB to pick up the GSA-H42L because the BB site says it is Vista compatible, but am concerned about Adre’s comment above.

I just installed Vista 64-bit and the Lite On LH-20A1H choked on Vista and was inoperable.

I definitely want a drive with the Lightscribe feature.

Should someone talk me out of the H42L and steer me to a Vista compatible drive? Or do I get the H42L?


#10

I confirm that the LG GSA-H42L works well with Windows Vista. Also, I confirm that reading speed is probably locked at 4X (RipLock?). Personally, I appreciate this feature because it ensures that I get an accurate read when I rip. Writing DVD DL at 4x is extremely reliable.


#11

I too confirm this player works with Vista Ultimate 64-bit. I don’t like the slow read only speed. Especially if I have to load software or do file transfers.

FYI - Adobe Acrobrat Pro 7 & 8 are incompatible with Office 2007. Acrobat 7 is incompatible with Vista if you want the latest updates.


#12

I own both drives, and I think that the LH-20A1H is far superior. To tell you the truth, I have only used my GSA-H42L for LightScribe after I got my LH-20A1H. The LG burns the image about ~5 minutes faster with enhanced contrast ratio enabled. Otherwise, the Lite-On is superior in every other way on my rig.

My LG is riplocked at 4X with poorer error correction whereas my Lite-On can rip at 16X+. It lacks C1 and C2 error reporting. It likewise lacks booktype setting to the EEPROM and all of the other cool Lite-On features.

What firmware is on your LH-20A1H? Have you tried LL06? I thought that I’d heard of some Vista success with this drive; maybe not. Also, with the tighter restrictions on drivers and such, does anyone know if it’s even possible to crossflash/upload unofficial firmwares onto the drive under Vista?

All in all, you’ll probably be disappointed with the performance of this drive. Sorry. :frowning: If you can’t wait for Lite-On to release some form of compatibility, it’ll do. The burn quality and LightScribe labeling are rather good; it just sucks at everything else by comparison.

edit: I forgot to mention that my LG does in fact get better burns on MKM003’s (Verbatim 10X DVD+R DL).


#13

to those of you who are using the gsa-h42l and have vista how did you get the software suit to install? or did you? when i try to install it says it only supports windows 2000, me, etc… and up. i’m using vista but it won’t install.


#14

nero 7 essential should work on vista


#15

It’s Seems No new FW update avilible now.


#16

weee wait…


#17

yes, knowing lg we will wait month or two


#18

i fixed the problems. my ID controler was on PIO. I set it on DMA and now the h42l “fly’s”. Excelent speed now! :iagree:


#19

How does one do that? I am not familiar with this setting.

Thanks!


#20

I bought a H42L a few days ago and the read speed on pressed DL DVD-ROMs is extremely slow (starting at 2x). I applied MCSE’s “increase read speed” option to the new H42L Firmware SL01, and to the H42N Firmware RL01 (crossflashed this one), both with negative result after saving and flashing. Then i downloaded Buffalo’s RJ11 firmware for the H42N, applied the read speed option, and now the H42L starts with a read speed of 5x instead of 2x on the same DVD. The only problem is that with the RJ11 there’s no lightscibe anymore (I love my lightscribe feature ;)) and i dont like to flash the drive back and forth just to use LS or have a fast readspeed…

The question is: Why is this RJ11 with “increase read speed” the only one that works on my drive, and is there a solution with the new SL01 released to make it work and read fast on my H42L?

Any help is appreciated… :wink:

Thanks and gn8,
Kali

EDIT:
Damn, i have to revoke anything i wrote before…
I flashed the drive to H42L again, and then back to the RJ11 with increased speed, now it is as slow as all the others… 2x… What am I doing wrong… It worked for one time, and now it doesn’t… Guess i’m stupid :wink: