Incorrect Firemware in CDRW

vbimport

#1

Hi

I have just accidently flashed my Liteon CD/RW with Samsung flash. Now my drive is not recognised in bios. I have attempted to use MTKFLASH to back this out but it hasn’t worked, I guess because the drive is not recognized in Bios. Are there any options for me here

Thanks in advance :confused:


#2

No. MTKFLASH does not need the drive to be detected by BIOS.
Make sure you supply correct parameters to it - how is the drive connected!
1 - Primary Master
2 - Primary Slave
3 - Secondary Master
4 - Secondary Slave


#3

I would like to add;

Make sure you got everything right. :cool:

Do you get any error messege?


#4

How the hell did you manage that?!

Been drinking eh?


#5

I’ve flashed my LDW-811S bin firmware into my LTR-40125W many times. It appears in the list of LtnFW before LDW a when you forget to change it…you’re fucked up and looking for the floppy with mtkflash.exe :wink:


#6

I had a cd and a dvd drive in my PC, The DVD wasnt working so wanted to update the flash, however both devices were set to Slave and you can guess what happened next


#7

Flashed both?:wink:


#8

As a slave device on the second IDE channel. Ive tried the mtkflash but I dont have a bin file for the drive so I extracted a utility to extract a bin from the windows flash update (Cant remember where I got it). Maybe you know where I can get a bin file. I used the following commandline

mtkflash 4 W /B file.bin

It seemed to accept this command but didnt do anything that I can see as I still cannot boot with the drive


#9

Maybee You should try a newer version of mtkflash - and beware, it does not require the /B switch anymore as it defaults to binary mode.


#10

P.S. you can download various BIN firmwares @ http://dhc014.rpc1.org

Also, be sure that the Samsung drive is not set to slave anymore!!! :stuck_out_tongue:


#11

If there is a binary firmware available on my site, then grab that to be sure that you have a proper firmware image. Disconnect other drives while you attempt to recover this one. If you are sure that you’re using the correct command, but mtkflash just on’t flash, then make sure that you’re in real DOS. After that, move the drive to another computer and try to flash there.