ImToo iPhone Transfer

I have downloaded the trial version of this software
But i cannot get it to connect

I have a pc laptop - initially without itunes installed.
When I run ImToo iPhone Transfer it give the “Enter registration key” dialog, which i cancel or say “remind me later”
I then have the split screen, on the left is the node saying “Please connect to iPhone”

alas when i do nothing happens within the app (i do get an autorun dialog appear - so the pc knows a usb device is connected okay)

i’ve tried various ignore / open opens from the auto run in case that affects things for the imtoo app

i’ve also since installed itunes in case any components/dependencies exist - same problem.

have tried with itunes running (get a dialog asking to close it - fair enough) and now.

have tried having the phone connected first or plugging it in after the app has started.

anyone else have this difficulty?
what is wrong with my setup or install?

the version of the software is 2.1.33 (build 0504)

the iphone is running v3.0 firmware
but was also not working before i updated this…

?

cheers for any pointers/help

hi,
the program ImTOO iPhone Transfer was updated today.The newest version is 2.1.34.0628 and this version app supports iphone 3G and works well with iphone v3.0 firmware.You just need to update iTunes to 8.2 and re-download the latest program.You can complete your work.
Ths for supporting ImTOO.:flower: