Impossible to flash ND 3500AG set-up via USB2.0 Enclosure

vbimport

#1

Impossible to flash ND 3500AG set-up via USB2 External Enclosure!
Any suggestion? What can I do for succesfull flashing my NEC drive with
Herrie 2.17 modified firmware?
Maybe it’s necessary to force connection via IDE 80pin conductor cable?
And the firewire connection will work with flashing tools?
Thanks a lot for any help you can !


#2

Have you try Liggy’s UNIFLASH yet? I flashed my drive with Liggy’s Windows flasher and the command line ones in an external enclosure without problem…

You might need to extract the firmware as .bin and then flash with the Liggy’s flasher.


#3

I tried yesterday so, but nothing changed! I tried Liggy’s UNIFLASH and flasher you
can find in package with Herrie’s 2.17 Firmware! But every action don’t sort any effect!
The drive led blink and flashing don’t start. But I’m lucky because drive don’t die after
flashing error. The original firmware remain and ND 3500AG keeps all capabilities!
What do you think of this…?


#4

Hmmm… then I am out of ideas… Liggy’s UNIFLASH works great on my 2 external exclosure… 1 firewire/USB2 combo, 1 USB2. Do you know what kind of chipset does you enclosure use? Brand of enclosure maybe?


#5

i had the same problem, it usually fails a flash, or will say it has flashed but it never actually did the flash. i had to remove my 3500 from the external usb2 and plug it in IDE to get it to flash

i have the cd-509 enclosure

edit: cd-509-u2 enclosure: http://www.coolmaxusa.com/products_gemini.asp?item=5


#6

I don’t know what kind of chipset my enclosure use but this evening, when I come back home will check this info. But this problem is very curios for me! The USB2
controller is Intel 845P w/ICH4 chipset integrated! Don’t you think is curios? I tried
many times and flashing starts but stop immediatly! The led drive blink and need turn
off the drive, after turn on for complete operational functions! The flash error don’t
kill the drive! Any suggestion? Maybe it’s better if force connection to IDE cable!


#7

I have Intel Application accelerator installed. Do you think can be that problem?


#8

i can you tell 100% that the nec drive will not flash within an enclosure, you will have to attach to the ide to flash


#9

I think it uses ASPI drivers to flash which mean enclosures may have issues. Also please do not use intel application accelarator as it causes many issues with burns.


#10

But how is it possible that several people, including Herrie for example, were able to flash their drives in an external enclosure?


#11

If I do remember I did flash my 2500 externally but that was with herries exe not the flasher. But, I can tell you intels application accelerator has issues with most everything to do with optical drives etc. It is a piece of crap. :Z


#12

you tell me liggy, as you remember when you released your flasher i did tell you then, that enclosures on the nec didn’t work to well if at all


#13

I was able to dump my ND 3500AG firmware to Hard Disk but not flashing!
For your information my nclosure is the same of Sir Knumbskull signed up !
The CD-509 Enclosure! I agree with Sir Knumbskull and PumaUK! NEC drive can’t
to be flash via USB2.0 Enclosure! I don’t know if is possible via Firewire!
Anyone tried it ? Thanks for yours help to all ! Now I’m going to attach NEC to IDE
cable ! Sigh ! Goodbye from sunny ITALY (25° degrees now around VENICE)


#14

Very strange. I think I already flashed a NEC burner with USB2 at work, but I’m not 100% sure and I must have used the official windows flasher (with an inofficial firmware) :bigsmile:


#15

Was this really necessary? Thanks for ruining my day.

Greetings back from freezing and rainy Germany.


#16

some say they have been able to flash via usb2.0 and firewire. but i havnt :\


#17

I would say Intel App Accelerator is probably the source of the problem. I have Nforce2 based motherboard… flash both NEC2510 and 3500 without problems.


#18

i haven’t got an Intel App Accelerator, so that can’t be the problem, i think its just converting the ide 3500 to a usb2 causes some form of problem


#19

If I do remember I did flash my 2500 externally but that was with herries exe not the flasher. But, I can tell you intels application accelerator has issues with most everything to do with optical drives etc. It is a piece of crap.

Well I hate to disagree But I ran some extensive tests and cpu usage is much lower during a burn with intel application accelerator installated and I can do much more stuff including memory intensive stuff during a burn with it installed than without it installed. I have a dual xeon dell precision 530 3.0ghz machine with 1.5 gig of rdram and should be able to multi-task easily during a burn… without it installed the buffer was going down and I was getting not a very smooth burn … but with it installed I do… It does however make winbtype.exe not run correctly… (I have another partition I can boot to without it installed to run winbtype and run tape backup in case of emergencies) I also have scsi drives in this system)…

Another nice thing about it is I can see exactly what dma mode I am in whereas without it. you just see you are running in dma/ultra dma or not… but not exactly what mode or whether you have 40/80 pin cables in the device or not…

also this is how I know an 80 pin cable is not necessary for the 3500 since the internal cabling is also only 40 pin and it only supports ultra dma mode 2 anyway (I also tried it anyway with and without the appliction accel. just in case it was wrong but it wasn’t).

      Secondary Master:  _NEC DVD_RW ND-3500AG
           Model:  _NEC DVD_RW ND-3500AG
           Firmware:  2.17
           Device Type:  ATAPI - Removable - CDROM
           PIO Mode Support:  0 - 1 - 2 - 3 - 4
           DMA SW Mode Support:  No Support
           DMA MW Mode Support:  0 - 1 - 2
           UDMA Mode Support:  0 - 1 - 2
           Default Transfer Mode:  UDMA-2
           Current Transfer Mode:  UDMA-2
           Transfer Mode Limit:  No Limit
           Cable Type (Device):  40 Conductor
           Cable Type (Host):  40 Conductor
           PIO PPE:  Enabled
           UDMA Control Register:  Ultra DMA Mode Enabled
           UDMA Timing Register:  CT = 2 CLK / RP = 4 CLK
           Base Clock:  Ultra DMA 33 Timings
           Auto-Acoustic Management:  Feature not supported by device.
           Dynamic APM on AC:  Feature not supported by device.
           Dynamic APM on Battery:  Feature not supported by device.


#20

hello… i have my 3500 in a Plumax USB/Firewire Combo case but could only flash it through Firewire… this works with all the firmwire/loader available… as with the USB it did not work for any of the firmwire/loader… i did once had a 2500 in a Bytecc USB only enclosure from Newegg and was able to flash it with Harries and TDB’s loader…