ImgBurn suddenly can't make a CD from mp3 files

I used to select a bunch of mp3’s, create a CUE file, then Write to CD.
Now, suddenly (after a Vista update?) I can’t to it with mp3’s.
I have to convert them to WAV files first. Then it works.

If I try it with mp3’s, it makes the CUE file but won’t burn it.
Instead of writing it says:
Potential DirectShow Error!
No data has been received for 10 seconds.
Then ImgBurn crashes and has to be closed by Windows.

What’s happening? Can it be fixed?

Maybe LUK can answer this one, I have no problem making mp.3 discs with Imgburn.

It’s probably due to a bad filter being pulled into the graph.

Turn off ‘prefer accurate audio track duration’ in the Create CUE File’ feature and then add one of the problem mp3 files. Now right click that item in the list and pick the ‘Display DirectShow Filter List’ option. Get a screenshot of what it reports (or press CTRL+C when the box is on the screen and then CTRL+V (paste) that info into a reply).

I have Vista but I admit I’m behind on doing Windows Updates.
I tested & ImgBurn is working fine for me.
I burned the .mp3 to a CD-RW . It played fine.
Shows as a Track01.cda pointer file as it should.
I may try the updates & see
if anything happens this weekend .

Always willing to learn something about ImgBurn so I tried what LIGHTNING UK! posted in #3 .
Below is a screen shot I expected LAME to be in the list as I have in installed.

@ LIGHTNING UK! , Should LAME be in the list ?


My list (on Win 7 x64 SP1) looks as follows and is about as ‘clean’ as you can get (i.e. it’s using the default / built in filters that ship with Windows).

DirectShow Filter List:

  1. -> Source (Vendor Info: Unknown)
  2. -> MPEG-I Stream Splitter (Vendor Info: Unknown)
  3. -> MP3 Decoder DMO (Vendor Info: Unknown)
  4. -> Sample Grabber (Vendor Info: Unknown)
  5. -> Null Renderer (Vendor Info: Unknown)

Thanks LIGHTNING UK!.
Mines obviously not default but it seems to work well.
I was mostly concerned that LAME wasn’t in the list.
As I thought it was what ImgBurn used.
I might look into the defaults whether I decide to try & use them or not.

ImgBurn uses whatever DirectShow pulls into the graph. It has no set configuration and it’s just based on how things are configured within Windows.

Tools like ‘DirectShow Filter Manager’ can be used to change the ‘Merit’ of a filter and make it more/less likely to be used in the conversion to CD-DA format.

Thanks, LUK. Here’s what I got:

for the MP3 files that didn’t work (created in mp3DirectCut):

  1. -> Source (Vendor Info: Unknown)
  2. -> MPEG-I Stream Splitter (Vendor Info: Unknown)
  3. -> [B]Viscomsoft MPEG2 Audio decoder[/B] (Vendor Info: Unknown)
  4. -> Sample Grabber (Vendor Info: Unknown)
  5. -> Null Renderer (Vendor Info: Unknown)

for the same files converted to WAV (by Switch), which did work:

  1. -> Source (Vendor Info: Unknown)
  2. -> Wave Parser (Vendor Info: Unknown)
  3. -> Sample Grabber (Vendor Info: Unknown)
  4. -> Null Renderer (Vendor Info: Unknown)

Right so then the problem with your graph is probably coming from the ‘Viscomsoft MPEG2 Audio decoder’ filter. Use the program I mentioned in an earlier post to change its ‘Merit’ and make it less likely to be used.

Viscomsoft MPEG2 Audio Decoder is 00800000 "Preferred"
I tried to lower it, but no matter what value I try I get:
*** Merit modification was failed

MP3 Decoder DMO is "Unknown Merit"
When I select it and click “Show filter properties,” nothing happens.

Try uninstalling the Viscomsoft software you have & see what shows up .
I’m not sure but my #3 is ffdshow Audio Decoder . I think this is from CCCP.
I didn’t verify that though .
There are a couple of other softwares that can change the merit .
I’m not saying their better but sometimes one software works when another doesnt.
Radlight FilterManager & filmerit . So you could try those to change the merit.

Don’t forget to run the tool as admin too (well, elevate it anyway) - it’ll probably need permission to write to locked down areas of the registry.

[QUOTE=LIGHTNING UK!;2649791]Don’t forget to run the tool as admin too (well, elevate it anyway) - it’ll probably need permission to write to locked down areas of the registry.[/QUOTE]
I agree with the above .
I always run this type of software as admin
so I didn’t think to add that .
That might make the ‘DirectShow Filter Manager’ work & set the merit.

Thanks, Cholla and UK. I do everything as admin. No other users.

I tried Radlight, with a similar result - “Cannot update merit” for Viscomsoft codecs, and it doesn’t list MP3 Decoder DMO under DirectShow Filters.

I found an old forum entry about changing the merits in the registry, but it says you have to edit the second dword. My Vista registry doesn’t have dword value types for Filter Data; it just has Binary, and I don’t know what to change. The Filter Data it shows for Viscomsoft MPEg2 Audio Decoder is 02 00 00 00 00 00 80 00 02 00 00 00 00 00 00 00 30 70 69 33 00 00 00 00 00 00 00 00 01 00 …

I haven’t knowingly installed any Visomsoft software, and a Windows Explorer search of my C drive somehow failed to find anything in a search for viscom, but the registry pointed out that there were a bunch of visom___.dll’s in the Free Video Converter program folder.

So I uninstalled FVC, which deleted the folder, and then re-booted. But both filter managers and the registry still show those Visomsoft filters. Radlight at least shows them greyed, but it still offers to set the Merit values for them, and later still says it can’t do it. The registry still shows the non-existent DLL’s in the non-existent FVC folder!

Ah! But now ImgBurn uses MP3 Decoder DMO, even though the filter managers say it doesn’t exist. Good old ImgBurn, knows what’s really going on even when no one else does.

So I assume I’ll be able to burn audio CD’s from MP3’s now. I won’t be able to try it till later tonight. Have to run out now. If it doesn’t work I’ll report back.

Many thanks!

I’m curious to see how it went,

I decided to look for Viscomsoft on my Vista OS . I have some .
In my Directshow filters I have “Viscomsoft QuickTime Decoder” .
I have these two files in my System 32 folder: viscomqtde.dll & viscomwave.dll .
I checked the link & also did a “Find” in my registry .These are the registry keys where I found Viscom :
HKEY_CLASSES_ROOT\CLSID{083863F1-70DE-11D0-BD40-00A0C911CE86}\Instance{C9FD7FF0-F906-4A4E-8963-4414EBFD93F1}

HKEY_CLASSES_ROOT\CLSID{3C78B8E2-6C4D-11D1-ADE2-0000F8754B99}\InprocServer32

HKEY_CLASSES_ROOT\CLSID{C9FD7FF0-F906-4A4E-8963-4414EBFD93F1}\InprocServer32

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID{083863F1-70DE-11D0-BD40-00A0C911CE86}\Instance{C9FD7FF0-F906-4A4E-8963-4414EBFD93F1}

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID{3C78B8E2-6C4D-11D1-ADE2-0000F8754B99}\InprocServer32

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID{C9FD7FF0-F906-4A4E-8963-4414EBFD93F1}\InprocServer32

HKEY_LOCAL_MACHINE\SOFTWARE\Debug\viscomqtde.dll

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs

As far as I can tell I don’t have any software from Viscomsoft installed & I hope to track down what installed these files & registry settings.
I do have "Free Video Converter " but it is from this site & appears to have no connection to Viscomsoft:
http://bluraytoavi.com/

So anyone know how or good at finding what program uses certain .dll files ?
I would like to know if they are just leftovers from an incomplete uninstall or if some
program is still using them.
In the ImgBurn ‘Display DirectShow Filter List’ Viscom wasn’t the filter that was found on my OS like it was on Elrod’s .

I checked Radlite & it doesn’t even list the MP3 Decoder DMO .
filmerit & DirectShow Filter Manager both do. In filmerit it is in “DMO Audio decoders” .

Cholla, you might try un-installing Free Video Converter and see if that gets rid of the viscom___.dll’s in the Sytem32 folder. You can always re-install it later.

My version of Free Video Converter put them in its Program Files folder, but maybe other versions put them in the System32 folder.

Or you could hide the viscom__.dll files by moving them to another folder, and then see what programs complain about it.

@ Elrod , I don’t use the Free Video Converter much so I uninstalled it. As I thought it wasn’t Viscomsoft so that didn’t remove the files or registry keys that have viscom.

I did a backup but haven’t yet moved the viscom_.dll files but I will try this . It may take a while to find out what program it affects . I kind of think the reg keys & files are probably just left overs from an incomplete install. If I knew what software installed them I would install it & try the uninstall again. So I will post on this when I remove they keys & files.

I got my Vista completely updated & I have no problems with ImgBurn creating a .cue from .mp3 files or ImgBurn writing them to a CD as .cda files. In other words creating an Audio CD. So the updates didn’t make ImgBurn not work on my VIsta.
I will add I don’t use the MS malware detector or Silverlight so I don’t install those updates I just “hide” them. So if you do use those it is possible they caused a problem that I don’t have. Probably not but possible.