Imgburn settings

vbimport

#1

hi! I would like to know which options do I have to change in order to make imgburn work in a similar manner to nero for data dvd burning
thanks


#2

Easy.

You use the Build mode ( Mode -> Build ) and switch the output from an ISO file to the required burner (Output -> Device) .


#3

^thanks I knew how to do that, but when I burn files they appear with their dos names or something
I just want the files to appear normally on the dvd…


#4

You must select proper options in Advanced --> Restrictions.

The pic is only an example, [B]not[/B] how you must set options :slight_smile:

Do some tests by yourself to find the right options building images on your HDD and then verifying if images are built properly before to burn them on a disc


#5

^thanks
I’ve selected level x and every options in the middle now let’s see if it works…


#6

No, you just need to make sure Joliet or UDF are selected in the ‘File System’ dropdown (those along side ISO9660 are fine - Windows will always use the best one when displaying filenames).

If it just says ISO9660 then you’re limiting yourself.

Changing the restrictions should only be done as a last resort or if you know what you’re doing and know that what you’re building requires such measures.
Level X is out of spec so use it with caution.

ImgBurn defaults to ISO9660 + UDF. That should have been fine for most projects.


#7

Hi [B]LUK[/B] :slight_smile:

I suggested to change restrictions because when I use nero to build ISO files, I have the following settings enabled (see the pic). Enabling these settings also in ImgBurn can create compatibility problems in burned discs? :o


#8

Anything where you break the spec can cause problems! :wink:

You can see from your screenshot there that the disc you’re going to create might not be readable under DOS/Windows 3.1x etc.

The default options are within spec and so are guaranteed (*) to work with all devices.

If you find a program / drive / player / whatever that goes EXACTLY by the book, it’ll fail to recognise your disc properly and probably blow up :stuck_out_tongue:

The ISO9660 file system is very restrictive/basic - but then it dates back years and years!

Things have moved on - so have file systems.

These days you’d use Joliet which supports unicode, long file names etc etc.

Newer still is UDF which supports all the above (only better) and more.

So rather than changing the ISO9660 settings to make them out of spec, just enable the Joliet or UDF file system.

As mentioned before, Windows will always use the best file system available on the media when it comes to displaying stuff to the user.

So even though the ISO9660 file system will contain filenames limited to 8.3 characters (XXXXXXXX.YYY format), you’ll never see them. It will show you the nice long ones in the UDF filesystem.


#9

Thanks for clarification [B]LUK[/B] :slight_smile:


#10

lightning, I’m not sure if it’s because I use win98, but I don’t think my system is choosing udf to show me the files
I’ll try udf only with no restrictions, I don’t care if I can’t read the disc in dos and win 3.1


#11

I’ll second that. :slight_smile:


#12

what it does is that it shows the root folders of the files I burn, for example if I burn something that was in my documents it’s gonna show the my documents folder


#13

98 does support UDF but it’s parser happens to pick up on a tiny glitch in my UDF code (boo hoo!). Under newer OS’s there isnt a problem - and hence why it wasn’t picked up in testing. It has the effect of limiting the number of files shown in any one directory to about 30 or something.

I shall be releasing v2.2.0.0 tomorrow (with a big changelog, as usual :wink: ) and that contains the UDF fix.

In the mean time (i.e. the next 24 hours) you should be fine with Joliet.

I still wouldn’t touch the ISO9660 options but by all means extend Joliet to Level X if you really can’t make do with 64 character file names - obviously you’ll need to switch the filesystem to ‘ISO9660 + Joliet’ though :wink:


#14

The ‘source’ box in ImgBurn IS the root folder.

Do you have ‘preserve full pathnames’ enabled?

If not, the following apply:

If you drop folders into it, those folders will be visible in the root on the disc. (i.e. if you drop C:\TEST1\TEST2, the folder ‘TEST2’ will be visible in the root of the disc)

If you drop files, the files will be visible in the root of the disc (and not the folder they live in).

If you JUST drop 1 folder, you can choose if the folder should be visible in the root or BECOME the root (i.e. only its contents are visible in the root, not the folder itself).

Otherwise, the following apply:

If you drop folders, those folder and their parent folders will be visible in the root on the disc. (i.e. if you drop C:\TEST1\TEST2, the folder ‘TEST1’ will be visible in the root of the disc and inside that will be ‘TEST2’)

If you drop files, the parent folder(s) of the files will be visible in the root of the disc and inside those will be the files.


#15

^hmm I’ve dropped files only that were in my documents/my videos, and both of the folders are visible on the dvd (‘preserve full pathnames’ is not selected)
thanks for the help!


#16

If you just dropped the files and the folders are there too, you must have the checkbox for ‘Preserve Full Pathnames’ checked.


#17

Looking forward to this… :clap: