Image won't work when mounted

Did same thing on two different computers, one works the other doesn’t.

  1. DL’d alcohol 52% free version.
  2. Created image of Warcarft 3 on both computers, mounted both…still ok.
  3. Create image (mds/mdf) of BF2, CoD2, Rome, Halo, etc, all safedisc protected, correct? Was patient and waited for it to skip the bad parts. Seem to get image ok. Just want to preserve my disks because I have 4 young kids that like to scratch them.
    Difference:
  4. On one computer, when I mount the images, they all work perfectly fine. But on the other computer, it looks like the image will work, then for example when I click on Single Player in Call of Duty 2, it asks for the CD again.

On non-working computer have tried:
1)mounting images in Daemon Tools with using safedisc emulation. nada.
2)(and this I thought was fool proof) Burn image files (mds/mdf) from working computer onto CDRW, then tried to copy files from CD to non-working computer. But it gets to about 35% and halts. So I tried to fix the transfer mode from DMA to PIO only but still to no avail.

As you can see, I’m quite new to it all but I do my homework before coming and posting. At this point I think it’s my Drive, I’m not confident it’s burning the images correctly because it can’t even read the images I burned from the other computer which I copied to a disk. It is a Samsung DVD Burner model SH-S182M/BEBE.

I’m ready to go and buy another drive but don’t want to come home and have it not work also…please advise!

Have you tried using any anti-blacklist tools such as YASU? If the hardware is different on the two machines, it could be the copy protection isn’t working properly on the one machine that you can run the images from, but is able to work properly on your other machine, which is why the images don’t work. For example, the Nforce chipset has been known to cause copy protections to malfunction in the past and allow images to play without anti-blacklist tools.

Have you used a new image using all security properties on with the image creation

it happened with my expansion of warcraft 3

Everybody is talking about the YASU, but no decent guide for its use, Can anybody help?