I'm Stuck! ND-6650A

vbimport

#1

I just got a ND-6650A… and I put in my laptop… Works ok in Windows, but the issue is that my BIOS and POST does not recognize it at all. I was thinking it was the suggestion from Liggy about Reverse ATA so I DLed that and have been trying whatever I can to fix it. I can’t boot from CD, cause it doesn’t recognize any drive and there is no way I can otherwise boot from anything (it’s a laptop). I am desperate and want to find out something somehow tonight!!

Should I do a hotswap with my old CD drive after I boot into some DOS? Would that work?? Suggestions please! :frowning:


#2

sounds like the problem is with your BIOS. Check and make sure your BIOS is set to ‘autodetect’ or something like that, if not available or doesn’t work, try entering the info manually…you might even have to flash your BIOS, you could check your MFG website for updates…if you still have problems, try the company that makes the ND-6650A…I’m sure if it’s a problem with the drive they’ve already had complaints and prolly got a fix for it too…


#3

Not sure… But as of now, I can’t get a BIOS update until Monday… Crap ass laptop tech support! :a and so I gotta try and figure something out…

Anyone else confirm that it is probably BIOS and NOT the Reverse ATA??? The drive is actually in the Secondary IDE connector as a Slave unit…


#4

da budda,
“…The drive is actually in the Secondary IDE connector as a Slave unit…”

What is on the Master of the Secondary IDE connector?
How did the old CD drive show up before you took it out? (slave or Master)


#5

In the BIOS, as “Secondary Master”, which is odd, cause the harddrive is “Primary Master”. This makes no sense at all, but then again it is a laptop and never will you add your own/switch around IDE periphereals, so they only gave you two that are always preset the way they are… There was a firmware update I was trying with the old drive and you had to choose what IDE position it was (1-4) and it was 4–secondary slave… that is why I say that, however not sure. The problem IS (I am 99% sure) the master/slave problem conflicting with the harddrive… I’m considering looking at the HDD tomorrow to see if it has an option to be slave and just doing that instead…


#6

Does anyone know if regular 2.5" notebook harddrives typically have a set of pins to change if they are master or slave? Everything in a damn desktop always has these options, but nothing that is miniaturized does!


#7

You basically have 2 choices. Solder pins 45 and 47 together to force the drive to Master, or Do the reverse ATA to set it with software. Problem with that is you will probably need to set it to Reverse ATA in a desk top setup with an IDE adapter.


#8

no no… I just did it without it… get this… :bigsmile:

I put in the old CD drive and booted to a FreeDOS CD I had, then hotswapped that old drive out (while FreeDOS was sitting in the FAT32 partition drive) and put the new NEC one in and went back and ran the .bat’s and the first one worked great… Then I had to do that same process all over again to run the MAIN.bat one and once I did that it worked great.

Now the drive is seen in the BIOS and everything works great! I am damn happy!! :bigsmile: Thanks to Liggy so much for even making this firmware!!! :bow: :bow: