Im so confused!

vbimport

#1

ok, this is my sad story…i recently updated my pc through windows update till there was no more updates left, then i realized that my pc was not recoginizing my cd drive, i did a little research and found it was a problem with vista and a registry entry, i edited the registry as sugested, and it worked…my drive got recognized, i try to play a blueray movie nothing, i tried a normal dvd and it worked, basicly it will play anything but blueray. so, i figure i need a driver update, found out i need a firmware update, no problem.found the firmware update, it says its NOT for OEM products.now my understanding is OEM means one company makes, another lables and sells it, but my drive has both names on it and i need to know if it is an OEM or not, AND IF IT IS WHO IS THE MAKER/SELLER…Hitachi-LG Data Storage Inc.device manager says its a HL-DT-ST BDDVDRW GGC-H20N. Also i read the readme file in the firmware update, it says i need to change the jumper to master on the back of the drive, THERE IS NO JUMPERS!!! So thats leading me to believe something is wrong here. All i wanna do is watch blueray on my pc, this is driving me crazy, anyone got any ideas on what to do? please help


#2

Take the drive itself out if you can and read what the label on one the drive says that should tell you more about the drive itself. Have you tried this link?

http://support.microsoft.com/kb/314060

http://support.microsoft.com/ph/11732


#3

did that, says Hitachi-Lg Data Storage inc., model#ggc-h20n


#4

Your drive is an LG, and uses a SATA interface, so moving the jumpers does not apply to it.

What make is your computer? If it is a Dell, Compaq, HP or another OEM (original equipment manufacturer), you may have one of their proprietary firmwares on it now, and need to get a firmware update from them.

Do you know what firmware is on it now? If not you can find this out using ImgBurn. (it will show up at the end of the name of the drive and look something like 1.02 or 1.03).

What software are you using for playing blu ray? Sometimes you need to update the software for playing blu ray.


#5

the current firmware is 1.01, and its an ACER computer,…with no warrenty, i tried calling them, basicly said i was on my own, or i could pay them $200.00, plus shipping for fixing it. im trying to update to 1.03, also i tried running the firmware update utility(.exe) and it couldnt find the current version so it did nothing but close. im using acer arcade live to play blueray movies, software came pre installed. funny thing with updating that software is, i update it, and when its done it wants to update again like it never got it, over and over, it keeps asking me if i wanna update it no matter how may times i do it, and its gotta be the same update cause its the exact same file size everytime, so i figure its not taking the update cause it doesnt know its actually a blueray player, or its the wrong firmware to run with vista.


#6

Just for grins and giggles, try downloading a different blu ray player. I recommend Arcsoft TotalMedia Theater Platinum: http://www.arcsoft.com/en-us/software_title.asp?ProductCode=TMT3P

There is a free trial at that site. Lets see if the software you’ve been using is the problem.


#7

well, im grinning from ear to ear, and giggling mao!!! so after all that it was only the stupid blueray software, cause this trial works just fine!!! thanks o ton!!! I kinda feel stupid now, cause i never tried diffrent software first, im not really a computer newbie, i do know a few things. i think i just got to caught up in reading all theese forums on the subject, and got misdirected. but THANK-YOU, for pointing me in the right direction!!!


#8

You’re welcome.

You might want to reinstall the Acer arcade software and see if that will restore it to a functioning state.


#9

An Acer without warranty and Windows Vista. Not the best combination all together… :slight_smile: Glad it got solved.


#10

That would’ve been my next resolution was to try different software to see if the program wasn’t the cause of the problem. But good know the problem is resolved.