I'm new and have DVD playback problems

vbimport

#1

Hi all! I 've come across this site before occasionally for various purposes, but now I’m a forum member because I must post this problem I’m having. When I play DVDs on my Dell Inspiron E1705 laptop, the playback is choppy, both audio and video together. I’ve searched around on the internet to find solutions but no solution has worked yet. DVDs used to play fine on my laptop. However, a while ago my computer was erased by linux and I had to reinstall Windows XP Media Center. I also installed the programs Nero Burning Rom and Imtoo DVD creator. They are uninstalled now, but playback is choppy. I think these programs ephed up the quality of playing DVDs. I’m no computer guru, sp what do you think is the problem? I just want to watch DVDs again. Thanks!


#2

Try VLC. It is a free media player that doesn’t rely on outside codecs, and should be able to play your dvds with no problems.

http://www.videolan.org/vlc/


#3

it should but it doesn’t. does that mean that my problem is with the firmware or something? playback on vlc, wmp, and powerdvd are all the same: choppy and makin me sad


#4

Are these commercial DVD’s or copies?


#5

commercial dvds. i wanted to watch the planet earth series but it drives me crazy with all the choppiness. then i put in another real dvd. same problem. what could it be?


#6

Don’t know for sure, but since it affects VLC too, it might be a hardware problem. Try cleaning the lens of the drive.

Check dma status of the drive (though I’m not sure being in pio mode would lead to choppiness in playback). http://club.cdfreaks.com/f61/troubleshooting-enabling-checking-dma-windows-vista-xp-2000-me-9x-101616/


#7

today i was listening to winamp and i put a widows office cd in. when it began to read the disc winamp started to skip. im almost 100% positive it is a related problem. does this help any to diagnose this bullsh!t? my dvd drive is only two years old, dont want to see it go.


#8

im think maybe, because i dont have much on my HDD i might just reformat and reinstall everything. im so desperate


#9

Have you made sure DMA is enabled for your drives, as per Kerry’s post? That sounds like it may be the problem. :wink:


#10

yep. turned both primary and second channels to dma (if available). problem remained. ive notice a base system device on my comp recently. on startup an installer pops up for it. cant seem to uninstall it either.im set on a reformat in near future


#11

It could be a problem with not enough processor power or RAM. You may want to check and see if there are any programs running in the background that take up a lot of CPU processes and/or RAM. I had the same problem for a while. I have vista so i ran task manager and ended the process for stuff I wasn’t using. Not sure how you do that on Linux though.
Hope it helped.


#12

i just reformatted my HDD and reinstalled windows. everything works fine now. i didnt have much on my C: so backing up files was nothing. thanks for the help tho


#13

Glad we could help.