"Illegal Disc" error trying to burn DL

Hello everybody,
I want to burn a DVD+R DL (and this is the first time I do this) but when I load it into the drive after a while it says I have no midia inserted.
The recorder is a NEC ND-6450A and the midia is a Verbatim Double Layer DVD+R 8.5GB. The notebook is an HP Compaq nx6110.
Meanwhile I’ve been looking around this threads and learned that should upgrade the firmware. I’ve falshed the drive - now it’s a ND-6500A with firmware 2.24.
And now the disk is well recognized - good so far.
So I went through ImgBurn to record this disk and when it was starting it gave me the following error: “Failed to write sectors 0-31 - Cannot write medium - Incompatible format”. It’s a movie with Audio_TS and Video_TS folders.
I changed to Nero 7: when it starts recording, the log states illegal disc and the burn fails.
I have set the Book Type to: DVD+R DL and then to DVD-ROM but the result is always the same one way or the other.
I even used MCSE and DVD Identifier to reflash with correct media information extracted from the disc but with no results.
I don’t know what to do more. :sad: Please someone give me a hand.
Any help would be appreciated. Thanks.

Have you tried using Liggy’s Drive Converter to toggle it to an ND-6500?

Thank you so much Tghoang.
Just did it and now it’s burning - hope it ends ok.
I’ll let you know. Thanks once again.

Success!!! Thank you very much Tghoang once again.

Glad it worked for you. BTW, that’s a “Q” in my username. :smiley: