Illegal character in DVD name

vbimport

#1

I tried to make a copy of “Bram Stoker’s Dracula” using DVDFab Platinum 3.0.6.6, but as best as I can determine, the original disc’s name is “SONY<005>”, where the “<005>” represents ASCII control code 005, which MS Windows apparently won’t allow in file or directory names, so it fails.

Does anyone know of a work-around for this problem? If not, can a future release of DVDFab allow overriding the default directory/file names?

Regards,
James


#2

Is that the title that you get when you use Windows Exployer and click on the drive with the DVD in it. Also are you able to try another drive to check if it reads Title Right. What I think you are getting is the drive brand name and firmware edition.

Mack


#3

Actually I think the drive status is what is between the < > as mine Shows up as D:\BenQ 1625 FW# <Idle> when used as target. My source shows as E:\Name_of_Movie which DVDFAB creates a Temp folder. This leads me to beleive that for some reason your drive is not reading the name of the movie. I had to go back and read some old posts that I made in the [B]Read First:[/B] for help thread to jog my memory so cold not add this to my other response.

Mack


#4

Well, apparently I wasn’t clear enough.

In Windows Explorer, the disc shows up as “SONY(D:)”, where “” represents a character that looks like a short, thick, vertical bar, and of course the “(D:)” is for the drive letter. It looks the same on another PC. After copying the disc label from the Windows Explorer “Properties” box to a text editor, I can see that the last “character” is actually an ASCII control code 5.

My DVD drive is an NEC 3540A with firmware revision 1.04, so I don’t expect that that has anything to do with the disc label that I see with Windows Explorer.

With DVDFab Platinum 3.0.6.6, this disc as the source shows up as “D:[SONY]”, with the “” again representing the odd character. Ordinarily, DVDFAb makes a temporary directory named the same as the disc label (often the movie name or similar), but for this disc, MS Windows gives me an error, “Failed to create directory.” “C:\My Documents\DVDFab\Temp\FullDisc\SONY” (substitute “MainMovie”, “Customize”, or “Clone” for “FullDisc” as appropriate, depending on the mode, and of course the odd character for “”).

I expect that the problem is that MS Windows simply won’t accept ASCII control code 5 as a valid character in a file or directory name, and I don’t see any way to change the name from DVDFab. I expect that DVDFab would have basically the same problem for any disc where a character in its label isn’t acceptable to MS Windows in a directory or file name.

Something that would help would be if DVDFab allowed us to override the temporary directory and ISO file names, or changed any “invalid” characters to “valid” characters, or even simply deleted any such characters. But now that I think about it, I wonder what would happen if the disc label were simply left blank; I don’t expect that that would make a valid directory name either.

By the way, DVDFab Platinum 3.0.6.6 does work for me with other DVDs.

Regards,
James


#5

Now that I am home and after doing some research it appears that your drive is not reading the disc that could be due to a bad DVD. <005> from what I have is a hardware bus address. I have 2 drives one is read only E:\ and D:\ is burner. when I start without a disc Fab ask me to choose a drive or image folder If I put a disc in the reader, it will start analyzing the disc when it is finished I see the following:

Source [B]E:[name_of_movie][/B]
Target [B]D:[1:1:0-BENQDVDDDDW1625BBIA (ide)][/B]

I do not know what “[B]1:1:0-[/B]” means, [B]BENQ DVDDD [/B]is brand and type of burner, [B]DW1625[/B] is model number, [B]BBIA[/B] is firmware, and B[/B] is way drive is hooked to motherboard. If I watch while Fab is analyzing I can see “[B]name_of_movie E:[/B]” briefly.

I had a similar problem when DVDFab was in a prerelease beta when I tried to force it to recognize E:[HL-DT-ST-DVD-ROMGDR8164B], I would get same message that you are getting. If your problem is limited to one DVD, I would try to exchange the DVD. If it does not read other DVDs, you are probably in need of doing some computer maintenance which is simple in most cases and I can tell you a few programs to run.

Mack


#6

Well, thanks for your efforts to help, Mack, but you persist in what I believe is a misunderstanding of what the problem is.

MS Windows, for good reasons, imposes certain restrictions on file (and directory) names. For example, the name can’t be over 255 characters, can’t contain the characters , /, :, *, ?, <, >, or |, and apparently can’t contain any of the control codes 0 through 31 (decimal). It might be possible to make names with such “invalid” characters with a disk editor, but ordinarily, the operating system won’t allow them.

DVDFab Platinum 3.0.6.6 and 3.0.7.0, and I guess any of the DVDFab Platinum 3 releases, and perhaps other current DVDFab products, insist on trying to make a temporary directory named the same of the source disc label, and in “Clone” mode, the file names also contain the source disc label, even when that label doesn’t make a valid directory/file name. As expected, this causes MS Windows to error out when trying to create the temporary directory with the invalid name, and as far as I’ve been able to determine, DVDFab Platinum 3 doesn’t give me any option to use a different temporary directory (or for Clone mode, file) name.

I don’t believe that my DVD drive is having any trouble reading this DVD, or that it’s a problem with my PC. Note that other PCs show this disc as having exactly the same label.

Nor do I see reason to think that there’s anything wrong with this disc, unless you count the strange disc label as being a “defect”. This happens to be a double-sided (both sides single-layer) DVD, with the “Wide Screen” version on one side and the “Full Screen” version on the other side. Both sides have exactly the same label; what are the odds of both sides having exactly the same error? I’ve owned this disc long enough that I’m not certain of where I purchased it, and in any case, it plays just fine. Can you imagine asking for a replacement disc on the grounds that this (copy-protected) disc can’t be copied?

I don’t know why this particular disc has such a strange label. It could be that it’s intentional as a rather primitive form of copy-protection. Anyway, with the current release of DVDFab Platinum, it seems to be an effective form of copy-protection.

Anyway, I’ve now made a back-up of this disc using DVDFab Platinum (Gold Mode) 2.9.8.3, so my problems with this particular disc are now solved. The old release changed the label to “SONY_”, that is, it replaced the control code 5 with an underscore character. I suppose that various other work-arounds with other software should be possible.

But shouldn’t we be able to make back-ups of discs with problematic labels with the current release of DVDFab without resorting to work-arounds with old releases or other software?

Regards,
James


#7

A correction:

For one side of this disc, I did the back-up (using release 2.9.8.3) by first writing a “ISO image file” to my hard disk, and then burning that to a DVD-R. For that case, the label was changed from “SONY” to “SONY_”.

For the other side, I used the DVD burner as the target, and for that side the “SONY” label was left as it was.

Regards,
James


#8

Hello James. I have backed up many, many discs where Fab showed something that looks like the character you describe. I never looked at it that closely (and I have to nowadays to be sure) but it sure looked to me like an empty pair of square brackets: []. I have been looking for one of these discs to verify my memory of the display. Could this be what your machine is showing? I am wondering if the empty brackets are Fab’s response to a (windows) illegal file name. If so, you may be right that the module that checks file names for illegal characters needs an update, at least for the title you have. What movie/version/region is it? (PM it to me if you don’t want to post it).


#9

May be Allen will read this thread, I know that he uses usb drives and had a similar problem recognizing DVD titles on usb drives in very early releases of Ver 3.

The old flipper discs, I have one or two and liked the WS on 1 side and FS on the other. Made it easy to copy each format to SL DVDs.

@ signals
Yes the [name_of_movie] does appear in brackets if title is read correctly and when saving Fab just uses what is between the brackets to develop a directory. In this case it reads [B]drive name [[/B] which brackets are not closed changind the illegal chacator simply uses the [B]drive name[/B] as name of movie.

Mack


#10

Hello signals,

No, the “” character certainly isn’t an empty pair of square brackets, it’s an ASCII control code 5 (ENQ or Enquiry), sometimes called a Ctrl-E or ^E. How it’s displayed depends on the character set and font in use; often it will be displayed as an empty square.

Using DVDFab Platinum 3.0.7.0, with my default source and target, the source shows up as:
D:[SONY]
and the target as:
D:[1:0:0-_NEC DVD_RW ND-3540A 1.04 (Scsi)]

I’d guess that an empty pair of brackets for the source would indicate that the DVD doesn’t have a label. Actually, I’m not sure whether that’s possible on a DVD, but it’s certainly possible on a floppy, hard disk, or flash memory device formatted with a FAT file system. Of course a file/directory name has to have at least one character, so an empty label wouldn’t be suitable for a file/directory name either.

Yes, I believe that a future release of DVDFab should be fixed to check that any directory or file names that it tries to write are actually valid for MS Windows and its file systems. Even if my system were misreading the disc label, DVDFab still shouldn’t try to create a directory or file with an invalid name.

That said, I do think that DVDFab is a truly excellent product, even though it’s not quite perfect.

The disc is “BRAM STOKER’S DRACULA”. I’m not sure what you mean by “version”, but it has “Wide Screen” on one side and “Full Screen” on the other, with spoken languages of English, Spanish, and French, and subtitles in Spanish and Korean, and it’s a region 1 DVD. On the back of the case it says: “Columbia Pictures presents an American Zoetrope Osirus production…”. The film was originally released in 1992, and the time-stamps on the disc’s files are 1997-07-28 21:01.

Regards,
James


#11

Well, I still don’t think that my system is having any problem reading the disk label, but rather that the disc label doesn’t happen to make a valid directory or file name, and apparently the current release of DVDFab Platinum doesn’t check that the name is actually valid before trying to create the directory.

For what it’s worth, my drive is connected IDE, not USB.

The old flipper discs, I have one or two and liked the WS on 1 side and FS on the other. Made it easy to copy each format to SL DVDs.

Yes, I rather like that way of doing things. Interestingly, I was surprised to run across one double-sided disc (although I don’t remember which one) that was DL on the “Movie” side and SL on the “Extras” side.

I recently read that some company was planning to produce discs that would be Blu-Ray on one side and HD-DVD on the other, so the customer could play the movie regardless of which player he had. That may be a good plan, but my guess is that players compatible with either format will be the way that it actually shakes out, somewhat like current burners compatible with both DVD-R and DVD+R.

@ signals
Yes the [name_of_movie] does appear in brackets if title is read correctly and when saving Fab just uses what is between the brackets to develop a directory.

Often it’s [name_of_movie], but sometimes it’s something “generic” like [DVD_DISK], or in rare cases something really strange like the [SONY] on the disc that I had a problem with, and I think that I once found one with a “:” in the disc label. What if what’s between the brackets doesn’t happen to make a valid directory name? Shouldn’t DVDFab check that the directory or file name is actually valid before it tries to create the directory or file?

That reminds me; I really don’t appreciate something like “DVD_DISK” for a disk label. I wish that DVDFab 3 would allow the user to specify whichever label he prefers for the target disc.

In this case it reads [B]drive name [[/B] which brackets are not closed changind the illegal chacator simply uses the [B]drive name[/B] as name of movie.

For this particular disc, the [SONY] may well have something to do with the equipment used to produce the disc, but I don’t believe that it has anything to do with the NEC drive in my system.

Regards,
James


#12

Hello James, an interesting case, and I love a good mystery. Fab does do some checking, I believe. There was a post back in October or November that I have been looking for all day where Ting, Fab’s co-Author responded to a similar problem, but I can’t remember the solution. There may have been a fix in the next beta. The problem was not a control code but a printable, but filename disallowed character, in a DVD volume name. Another example of this may be “Murder at 1600”, which shows up as a Fab source as “D:[]” but is re-written to “D:…\DVD_VOLUME” (see below) when Fab writes it to HDD or disc, so there is at least something going on in there that may need updating. I will keep looking for that earlier thread about this and post a link if I can find it. :eek:
All the best
Left image is original disk source, right image is Fab backup disc as source.




#13

Two minutes too late to edit this into earlier post :a . I finally found the posts about filenames. It’s not particularly informative but here is a link anyway FYI. I’ll see what else I can find out.


#14

Hello signals,

It took me a while to find it, but I expect that you’re thinking of posts 38-42 of this thread.

Yes, that’s the same, or at least similar, problem. From the posts, it’s not clear to me whether it was ever fixed. It could be that it’s fixed for the printable characters that aren’t valid in a file name. Indeed, I seem to recall seeing a “:” in the label of a disc that I copied, but I don’t recall whether that was with a DVDFab 29 release or a DVDFab 3 release; note that DVDFab 2.9.8.3 handled my problem disc just fine.

But in addition to certain printable characters not being valid in a name, apparently the ASCII control codes 0 through 31 (decimal) aren’t valid either, and DVDFAb should also check for these in a name. Strangely enough, ASCII control code 127 decimal does seem to be valid in a name.

It’s encouraging that DVDFab apparently at least substitutes a “generic” name for an “Empty” (or perhaps more likely, all spaces) source disc label.

Regards,
James


#15

What I’m hoping is that it also substitutes that generic when it finds illegal characters in the name, which should make it relatively simple to update. Disclaimer: I have not written software since Applesoft came on a 5.25" floppy. :slight_smile:


#16

Yes, substituting that generic name when DVDFab finds anything that would be invalid for a filename would be fine with me, and I suppose that it would be a relatively quick and easy way to fix the problem.

Other possibilities would be substituting a valid character (for example, an underscore) for any characters that wouldn’t be valid in a filename, or prompting the user for a valid name, or even simply allowing the user to specify whichever temporary directory or ISO file name he prefers.

Somewhat related is that, as far as I know, DVDFab always uses the source disc label (if it has one) for the target disc label. That’s okay when the label is something like NAME_OF_MOVIE, but when it’s something generic like DVD_DISC, I’d like an option to change it to whatever the user prefers.

Regards,
James


#17

I do not disagree. This feature has been requested several times in the “Feature Request” thread and will probably show up in a beta at some point. The other behaviour fixes would be nice, too and might show up in conjunction witht he filename function, but for now I suspect it’s cleaner for them to just dump the entire offending volume/file name and substitute the generic (if that in fact is what happens).


#18

James:
Fengtao says this filename problem will be addressed in the next beta release.


#19

Yes, I can confirm that this is fixed in “stable” release 3.0.7.2 of DVDFab Platinum, and presumably DVDFab Gold and Decrypter as well.

My thanks to all involved!

For anyone interested, the volume label “SONY” is changed to just “SONY” for the temporary directory name, and for “Clone” mode or making an ISO image file on the hard disk, the same is true of the file names.

In Clone mode, the “SONY” volume label from the source disc is written as is, “SONY”, on the target disc. In “Full Disc” mode (and, I’d guess, Main Movie, Split, and Customize modes), it’s changed to just “SONY”.

Regards,
James