iHAS220 SmartPack Firmware Upgrade Failed

vbimport

#1

Hello Club MYCE. Here is what happened to my iHAS220 SATA. I tried to update the firmware by going to Liteon US website. I downloaded the SmartPack - Firmware Auto Upgrade Program. It notified a firmware update for my optical drive which I believe was version 8L08. I installed the firmware update but at the end of the process it said “Firmware update failed. Contact your vendor”. I decided to restart the computer thinking everything would be back to normal after a restart. Now it’s not even detected by the BIOS. I know I was stupid.

I tried to fix this thing myself but no luck until now. I tried to revive it with mtkflash, even did the hex edit stuff, it did detect the sata drive but won’t even start the process of flashing. Until I finally revived it using Dosflash32 and the stock 8L08 firmware I got from this site. But the drive’s LED just keeps constantly blinking until this moment. Also, it cannot read any CD or DVD anymore. I tried to reflash it to other firmware versions 8L06 official, patched 8L06 and 8L07 firmwares I got from this site, but still no luck, even when using Flash Utility for Liteon. I also tried to use the EEPROM utility but I always get invalid EEPROM file. Yes i know that was stupid, I forgot to backup my stock EEPROM file before firmware upgrading my optical drive. But I trusted liteon since I used the SmartPack program I got from their website.

I remember the stock firmware of this drive was 8L07. I’m puzzled as of why they have only 8L06N on liteon’s global website. Then from Smartpack program gave me 8L08.

So is anyone here kind enough to share any knowledge of a workaround or fix for this? I’m kind of desperate. I’ve been google-ing for two days but I still can’t find any solution. I already emailed Liteon Support today and still waiting for a reply. Thanks in advance. Have a good day.