iHas124 y Problem

vbimport

#1

okay, i have a dvd burner problem

it’s a lite-on iHAS124. i tried flashing the new firmware but all it said was “Unable to flash firmware. Contact your vendor”.

Now the burner is just constantly flashing, won’t open, device manager says it’s working properly.

what happened and does anyone here know how i can fix this? sorry if this is a common problem. please bare with me.

thanks


#2

Did you try the correct firmware. Sounds like you hosed your drive with the wrong firmware.


#3

http://www.firmwarehq.com/Lite-On/iHAS124/files.html

used BL0X


#4

How is the drive hooked up?
BL0X is the correct firmware for the ‘Y’ drive.


#5

[QUOTE=Daavis;2471673]http://www.firmwarehq.com/Lite-On/iHAS124/files.html

used BL0X[/QUOTE]

That’s certainly not the official Lite-On web site. It’s not even the web site of a trusted CDFreaks member like CodeKing or Liggy&Dee. You shouldn’t download firmware or software from just anywhere.


#6

Yes, you’re completely right. I found out the hard way.

Would it be alright if you could link me to the proper place to download this firmware?

thanks


#7

Official Liteon site :slight_smile:


#8

Daavis
There are two different “versions” of the Lite-On 124. The Lite-On124 Y uses firmware BLOX, and the Lite-On124 A uses firmware BLON. If you have the Lite-On124A and flashed it with BLOX you could have screwed the pooch.
I have a Lite-On124Y. I recently downloaded firmware BLOX from http://www.firmwarehq.com/Lite-On/iHAS124/files.html and flashed my 124Y with it. Worked great. No problems. I think that you may have a 124A. You may need to try firmware BLON. I have read reports of software that can “cure” a “dead” burner and set bitsetting, but I haven’t found a version of the software that will work on my Lite-On124 Y. Maybe there’s a version that will work on your Lite-On124 A. (supposing tthat you have the 124 A). Hope this helps.


#9

Positive that I have the 124Y after looking in device manager to confirm this. I actually got the firmware from that exact site. Is it possible that the drive is just a defect?

Thanks


#10

Have you tried reflashing the drive? Try in safe mode?


#11

Tried it in safe mode, still didn’t work.

Thanks for all your suggestions guys. I’m starting to think I just have a bad drive.


#12

This could still be a problem with your SATA port or SATA driver. The iHAS124 Y is a rebadged Optiarc AD-7240S drive and the blinking LED means that the drive has no valid main firmware (at least if this behaviour doesn’t change after a power cycle)

You might try flashing your drive in a different PC


#13

Hi Liggy,

Same here, flashed with firmware from firmwarehq.com and did not complete leaving me with a green blinking led.
Will try hooked to a different pc and post results.
In case it fails, do you have access to the original firmware BL0W so i can try to flash in DOS with MTKFLASH?
I have not been able to find the original firmware anywhere.

Thanks


#14

Sorry, I only have BL0V and BL0X - I’d like to have BL0W myself but it was not available on a page where all the other firmwares were.

Mtkflash wouldn’t help you at all as this is a drive based on a NEC chipset. You could try using Binflash for flashing/dumping firmwares.

The blinking LED usually means that there’s no valid main firmware on the drive but only the bootcode. The flashing won’t go away until there’s a proper firmware on the drive again. Some chipsets/SATA drivers/whatever sometimes cause problems with the commands that the flasher sends to the drive.


#15

Thanks for the info Liggy, my last option would be to try flashing with binflash under DOS before putting the bricked drive in the bin.
Could youy please point me to where the BL0V, BL0X .bins can be downloaded so I can give it a try?
Thanks again.


#16

[QUOTE=leojosem;2476350]Thanks for the info Liggy, my last option would be to try flashing with binflash under DOS before putting the bricked drive in the bin.[/QUOTE]
If possible you can also try flashing the drive in a different PC or using a Linux live-distro and trying to flash from here.

Could youy please point me to where the BL0V, BL0X .bins can be downloaded so I can give it a try?

I just published all files. Further information can be found in [thread=306268]this thread[/thread].


#17

Liggy,
You are a genius, just to let you know my Liteon iHas124 y-19 is back up and running.
I am not to good with Linux so I flashed it via Hieren’s boot CD under mini windows using the windows gui version of binflash and your BL0X firmware RPC1 without bisetting.
The drive works flawlessly.
Thanks again for your support and for creating the firmwares for us.
Word of advise to everyone out there with same DVD-RW drive !!!DO NOT USE firmwares from FIRMWARE HQ.COM!!! they are not tested and can leave you drive useless like they did mine.
That is why you have various different versions of binflash according to what operative system you are running.

Well done Liggy, keep up the great work.

Leo


#18

Hey Liggy

Just letting you know that this worked wonderfully for me as well. Thank you so much. You’re the best!


#19

I uploaded the BLOW.bin (original firmware) and the fix to restore a bad flash from the BLOX firmware on FirmwareHQ.com at http://forum.digital-digest.com/showthread.php?p=581460#post581460

I can’t upload the BLOW.bin here because of the file size limitation, but if you go the referenced link you will find it there.

Liggy’s BLOX firmware (reliable as usual) works great. Obviously, it’s best to stay away from less trusted firmware sites.


#20

I just checked the BL0X firmware from FirmwareHQ and it’s the same file that PLDS provides. Looks like their flasher doesn’t work perfectly. But it’s at least the same firmware binary that I provide for download on my site.

BL0W will be patched after x-mas.