If-then-else constructie in Excel formule

if (a1 = 1 && b1 = 2)
{
c1 = 1;
}
elsif (a1 = 2 && b1 = 3)
{
c1 = 2;
}

In excel kwam ik voor veld C1 tot zoiets:

=ALS((A1=1)*EN(B1=2);1;*OF(ALS((A1=2)*EN(B1=3);2;999)))

Eerste deel van de if constructie werkt, de rest niet… iemand een idee?

Probleem opgelost:

=ALS(EN(A1=1;B1=2);“1”;ALS(EN(A1=2;B1=3);“2”;ALS(EN(A1=3;B1=4);“3”;ALS(EN(A1=4;B1=5);“4”))))