IE opens very slowly? why?

vbimport

#1

When I click on the Internet explorer icon to open a new window IE just sits there for a while. I can see all the icons but in the window it is all white and takes about 15 seconds for anything to happen. It happens everytime I open a new window. Any suggestions?

I ran spyware and adware programs plus hijackthis but I can’t figure out why it is doing this. It has been doing this for quite a while.

Any help would be appreciated…

Oh my comp specs:
Gateway Notebook
2.2 Ghz P4
512MB RAM
30 HardDrive
Windows XP Home SP2
High speed wireless internet


#2

Have you tried another browser to compare and see if it is the browser itself. I would definitely give Firefox a shot. www.mozilla.org. Do you have an anti-virus program on your PC? (ie Norton) as that would also help.


#3

i have mozilla firefox… but the pages seem to load slower on mff… i have norton antivirus and have checked for viruses and there is nothing… any other ideas? i just like using IE


#4

When you say that firefox loads pages slower, do you mean that it takes longer than 15 seconds to open a web page?

If so, then I think that the issue might be your your ISP. Call them and see if there is a problem affecting other customers in your area.


#5

No no… I experience the delay when I first open IE. After the delay everything works great. Mozilla firefox seems slower at opening pages versus IE. MFF doesn’t have the 15 second delay when I open it.

It seems like IE is trying to connect to or find a different connection(?) type thing?

It doesn’t matter what ISP i use. I tried dailup and wi-fi… both are the same…

I guess I’m just not explaining it correctly


#6

Have you cleared the browser cache lately?


#7

Set your homepage to
about:blank


#8

Try uninstalling both browsers. Then reinstall Internet Explorer. They both might be conflicting with each other.


#9

Try this:

Right click on IE icon, select property, go to “Advanced” tab, scroll down and untick “Enable 3rd party browser extension” or something similar to that as I don’t have an English version IE here. :slight_smile:


#10

I cleared the cache a few days ago… It didn’t help…

How can I uninstall Internet Explorer? I didn’t know that this was possible. And how would I reinstall it?

@Me$$enger I tried your suggestion but it didn’t help. thanks anyways tho~!


#11

go here and download the program.

Before you uninstall, make sure that you download a full version of both browsers first.


#12

could you give me link for IE? thanks~!


#13

www.microsoft.com ? :confused:


#14

You may want to scan your system for spyware. If there’s spyware integrated into IE, it may take some time to load on IE startup (if it hasn’t been loaded on system’s startup of course).


#15

go here for a full version link to IE.

The latest version (6.0sp1) is huge.

I hope that you use broadband. If not then go here and order a cd from M$.

You can’t dowload a full version from M$.


#16

FIXES: Yea…after reading posts dating back to 03 on this Explorer version…whatever…initial delay getting to your first page or initial long wait for Outlook Express to connect, I finally came up with what is really going on here. Task manager says 98% cpu eaten up by svchost “NETWORK SERVICE” , which is the whole tcp/ip hand-shake thing. Come to find out…it’s been looking for a DNS address in some DNS cache before it has a chance to hook up DHCP style instantly… as it should. The “flushdns” command didn’t fix it, however, shutting down the DNS Client did the trick…for me…that is. Your mileage may vary! You can disable the DNS Client in Control Panel, Admin Tools, Services. Select DNS Client, Disable, Stop, then Ok. NOW…Ie7 was supposed to fix this, but the hang-up was happening in my version w/Sp2. This initial delay business has been going on, at least, since the release of ie6 and a hotfix “KB 907455” was made available for those who were so deeply annoyed they couldn’t wait for a service pack. The new ie8 may or may not hang. I just loaded it and so far…so good!


#17

sweetnamja,

Hi my name’s Feran and I am working with the Internet Explorer Outreach Team to help provide assistance to folks about their Internet Explorer.

As revgen suggested you may want to try a reinstall. What IE version are you using? You may want to make sure you are using the latest version is IE8: http://www.microsoft.com/windows/internet-explorer/default.aspx?ocid=ie8_sm_a . IE8 is a faster and more reliable version, installing it mayhelp with some of your issues.

Hope this helps!
Feran


#18

Did anyone notice that this thread is 4 years old?

@[B]Hi-Rez[/B] & [B]feranm_ie8team[/B]: Welcome to CDFreaks! :slight_smile:


#19

[QUOTE=Hi-Rez;2277738]FIXES: Yea…after reading posts dating back to 03 on this Explorer version…whatever…initial delay getting to your first page or initial long wait for Outlook Express to connect, I finally came up with what is really going on here.[/QUOTE]

This seems to be still an issue with IE8 and Windows 7. My guess is that the DNS Client is behaving badly on home networks that don’t have a proper DNS server they could register on. Anyway, by disabling DNS Client from the Services as Hi-Rez explained does the trick.


#21

For anyone experiencing this issue currently with IE8 regardless of OS, try disabling the “Java Plug-In 2 SSV Helper”. This resolved my slow unresponsive browser when opening new tabs, and when opening a new window. Something goofed up in the latest Java update I guess.