Idiots Guide to updating your NEC2500 firmware

vbimport

#1

Here’s an Idiot’s Way of Updating Firmware to your drive:

Well here’s how I did it using WinXP Pro

  1. You must have one floppy disc which has been formatted with the FAT filing system

  2. Go to www.bootdisk.com and download the Dr Dos v7.x boot disc setup file:

http://ftp.sanguine.jp/pub/sahughes...os/drdflash.exe

  1. Once downloaded double click on the setup file and insert the floppy disc to copy the files across. You will find you have two files now on the disc.

  2. Copy over your new firmware an excellent source is right here at:

http://forum.rpc-1.com/dl_firmware.php?category=4&manufactor=23

  1. Download the firmware, extract and add to your floppy disc (sometimes the Dangerous Brothers flasher is included iwth the firmware update- please ensure that it the latest one!)

  2. You should now have 3 files on the disc!!! Make note of the firmware file name

  3. Restart the pc and boot up with the floppy disc

  4. Once you have reached the command prompt ie A:\

  5. Type in the following (This is assuming you have the NEC 2500a set as Master on the Secondary IDE with no other drive attached) :

A:
ec2x00a.exe -sec -mas -flash (file name for the firmware) .bin

  1. The PC will start to read from the floppy and will initiate several commands to update your firmware informing you of it’s completion in percentages.

  2. Restart your PC.

Hope this helps some new owners of this drive, REMEMBER it is really important to backup your current firmware before attempting any firmware updates, well you might have to return your drive at some point!

Here’s the info again if your unsure:

http://forum.cdfreaks.com/showthread.php?s=&threadid=93863

Lastly I would like to thank the members who helped me along this path and hope it’s okay to post the links to the files and the program from the Dangerous Brothers site:

http://www.firmware-flash.com/~tdb/

Please note that I am a member of this Board and not a MOD so if you follow the instructions above you do so at your own risk

Hope that’s covered everything!

Alternatively you could create a folder on your hard disk drive (assuming it’s C:) as NEC2500, which must contain the Dangerous Brothers program, here again:

http://www.firmware-flash.com/~tdb/...re/NEC2X00A.ZIP

  1. Follow step numbers 1, 2, 3, (IGNORE 4), 5 and 6.

  2. Now that you have reached the command prompt a:\

Type in:

c:

  1. To return to the command prompt and then type in:

C:\2500
ec2x00a.exe -sec -mas -flash necstock106( name may differ).BIN

This will go through the same process and write your firmware on your NEC2500a drive.

  1. Once this is completed restart your PC

Thanks Wes for the input!!!

If your operating system is Windows 9x another alternate for the hard drive method for 98 users would be to boot to safe mode command prompt only and not mess with a boot floppy.

  1. Create a folder on yoiur hard disk with the folder nec2500

  2. Include in the folder the flashing program

  3. Restart your pc and boot into safe mode

  4. Once again at the command prompt type in:

C:\2500
ec2x00a.exe -sec -mas -flash necstock106( name may differ).BIN

Thanks dentman for your input!

chrome


#2

it helped :wink: tnx!


#3

Sticking with a Windows based flashing program
Where can I find one that works properly with NEC2500A flashing under Windows XP ?


#4

You can find one of these 107v2b5 from Herrie if you want DL support.

If DL support not necessory 107v2b4 also from Herrie is another choice. :slight_smile: :wink:


#5

I just downloaded the “RPC1, Rip Lock, Bit Setting, 2100@2500 - Binary Only NEC 2500 1.07” I dont really now how to use this BIN. Can anyone teach me how to use it step by step?

One movre questions, How can i do bitsetting afterwards?


#6

This thread can also be viewed on the <a href=“http://club.cdfreaks.com/showthread.php?p=647361#post647361”>Firmware Forum</a>, but I thought it applied here as well, as it concerns the flashing of the NEC 2510A. Please post any help you might contribute in either thread. Thanks! (Paul)


I have my firmware update in C:/Program Files/NEC Firmware/107v2b5d.bin

As far as the flash utility, it was explained to me that the flash utility is the .EXE file packaged with the firmware update .BIN file. Based on that I unpacked the .rar package into my NEC Firmware folder which now contains 107v2b5d.bin and NEC2X00A.EXE. Perhapes I need to be more specific so my PC can find these files, or include the .EXE extension when running the flash command…
My hard drive is the C drive (with the firmware file) and my D drive is the DVD-RW (which I am using for both the bootdisc and subject of the flashing, is that a problem?). I just assumed that I should be in the drive which the DVD-ROM is set to, but I guess that’s why you specify what to flash with -sec -mas.

I just tried both of these commands in DOS while in C:> (hard drive)

nex2x00a -sec -mas -out BACKUP.BIN (backup original firmware)
nec2x00a -sec -mas -flash 107v2b5d.bin

Both resulted in [Bad command or file name].

An interesting thing I just remembered which may be of importance - When in Windows my harddrive is shown as C Drive, and DVD-ROM as D Drive. Now when I entered DOS with the bootup CD it verified my DVD-ROM as the D Drive. However, when I typed
C: [enter]
dir [enter]

I got files which do not resemble anything like my recognizable C Drive. When I typed
D: [enter]
dir [enter]

I got my Program Files folder, Games folder, System folder, ect… which looked exactly like my C Drive. I don’t know why this is or what it may affect, but either way I am unsure where to go from here.


#7

DOS only uses short file names ie Program Files folder will named something like progra~1

Try making a new folder on drive C: call it NEC and copy the BIN and flasher program into that folder and try again.
Also, If your harddrives are formatted as NTFS, DOS doesn’t support NTFS, in which case you’ll need to make a FAT32 partition and flash it from there.

i can’t help but think i’ve seen this question asked by you on another thread?


#8

I appologize for the replicated thread, I noted at the top of my message that I added it here, which was for added support.

I did a little research and found that NTFS is the new standard over FAT32 and I’m running xp, so I believe that is my hard drive format. What would creating a FAT32 partition to use in DOS consist of doing? I have never heard of doing so, and have no knowledge about this. Thanks!


#9

First, crossposting is against the forum rules. :cop: Second, the use of the CD-ROM image suggested in your original thread in the firmware forum solves the NTFS problem, as the CD-ROM image includes a driver that lets you access NTFS paritions from DOS.

Edit by Wesociety: Thread merged with " Idiots Guide to updating your NEC2500 firmware" thread.


#10

helo, sory for my bad english…

the problem is that I have a NEC ND 2500A, and wanted to make it a DL suitable burner.

so, I red a lot of inf in this page, and only thing that i get is - the better way is to flash the firmware in dos mode.

also i got the firmware 2.15vers and interesting soft - bootCD - with wich i can boot in DOS mode. (all the things are gotten from cdfreaks page)

so, thanks a lot, if someone has time to answer to my naive questions:)

Edit by Wesociety: Thread merged with " Idiots Guide to updating your NEC2500 firmware" thread.


#11

Well, I typed your exact subject line into the “search” (the menu on this page) , “how to flash the firmware in dos mode”, and got this:

http://club.cdfreaks.com/showthread.php?t=93873&highlight=flash+firmware+dos+mode


#12

If you go the bootable CD route, and you’re using NTFS, then you can get what you need to make the bootable here: http://www.ntfs.com/boot-disk.htm


#13

This is a great guide!! I need to try it. But first how do I back up my current firmware which is the original nec 2500a. And how do I know if a floppy disc which has been formatted with the FAT filing system. I have windows 2000.
I have an external dual layer burner that should burn both dvd+R and dvd-R. The cd burner part of it works fine but so far every brand blank dvd I put in it says there is no disc in the drive. Even maxwells don’t work. But I was able to use those discs in my stand alone recorder. I just got to get my burner working on my computer.


#14

I have the NEC ND - 2500A (bought under Mad Dog branding) & I started having a problem…whenever I open My Computer this drive says “DVD-RW Drive” but when I put in a data DVD that I burned in this drive, the listing in My Computer changes to “CD Drive” and I can’t ever access the content on the disc…I’ve tried the firmware updates that I could find. I don’t have a floppy drive, so I’ve only used the Windows XP flashers.

Any ideas???


#15

I have a big problem. I flashed my NEC 6650a on my Dell Lattitude d610. Now i does not recognize it anymore. (“the BIOS reports” device could not be identified"). Even booting into DOS doens’t help because, it is also not found there.

Can anyone help me out here?


#16

i’ve tried to follow this guide in an attempt to recover an ND-1300a that was rendered unusable after a bad flash using binflash. (was trying to flash with modded firmware to enable it to burn on 16x media…which i know…is not recommended)

little info about the bad flash:
everything seemed fine until a message about going into safe mode…then binflash froze up and eventually gave me a message saying that the flash had failed due to not being able to come out of safe mode. (it was something to that effect)

now the drive is not recognized by windows or by the bios.

i’ve created a boot flopy disc using the windows xp “create ms-dos boot disc” function.

my computer’s real floppy drive is F’d so i’m using a friends usb floppy drive.
i’ve copied NEC1x00A.EXE and 10cf-t2.bin to the floppy (both files were from the 1300-10cf-t2.rar which was downloaded from: http://www.herrie.org/)

i’ve got the drive jumpered to master and it’s on the secondary IDE channel with no other drives attached.

I’ve managed to get my computer to boot up off the usb floppy drive.

once i’m at the A:\ prompt i’m typing in: nec1x00a -sec -mas -flash 10cf-t2.bin but when i hit enter all i see is:

NEC ND1100A Flash Toolkit, Ver 1.03
Coded by the Dangerous Brothers, Vlad & Igor

a:\

it’s just going back to the a:\ prompt and not doing anything.

so, is the drive just dead as a doornail at this point. I was kind of hopeful when i read that most bad flashes can be recovered from.

any advice or tips would be much appreciated!

Thanks!
–Corey


#17

Tried with binflash/necflash too and what is the dos version?
Run “ver” on prompt.


#18

i used the Dr Dos v7.x created with drdflash.exe just as the guide specified (in a second attempt) at this point it doesn’t matter anymore :slight_smile: my friend and his floppy drive went home and i just bought a new nec 3550a offa newegg (with a big fat stack of 16x verbatim discs) I was sick of my 1300a anyway. I had it since like '03 and it seems like every dvd I burned with it would play all skippy on my dvd players. thanks for the reply though…and this forum is a great resource.

Sincerely,
–Corey


#19

Hi, anyone know if some of the old TDB dos flashers 2x00,5x00 etc can be used for flashing 7170A drive? I have used the Dee’s AD-7170A 1.O4 Modified Firmware and although I was flashing under safe mode I got the checksum error. Tried just about every fw/flasher I could find but none will write sucesfully. It seems maybe the DOS is the only way to restore my drive. The problem also is that all the 7170A firmware seems to have more than 1,44 MB, but maybe I could make a boot flashdisk and update from it. My bios should support it. I read the flashdisk must be formatted to specific format USB-Floppy, USB-HDD etc, so I guess if I just copy the files from the floppy created by drflash it won’t work. Anyone has some thoughts that could help me please?


#20

btw when I tried today the BINFLASH utility (http://binflash.cdfreaks.com/) with the -v option I got this error. Maybe the info will be useful to someone who knows how it works. I have used the original sony 173_rpc1.bin (only bin fw I could find for my drive)
http://img267.imageshack.us/my.php?image=20070718190935hk3.jpg

after sending firmware to 0x1e8000
it says sending checksum f3c5 to drive
Error submitting checksumError while flashing firmware