Identify this physical CD ROM copy protection

I own a CD-ROM containing a motorcycle training course which I would like to copy so I can have it on my laptop (a IBM X31) which has no CR-ROM.

The disc seems to be copy protected but none of the scanners seem to identify the copy protection. Here are the symptoms:

1) If you look on the surface of the disc about 1/3 from the center of the disc is a ring (1.5 mm width) where either no data or some sort of special data is located (see image)

  1. If i insert the disc and run the executable, the program runs normally.
  2. If I try to copy all the files to a folder, after a few files the process hangs on a file. My computer pretty much hangs until I eject the disc.
  3. If I try to create an Iso of the disc, when its gets to about 33% (I assume that’s when it hits the ring from 1 above) it hangs the computer.

What is this copy protection and how do I overcome it so I can use this CD (which I do own) when I’m away from home?

Thanks,
Will

Hi, and welcome to cdfreaks.

Looks similar to ProRing aka RingPROTECH - or maybe it is ProRing :wink:

Try to make an image with Alcohol 52%/120% using the RingPROTECH or RingPROTECH+ profile,
or try with the Automatic Profile of Blindwrite 6.
Then mount your image in the virtual drive of Daemon Tools lite or Alcohol 52%/120% to check whether it works.

Not sure if it was ProRing or not, but your suggestion of using BlindWrite worked a treat. Used the ISO to create an image that works on my X31 without issue.

Thanks for the advice.

Regards,
Will

Just for the sake of completeness.
Now i remember that a ring near the center indicates Laserlock, not RingPROTECH.
Is there a hidden folder on the CD named Laserlok ?

Looked through the CD and did a search (includling hidden files & foleders) and did not coma across any Laserlock/Laserlok folder. So can’t confirm that.

-W

Maybe sysiphus copy protection I had disc with this protection and there was also a small ring but I’m not sure if it was in the first third of the disc and if it has the same size as your ring. You can try this clonecd profile which I used for my sysiphus disc and it worked. Maybe I find the disc I have to search a bit…

[I]edit: I didn’t recognize you already got a working copy so forget about my clonecd advice :doh:[/I]

hmmm Protection ID (latest v6.1.6) should detect sysiphus or ring-protech, try scanning the installation dir on your hd.

Protection ID did not find anything in the install directory on the HD.

However, as I said above, BlindWrite was able to make a working ISO image of the CD-ROM with the following log entries of note during the process:

2009-02-18 16:42:01 Info 14 sectors fixed between LBA 048116 and 048129
2009-02-18 16:41:12 Warning Gap ending LBA 54727
2009-02-18 16:22:49 Warning Possible gap. Starting LBA 48130

Notice the long pause between the warnings (of almost 20 minutes) while BlindWrite worked through the ring of missing data.

-W

Try to recover all data with BadCopyPro and when the program it will try to recover for long time one file, just skip it after 30 sec. Even if you skip the file, BadCopyPro it will create a file and be sure you save it with the regular ones. After this, try to use the program from recovery location.
Surprised?