Ideal DVD Copy 4.0 is released - A NEW GUI

vbimport

#1

Good news, my friends. We finally finished Ideal DVD Copy 4.0. :smiley: This version re-write the core code, so it took us a little longer time than usual to test.

Download link: http://www.idealdvdcopy.com/dvd-copy.htm

What’s new in this version?

  1. A completely new GUI
  2. Improve the copying process. It’s more easier for you to report a new dvd to us.
  3. Embeded ImgBurn burning engine
  4. Solved blu-screen and crash issue when launching on some laptops
  5. Fixed camera icon issue of the dvds with multple angles, like UP
  6. Fixed the issue that can’t recognize dvd drive whose volume is A or B
  7. Added check for new version function.

    8.Added disc label and number of copies in the main form, it’s more easy for you to rename the copied dvd and make multiple copies.
    9.Prevent system from going into sleep mode while burning to save your blank dvd.
    9.Some minor fixes and improvements

#2

That looks excellent moonlight79 and I’ll test that out as soon as I can.

Thanks for listening to the comments I’d made both in the review and here in the forums. :flower:

I’m sure ImgBurn support in particular will be welcomed by many.

[B]Wombler[/B]


#3

Thanks, Wombler :flower:

Yes, we know ImgBurn is a great freeware, but we never thought of embedding it in our program until you suggested it in your review.:wink:


#4

Thanks Moonlight79 :flower:


#5

That’s a nice improvement. :iagree: :clap:

I always liked the clean simple interface but changing to the more standard minimise and close has simplified things even further and I like the way you’ve moved the shutdown option to the main interface.

ImgBurn seems to work perfectly too.

One small display glitch though.

If a user changes the skin to ‘none’ then there aren’t any icon graphics shown.

I’m a beta tester for other programs so I do tend to play around with all the settings. :slight_smile:

[B]Wombler[/B]



#6

Yes, I noticed this problem. With the none skin, we just used the button with text, but not graphic. I’ll consult with my pogrammer to see if he can use graphic icon. Thanks. :flower:


#7

[QUOTE=Moonlight79;2626340]Yes, I noticed this problem. With the none skin, we just used the button with text, but not graphic. I’ll consult with my pogrammer to see if he can use graphic icon. Thanks. :flower:[/QUOTE]

No problem. :flower:

It’s not really an issue for normal users as you have to mess around with the settings to get it to appear.

Just thought I’d report it though. :slight_smile:

[B]Wombler[/B]