IDE Controllers (The definitive Thread )

vbimport

#221

As a followup to my prior question, I’ve now put two SiI0680 cards in the same system and (unlike Promise) they work fine together. Well, almost.

In one system, after the first card displays it’s “Hit F3 to configure” and finishes detection, the 2nd card in turn does it’s “Hit F3 to configure”, and detection. System bios shows both items in the boot list.

In a different system, only one card brings up the “Hit F3…” and detection and if you have a boot drive it must be attached to that card. The ordering of cards depending on which PCI slot they were in. In this same system I had formerly tried using one SiI0680 and one FastTrack100 and the FastTrack100 wasn’t usable at all.

On either system, all drives connected to both cards were visible and usable, and in the Silicon Image Raid manager, one is shown as “-0” and the other “-1” and both handled properly by the Raid Manager software, tested while both cards had RAID1 arrays running, I’d presume RAID0 should work also.

Just for kicks I tried to create an array with one drive on one card and the other member of same array on the other card (array was created on one card alone then one of the drives moved to the second card). I expected it wouldn’t work but figured what the heck and tried it- it didn’t work, I had Autorebuild enabled so they started rebuilding till I powered off, switched them back and had them rebuild as they should be.

So anyway, it seems at least two SiI0680 cards can be used simultaneously, at least on the two systems I tried.


#222

It was my understanding that all drivers for the 64bit version of Vista have to signed my MS. No so for the 32bit edition. Is this correct?


#223

Well I haven’t tried the 32 bit so can’t answer.
But I can tell all of you that the [B]non-Raid[/B] bios [B]works fine[/B] with the [B]Raid[/B] driver for Vista.
The [B]Non-Raid[/B] bios [B]does not[/B] work with the [B]non-Raid[/B] driver in VISTA


#224

Hi everybody,
I’m new on Club CD Freaks, and have to thank you a lot:
your thread allowed me to install my Ite W-8212 ATA card (+++ with the various versions of Flash Utility and BIOS listed by Engine).
But my old Dell GX1 has some problem with ATA133. Is there no mean to ‘force’ ATA100 for the Ite controller card? Or for a Hitachi ATA133 hard disk (the ‘Hitachi Feature Tool’ dskt gives me “Error” if I try to downgrade ATA from 133 to 100) ?
Thank you again for your attention.

Gargamel29


#225

I had today a solution, ‘forcing’ ATA100 for my new drive ATA133.
The Hitachi ‘Feature Tool’ couldn’t modify the default setting (ATA133) because the drive was connected to the Ite PCI card (ATA133 controller).- The Feature Tool working in DOS, I tried connecting that new drive (alone) to the IDE1 port of the motherboard, using an old ATA33 cable -> Bingo ! The drive was configured in ATA100 by Feature Tool without a problem.
Re-connected to the Ite card with 80wire cables, the two drives are now working in ATA100, OK, and as a test I copy a 700M AVI file from one to the other (or from the other to the one) in 28 to 30 sec.- HDTune shows a very good improvement.
A detail I don’t know well: is it better to connect each drive as Master to Primary and Secondary ports of the PCI ATA-card; or to connect them as Master + Slave (but ‘cable select’), using the same 80wire cable, to Primary port only ?
Thank you for your attention. Maybe that will help another !

Gargamel


#226

Hello all,
I have a gigabyte DS4 which has one IDE channel provided by a JMicron 363. Gigabyte doesn’t say it’s a JMicron and even labels the chip as Gigabyte, but it’s actually a JMB363.
I have a Liteon 16H5S set as master, and a NEC 3500 set as slave. I’m using the latest (beta) drivers from JMicron v1.17.04.00, but the results are the same even if I uninstall the JMicron drivers and use the IDE controller with the default Windows driver.

Both drives work fine at reading disks. The liteon does error scanning just fine. But when I try to write (Nero 6.6.1.4) only the NEC works. The liteon gives an error “DMA-driver error, CRC error”.
As both drives are recognized as SCSI with the JMicron driver there is no DMA option to check. When I uninstall the driver and use the default windows driver the drives are recognized as IDE and then DMA is enabled on both drives, but the Liteon still can’t write.

Even if I set the Liteon as slave and the NEC as master I still get the same problem. The Liteon can read, scan, simulate cd burning, but can’t burn dvds.

I’ve read about other people having trouble with the JMicron crap, but most report that their problems were solved with the beta JMicron driver.
It goes without saying that I’m using all the latest firmwares and drivers for everything. The cable and the liteon worked fine on my previous pc. I also tried to use the driver that gigabyte gives for the JMicorn controller, but it’s even worse than the beta driver I’m using now.


#227

I have the mainboard s3 gigabyte one ide controller :doh: and i want to buy one to support optical. It some available in online shop?


#228

Promise LIES.

I checked out their website and it was stated in their product documentation that their IDE controller card supported ATAPI. They lied.

I ordered a Promise Ultra133 TX2 from NCIX for $80 CAD, it took almost 3 weeks to get it since it was special order. When I finally got it, I plugged in my two Pioneer DVR-111Ds, which were recognized, tried to burn with Nero… and CRASH.

I checked the firmware versions of the card, the drives, checked all my drivers to make sure they were up to date, include the Promise driver. And still… CRASH.

I gave up, sent it back to NCIX for a refund.

Promise LIED.


#229

I heard that maybe some optical drives work with it, but other not. Dunno with which drives it works


#230

Since I’ve used Promise PCI ATA66, and 133 Ultra (not FastTrack which doesn’t support ATAPI) with burners, I can confirm they are supported. IIRC (I may not), the burners I’d used were Liteon and BenQ CDRW (48-52?) and NEC 35(40?).

I’d more likely suspect a flaky or overloaded PCI bus, or the burner software.


#231

There is a new siI0680 Bios out

http://www.siliconimage.com/support/supportsearchresults.aspx?pid=31&cid=15&ctid=2&osid=0&

III. Corrections

  1. Resolved boot failure for RAID volumes beyond 1TB.

  2. Resolved “Press F3 to enter RAID utility” message missing during boot.

  3. Resolved Blu-ray DVD detection issue.

  4. Expanded BIOS function to support BOOT from an ODD on the secondary channel when an ODD is also present on the primary channel.

  5. For a setup with 4 ODDs attached to the SiI0680, corrected device description string displayed at POST for the ODD attached to the secondary channel as a slave.

  6. For a system with a bootable HDD attached to an alternate controller, corrected device enumeration to ensure the system will display “Press any key to boot from CD…” for a bootable media in an ODD attached to the SiI0680.

  7. To avoid delays during POST, SiI0680 BIOS will check for device type and will not request metadata for ODD devices.


#232

I’ve installed an IDE card based on the SiL680 chip. Its running with XP and it automatically installed the driver for the RAID version. It will not install the non-RAID driver regardless of how many times I uninstall it and reinstall it, and I have offered it a CD containing only the non-RAID driver, which it does not accept.

It will run one CD drive at one time in its RAID mode but not two - either on the same IDE channel or split between channels - taking due care of the drive master/slave jumpers. If two CD drives are connected it simply hangs up early in the boot sequence.

I have read in a web posting that there is a jumper on the card (JP1) which dictates whether it operates in RAID (closed) or non-RAID (open). My card doesn’t have a jumper but does have a wire link labelled JP1. The posting suggested that cutting this JP1 link would cause the card to operate as a non-RAID IDE controller. I beieve these cards are generic and sold under many different brands so a solution would probably help a lot of people.

I don’t mind damaging a £12 card, but I would mind a lot if it damaged my motherboard - does anyone have experience of cutting this JP1 link?

(I also posted this on another thread that seemed to deal with this issue)


#233

Just flash it with the non-raid bios (that’s what i did) if your card is flashable ofcourse as some apparently are not


#234

OK, I’ve been battling the 680 controller issue for a couple weeks and last night I finally hit the “Eureka” on my system.

I’ve got my main system pretty loaded up - 7 DVD burners (Lite-On SOHW-1693S), six hard drives, and a few other goodies all hooked up to a Gigabyte GA8-KNXP Ultra 64 in a Lian Li V2000B case with a 3.2 gig P4 Prescott (not OC’d) and 2 gigs of Corsair XMS memory. The maddening thing is that it had all been working perfectly until a few weeks ago when I had to reinstall XP after one of my raided boot drives started getting flakey. On a positive note, I lost not one bit of data (I was able to back up all my user files prior to a complete meltdown), but after I reinstalled Windows the system would not boot with the 680 card installed if an optical drive was hooked up to it. It would boot fine as long as nothing was hooked up to the card, but that’s a little pointless isn’t it? NOTHING HAD CHANGED EXCEPT A NEW HARD DRIVE AND AN XP REINSTALL! So why did it work before but not now???

I tried updating the driver (and using older drivers, too), tried flashing to the latest firmware (and 3.2.10 which someone else said worked, but didn’t), tried changing slots, etc. The Gigabyte Ultra 64 includes a Silicon Image 3114 four channel SATA controller onboard which I run four 300 gig drives on for professional, uncompressed video as well as an Adaptec/Hance Rapids dual channel sata raid controller which I run two 200 gig drives on for system and low-bandwidth data, though in a pinch they’re fast enough for the pro video, too. Besides that the mobo has two regular PATA channels which I run four of the DVD burners on.

The very latest firmware (3.2.20) would cause the computer to freeze as soon as it finished booting through the various bios. Someone else had suggested 3.2.10, but it did the same thing. I tried all the different drivers, but I was pretty convinced that since it was crapping out before it even started booting into XP that it wasn’t a driver issue, at least not by itself.

So the trick: Bios 3.2.13!!! 3.2.13 plays perfectly with the embedded controllers and the system is once again EXTREMELY stable!!! (Yeah - happy dance!!!) I’m using the latest 680 driver from the Silicon Image site (1.2.25.1). The device manager shows all three controllers (the embedded Adaptec and 3114 controllers and the 680 card) under “SCSI and RAID controllers” and has the option for flashing the 680 right in the properties manager as someone else noticed earlier. The card can also be flashed from the control panel applet. The card itself is a Siig SC-PE4B12, though I don’t know why it wouldn’t work with other vendors 680 based cards.

The only quirk (and this one’s minor) is that during the 680’s bios boot it doesn’t indicate that anything is hooked up to the card. Firmware 3.2.20 would show the three DVD burners I have hooked up to the card during the bios device detection, but I’ll take the firmware that actually allows my computer to boot rather than the one that teases me by showing me which optical drives I won’t be using along with the rest of my system.

I had tried a Promise controller (TX2 I think) before the 680 when I first built this system a couple years ago, but the Promise didn’t work at all for DVD burning. Also, even with (at the time) a really powerful system you can’t burn with all 7 burners at anything more than 6x, though when I’m using all seven burners to burn DVDs for clients I use 4x anyway to get better quality burns. If I choose to burn at 16x I can use up to three burners. It doesn’t seem to matter much which three. Up to 6x I can use all 7. BTW, I payed $250 to Nero for a serial number that will allow burning to 7 drives at once - the regular version is limited to either two or four burners.

One other thing: Just as before, the three burners hooked up to the 680 show up in the device manager-DVD/CD-ROM drives as “LITE-ON DVDRW SOHW-1693S SCSI CdRom Devices” while the other four just show up as “LITE-ON DVDRW SOHW-1693S.” Evidently the 680 looks like a SCSI controller to Windows so it makes sense that XP thinks the drives hooked up to it are SCSI also.

I spent so much time researching and fighting this that I thought it only fair that I post the solution that worked for me. I’ve read through all 10 pages of this thread several times, as well as “using the Googler” to search for ANYTHING that might help. I was about at the point of pulling out the 680 and the three burners hooked up to it and calling it a day when I had a “Goldilocks” idea: Don’t use the newest firmware, don’t use the oldest, use one between the two. 13 is now my lucky number.


#235

Hi everyone,
I have the SiI 0680 ATA133 Controller, and am also getting hangs at boot whenever I have ANY ATAPI devices attached. My motherboard only has one IDE plug (for 2 devices), and I have 6 optical drives which I wish to get working. The only way the computer will boot is if I disconnect all the drives from the card, and have only the 2 plugged into the motherboard.
My card currently has BIOS version 3.2.10, and I am unable to update it as I have no floppy drive in this computer. I noticed the gentleman a page ago had an option to update the BIOS of his card from device manager, but no such luck for me, as I only have the standard 4 tabs for this device, and I have tried both of the driver versions available on the SiI website.
Can anyone help me get this working? (Why on Earth can’t these filthy rich companies write an update utility that works in windows, or AT LEAST ship the card with a BIOS that works properly). Thanks.


#236

OK, I yanked a floppy drive out of my other computer and flashed the BIOS to 3.2.13, so it’s now booting into Windows. I have now encountered a new problem, only 2 of the 4 devices are being recognised (the master on each channel). What the? Anyone have any ideas on why the slaves aren’t being picked up by windows? as this new firmware no longer displays it’s optical devices on POST, I don’t know what’s going on with the device. Any suggestions?


#237

FWIW I have three Lite-On 1693s hooked up to the 680 along with four more on the two PATA mobo connectors and they are all detected and work fine. I haven’t had a reason to hook up four optical drives to the 680 as my case only holds seven total and that’s what’s hooked up now between the three on the 680 and the four on the mobo. If I get adventurous over the weekend I’ll try switching one of the slave drives from the mobo to the 680 and see what it does, but I suspect it’ll work.

Along with the 3.2.13 bios make sure you’re running fairly recent drivers, too. I’m running 1.2.25.1, dated 7/14/06.

One last thing - it’s obvious and I hate to say it, but I’ve often overlooked simple solutions while assuming something more complicated is wrong: Double check your master/slave jumpers on all the drives and perhaps try swapping out the IDE cables. I’ve never used the “Cable Select” jumper for anything and have always preferred to manually select master and slaves drives so I know for certain that the m/s selection is correct. Also, try swapping the power leads. If seen some molex connectors allow a pin to come lose and partially back out of the connector. At a quick glance it looks like everything is fine, but on closer examination one of the pins has backed out and you see a little bit of silver from the pin poking out from under the molex hood.

Also, try flip-flopping the m/s between the two sets of drives (switch the ones that are currently jumpered as master to slave and vice versa). See if they all disappear or if you still have access to the two drives that are set as master (or maybe you’ll really luck out and all four will appear!).

I assume you’ve tried running the 680 in a different slot, but if you haven’t give that a shot. Once again, its unlikely that’s the problem since you’re seeing 680 with two drives connected and a PCI slot issue typically is a go/no go situation, but maybe this one has a more “colorful” glitch.

Honestly, if you don’t have the tab on the device properties to flash the card I really suspect a driver issue. Check your control panel applets, too. Under control panel I have an applet called “Silicon Image SATA controllers”. Yes, I know it’s not a SATA controller, but it still shows up there along with the onboard 3114 (which IS a SATA controller), with one tab for device info for each connected drive along with another tab labeled “Flash BIOS.”

Another possibility is to make sure your optical drives are running current firmware, but I seriously doubt that’s the problem.

If you’re detecting any drives at all through the 680 it sounds like you’re headed in the right direction. My bet is on a driver issue.

Good luck.


#238

Is there an inexpensive PCI SATA controller that handles hard drives well? I currently have a Promise sata150 tx2plus. It does okay with my hard drives but it won’t allow me to monitor their health. No S.M.A.R.T., no temperature, and no drive self test.

One good thing about this controller is that I don’t have to install a driver. Apparently XP has one.


#239

Hi, this is an excellent thread, I am making a post to help anyone in my situation.

Motherboard: ABIT AV8 3rd Eye (K8T800 Pro) (bios v27)

My card was a Koutec PIR133 from newegg which looked like a sil0680 version 2 reference design… Have seen cards from other vendors that looked exactly the same.

Anyway, it came with firmware 3210 which worked okay with hard drives attached, but would crash the system hard when querying SMART data from Windows. With a CD/DVD drive attached the system was completely unbootable. I tried some firmware upgrades a while ago but could not get it to work, finally with version 3224 it is working correctly with a DVD drive attached, and the drive is bootable! I have not checked the SMART crashing problem yet.

Anyway thanks to everyone who has posted and good luck; by the way this link with old bioses is still working:

http://bichon65.free.fr/Bios%20Silicon%20Image%200680/


#240

Thanks for replying Uschintsky.
The driver version being used is 1.2.26.0.
I tried switching the PCI slot, but as expected, no difference.
The power plugs aren’t a problem, as whenever any given drive is set to master, it works fine, whenever it is set to slave, it isn’t picked up at all (therefore, I can get all the drives to work, just not all at the same time, as I can obviously only have 1 master on any given channel). I have updated all the drives to firmware version 1.29 (the newest one), but no difference again. It just seems to be stupidity on the part of the card. I cannot fathom why it doesn’t like drives set to slave. It seems to pick up all four drives no problem with all other firmware versions, it just won’t boot with them. This would all be fine if my motherboard had 2 IDE channels, but it only has one, so I need to use 4 on the card. Also, I have tried the app in the control panel, but it seems to have the same tabs as the one opened up from the device manager. Thanks again to anyone with any ideas on what to try next.