IDE channel wierdness

my laptop (acer travelmate 8104 - winXPpro) has a flaky DVD drive (HL-DT-ST DVDRAM GMA-4080N.) When I go into device manager and set the secondary IDE channel to DMA mode (DMA if available - it chooses Ultra DMA Mode 2) it usually refuses to read any disc in the drive. all that happens when i put a disc in the drive is that the “DVDRAM Drive (E:)” in My Computer changes to “CD Drive (E:)” but I am unable to see/access any of the disc’s contents. This happens with any type of disc including CD-ROM, CD-RW, DVD±R DVDvideo etc etc. However when I set the set the secondary IDE channel to PIO only it works normally, but this is very slow and eats all my CPU time so everything else on the computer is slow too. I ran the factory re-initialise discs the format the hdd and reinstall windows/drivers etc and the problem is still there, and it seems the default mode for this system is DMA. This tells me it’s either a hardware problem or there’s something wrong with those discs. I sent the computer in for warranty repair, and they replaced the DVD drive. The problem was fixed for about a day, then came back. On the rare occaision when it will read a disc while in DMA mode I get a lot of I/O errors.

So my question is - is there anything in software that could cause this, or is it definitely a hardware issue?

thanks,
Jeff

i’ve seen a BIOS update fix your problem on other PCs. worth a try. go to acer and look for your laptop’s model/download section etc. could be other reasons too many to list. try my troubleshooter below

hmm, my bios is version 3c17.last time i checked it was the newest. now theres a 3c22, so i’ll try that.

thanx
j

i updated the bios to version 3c22. no improvement.
i noticed when un/re-installing the secondary ide channel, that on the fisrt restart i got an interesting error message, as follows:
"Found New Hardware Wizard

cannot install this hardware

there was a problem installing this hardware
IDE channel

An error occurred during the installation of the device

Driver is not intended for this platform"

any new ideas?

you may need to install motherboard chipset drivers. get them from acer or cd that came with notebook. use Everest home edition to find out the chipset on your mobo, if you do not know - usually they will Intel, nVidia nForce, VIA, SiS etc

OK got chipset drivers from Acer website. No improvement. then tried chipset drivers from Intel website. Still no improvement.

whats next?

Ok, so I was playing around in device manager fiddling with everthing that looked vaguely relevant, and i tried to update the driver for the DVD drive. Windows gave me alist of drivers to choose from and I chose one called “CDROM drive (force imapi disabled)” and now it seems to work. :-):-):-):-):-):slight_smile:
maybe burning doesn’t work now. i’ll hafta check it out…

and just as mysteriously it’s stopped working again…

For proper DVD burning without DVD burning software conflicts, you should be using Xp’s native ide drivers, I don’t know what you have. If I were you I would go into device manager, select your ide channel that you know your burner is on and uninstall it, then reboot. On the reboot XP should install the Microsoft drivers for it. If you are unsure of what channel your burner is on, download Nero Info Tool v 3.01 and it will indicate what’s on each ide channel.

Get it here: scroll downto NeroInfo Tool> http://www.cdspeed2000.com/go.php3?link=download.html

To check, go into device manager and click on the driver tab as illustrated in the first attachment.
The driver should look like what is dispalyed in the second attachment.

Hope this helps in some way.



yeah, thanks, I tried that a bunch of times already. didn’t help. I’ve handed the thing over to Acer again to see if they can fix it properly this time.

wish me luck!!!

Jeff