Ide-cdrom driver Centos 4.2

vbimport

#1

I use Centos 4.2 (clone built from source RPMs of RedHat
Enterprise 4) on my Linux IA-32 laptop that has a removable bay CD-ROM reader/writer (that can be replaced with various things, including a ZIP drive). XCDroast has no problem finding the drive that is mapped as a SCSI unit via ide-scsi that is loaded into the kernel; I checked that ide-scsi is present in the kernel via lsmod.

However, nero will not activate because it “refuses” to use the “buggy” ide-scsi kernel module and insists upon ide-cdrom . There are other applications besides XCDroast that expect the CD reader/writer on a SCSI device (sg0 as it turns out). I have been unable to locate the ide-cdrom module for Centos 4.2 (currently kernel 2.6.9-34.EL).

Is there any way to force Nero to use the same kernel module driver that other applications are willing to use?
If not, where does one get the appropriate module for this kernel and how does one trick other applications to use ide-cdrom when these are expecting ide-scsi? At the moment, although I have licensed NeroLinux for fee, it is worthless without this problem being solved. Thanks for any help.


#2

There is no way to get NeroLINUX working with ide-scsi and a 2.6 kernel. You should check your kernel configuration to see if ide-cdrom is not directly compiled in the kernel (have a look in the boot subdir to check the configuration).


#3

Although there is no ide-cdrom is /lib/modules/xxx where xxx is the path for this kernel, there was evidence for ide-cdrom in /boot/System-map-2.6.9-34.EL . I modified both the grub configuration file and /etc/lilo.conf with vi (a plain ASCII text editor), as I use lilo to boot.
The modification was replacement of hdb=ide-scsi by hdb=ide-cdrom in the append stanza for this kernel.

This worked and Nero seems to see the drive (correctly identifying the Toshiba model number as seen in the kernel table and by xcdroast). Moreover, when Nero is not in use, the regular CD-ROM automounter works and I can read CD-ROMs from the same drive.

However, none of the other devices for this removable bay seem to work; in particular, the Zip drive is no longer recognized, in part because the Zip is not an ISO-9660 file system but rather a MS file system recognized by linux. Do you know of a fix for this issue? Do I need to change the lilo.conf stanza each time to get different devices to work, then run lilo, and then reboot?

Thanks.

Yasha Karant


#4

This would be rather complicated… I think I read somewhere that you could change dynamically the driver for a device, but I cannot remember how. Have a look to the HOWTOs of your Linux system. Maybe this will help!