IDE ATA/ATAPI Controllers

Glad to find a newbie forum because I need very basic help!
In Device Manager, I see that Primary IDE Channel and Secondary IDE Channel, as well as SCSI/RAID Controller have that yellow exclaimation point on them, which I know is not good. I have tried all troubleshooting and do not know how to correct.
The reason that I even went to device manager is because the CD/DVD drive (removable bay for laptop) suddenly is not being recognized and the PC card slot will not work either. Seems that problem came up after doing a Windows Update (XP).
Any insight on the problems welcome! Thanks! :confused:

Welcome to the madness. While in Device Manager have you tried right clicking on them and updating the driver? Did you reboot since the XP update?

Thanks for suggestions, however…
I have done the “update driver” thing. It goes through the search for driver and then says that it finds no driver better than what I have. (paraphrased)
The XP update that seemed to mess things up was done months ago and I am still struggling with solutions to these problems…

Have you tried uninstalling them and allowing Windows to reinstall the problem devices?

Are you asking if I have tried uninstalling the drivers for the devices?

I did try that.

In “System Information” I found this stuff. Does any of this shed any light on the problem?----
Primary IDE Channel
PCIIDE\IDECHANNEL\4&CB9060A&0&0
This device cannot find enough free resources that it can use.

Name Primary IDE Channel
Manufacturer (Standard IDE ATA/ATAPI controllers)
Status Error
PNP Device ID PCIIDE\IDECHANNEL\4&CB9060A&0&0
I/O Port 0x000001F0-0x000001F7
I/O Port 0x000003F6-0x000003F6
IRQ Channel IRQ 14
Driver c:\winnt\system32\drivers\atapi.sys (5.1.2600.2180 (xpsp_sp2_rtm.040803-2158), 93.13 KB (95,360 bytes), 10/3/2001 9:02 AM)

Error message on Secondary IDE is the same as one on Primary. Error message on SCSI/RAID Host Controller says This device cannot start.


eeeeeeeeeeeeeek - is it possible for a newbie to solve this? :doh:

Have you tried system restore? And have you tried to put in your driver disc that came with your Motherboard and or your computer? Put the disc in and go to device manager and click on update driver. That has always worked for me when i got them damn yellow boxes. :a

What version of XP have you got? has it got sp1 as part? if not try instaling it, either from disc, or from MS web site. this is a common cause of cd/dvd drives or ide channels not being found, also with some early modems, not having sp1 used to crash the system.

try and uninstall/delete the actual IDE channels, reboot and see if windows reinstalls it’s generic drivers for them.

I have XP Home Version that was updated with SP1 and SP2. Always do the recommended Microsoft updates. Unable to do anything with the CD-rom drive…Thanks for trying to help…

I will try this later today…thanks.

You need to go through the following sequence, up to and including point #4:

Then you have a choice: either renavigate back and select point #5 (Scan for hardware changes), or as Nemesis01 says, restart the PC and let it find the hardware during that process. Certainly if the first suggestion doesn’t work, then try the restart.

Thanks for everyone’s suggestions so far.
I uninstalled the Primary and Secondary IDE channels. Then I rebooted. The system did find the hardware and install drivers etc. Then had to reboot again. This did accomplish one thing for me: Now the computer recognizes that the CD drive exists. However, it still will not recognize when a CD or a DVD is in it, so I cannot play them. I tried updating driver, uninstalling drive - but still cannot get drive to work.
The drive is named in Device Manager: TEAC DV-28E-A SCSI CdRom Device.

Does anyone have any ideas what to do since the computer troubleshooter is not any help either?

Well i would have to say that maybe your drive took a dump on you. Do you have another drive you could try? If not you could buy one and if that doesn’t solve the problem you can return it. But it sounds like to me your drive is toast. :sad:

I was wondering if a toasted drive was a possibility. My computer is a laptop with swap bay (swap to floppy drive). This means that I would have to replace it with the swapping type of drive… :frowning: Thanks for the advice. Maybe it is time to replace 2001 laptop…

this has been up before in another thread, same thing happened to me and others, my problem was that I instaled Norton AV, and for some reason the same happened, I tried the same as you including sys restore, the only option I had was to reinstall windows, that worked.