IDE #1 Error

vbimport

#1

I just tried to install a Sony AW-G540A onto my Toshiba Satelitte A-15-S157. Everything seems to match up just fine until I put it all together and start it up. When it starts the booting process I can see the light flicker on the unit as it tries to make it work but then I just get the message “IDE #1 Error”. Windows then continues to boot but doesn’t recognize the drive in any manner or fasion. I looked aroud for any thing involving the drive on the net as far as firmware, drivers and the like or even suggestions but even sony’s own website doesn’t even list this product.
Im not completely sure that this drive is compatable with my laptop so returning it is always an option. I just would rather know for sure before I go through the process of getting an RMA and shipping it back. Any help would be much appreciated… Thanks. Oh and the old drive was a Tecra “teac dw-224e-at4”


#2

Did you make sure there is a firm connection between the drive and cable? Also did you make sure you have the jumpers set correctly? How many flickers does it do and does it make any beeps? As those flashes and beep indicates what kinda problem is occuring. Sound like a connection between the drive and connectors aren’t making connection?


#3

Are you sure your new drive is compatible with your notebook?
When it comes to laptops, CD/DVD drives must be in accordance to the host design, and some require the drive to be a “master” and others a “slave”, and sometimes contrary to desktops this it is defined by the firmware not a matter of switches.
You may be experiencing a sort of problem like this - your IDE connector is expecting something different and returns an error message.
Just a guess…


#4

CoolColors- Well Im fairly sure that the connection is firm… although it doesn’t seem to fit as tight as the old drive it is in the slot as far as it will go… and due to the light flashing I was just assuming it was getting connection. There are no visible jumpers on the drive and I am reluctant to take it apart to see if there are any inside the device. Ill try to restart it here and get back to you on the beeps if any and the flickers.

agomes- Well unfortunatly Im not completely sure that it is comptable with my Laptop… the spec information I can seem to retrieve from toshiba and the site with the most spec information on the drive really dont seem to tell me much or perhaps it is because I don’t know what I am supposed to be looking for. I have read a little on the slave master system but I don’t really know which my computer needs, or how to tell which a drive is when I am purchasing it for that matter. There is supposed to be some indication on the spec information for the device but I can’t seem to find it anywhere.


#5

“IDE #1 Error” means that the drive has a wrong firmware for how its connected.


#6

OK… so I went and found the firmware for it… and downloaded binflash. Unfortunatly because it doesnt recognize it in windows I am not sure how to take it any further.


#7

I’m going to ask a stupid question 'cos I have no experience of such a change on laptop.

Does replacing a CD-RW/DVD-ROM by a DVD-RW actually work?

Might it be necessary to do something in the BIOS for this as well?

Actually that’s 2 questions.


#8

Either you IDE in your “Motherboard” is gone bad or the connect (cable) from IDE to the drive is bad.


#9

Well I don’t know that something is wrong with the ide port or cable because the original drive works just fine. Im just trying to upgrade to something that will burn dvd’s… though I suppose I should have asked whether that is even possible as TIMC brought up. Chef said firmware but I dont know how to flash new firmware when I cant get windows to even recognize the drive. Im quite new to this whole thing I have to admit.


#10

If the original works fine there is nothing wrong with your IDE connector.
chef told you that there is a formware problem, and I think I ave you an indication before, because connecting new drives to a laptop it is not just like to a desktop.
Laptops come with preconfigured things and one of them can be the CD or DVD drive status, and drives for laptops sometimes don’t have the pins to define such a status and this one is determined by the firmware.
This meaning the firmware tells the drive to act as main or slave.
Some brands allow this to be flash again others don’t - to be honnest don’t know neither your drive nor yout Tosh.
By your indications you are not confortable about flashing firmware - it ca be done using DOS or windows - the better would be you to ask your drive supplier how to install the drive in your notebook, including the possibility of getting it recognized via a firmware update (if Sony does provide one that does the trick).


#11

I have solved the problem… although Im not sure it is really what I wanted to hear. Unfortunatly dvd/rw drives are not compatable with my laptop. The tech I talked to from toshiba that finally was willing to ignore my expired warrenty checked… and apparently with many older toshibas, combo drives are the only option due to programming and supposedly power settings. I have no way of verifying this but I do know that I have since this post tried several brands of dvd/rw drives and all with the same result… so Ill trust the guy. Hope this helps those of your out there with old toshibas and this problem.