IBM POS 4835-152 Boot devices and BIOS update

vbimport

#1

I recently purchased a 4835 IBM POS AIO unit from a reseller on EBAY. The unit was in cosmetically great shape and looked like it would satisfy the customer. The reseller stated that there was no O/S on the unit and it needed to be brought up from scratch. So, I attached a USB CDROM to the unit and was going to install the O/S. I could not load the O/S because it said the HDD was write protected. Doing research on line, the resounding suggestion was to update the BIOS and sure enough the BIOS was 10 Revs back. I downloaded the BIOS update and tried all methods at my disposal with USB floppies, USB CDROM, thumb drives, IDE CDROM, booting Windows 2000 and using the phlash utility and errors came back stating that the unit was not the proper unit when all documentation confirmed the contrary. I really need some help with this. I have spent going on 30 calendar days on this problem and need to get a method to force flash the BIOS in order to get past these errors.


#2

This thing?

Did you read the installation and operating guide?


#3

It seems the 4835 model is totally not supported by IBM anymore. Can’t find anything regarding the 4835 model on the ftp site.


#4

The pictured unit is correct. I have a hard copy of the manual and have read it and followed the related troubleshooting steps. The prior research and commentary from others was what lead me to the conclusion of flashing the BIOS. The method I had to use to get the unit to boot was to replace the single device IDE ribbon cable with a dual device ribbon cable, place an operating system loading disk into an attached slave CDROM, let it fail to boot, and have it acquire the OS from the master HDD. It would not boot off the HDD in single device mode no matter what different configuration settings I used in the BIOS. The only device I have not tried “Special” external floppy with the unique connector that plugs into the bottom of the flat panel housing. I have not tried that because I cannot find anyone who has one. And then, I am afraid that acquiring one would be cost prohibitive by sheer virtue of supply/demand.


#5

My Knee jerk reaction when a computer tells me the HDD is “Write protected” is to assume that the HDD is encrypted as some corporations do…

At that point I set the HDD aside and try installing the OS on another HDD.

Until recently I had a stack of Hitachi/IBM drives that reported similar errors
and when any of them were connected to a computer via a USB housing they
report as “access denied”

I say “until recently” because they all went into the trash early last month.
they are someone else’s problem now.

Replace the drive and try again.

Look at the bright side… it doesn’t appear to have a BIOS password you need to bypass…

I suggest you get an OS installed on another HDD THEN try to update the Bios

AD


#6

Hey Allan, thanks for the post, appreciate the time. The drive is not write protected. It is a false condition. If I take the drive out and put it on one of my network diagnostic machines, I can read and write to it all day long. I have tried other drives with known good conditions in the POS machine and have gotten the same status. It is almost like the BIOS is forcing a PXE boot condition. As I said earlier, the only way I was able to “fake it out” was to set up a configuration that it had not experienced before (i.e., the dual IDE configuration). Then it booted, but I cannot leave it that way due to the case and the fact that I need the ability to load additional software. I even looked for a BIOS protect jumper that another poster on another site guided me to, but the jumper was not present. Thanks for taking the time…


#7

Perhaps its serial number locked somewhere. I know the original Xbox would do that. :slight_smile: How about cloning? Perhaps you can clone the data and abuse the cloning to install another disk.

You could clone the original data of the original harddisk (not that there is any, but you never know where suchs keys are) to another harddisk (preferably the same model one).

Next, prepare that clone harddisk on another pc without formatting it So, Windows barely installed. Try if this boots.

Warning: This last step may erase everything from the original harddisk and therefore also any “lock information”. So this step might get your computer bricked (as useful as a brick forever.

If it doesn’t clone this configuration back to the original harddisk. See if it boots.


#8

Mr. Belvedere, thanks again for taking the time to respond.

I have been using Ghost 9.0 on one of new network machines to hold the original image from the hard drive. I have been using a modified version of your suggestion, that is to say, I have made attempts to modify the image and when it went bad (and it has numerous times already), I used the Ghost image to get me back to a working image that would boot. But, none of the modifications on the hard drive suggested by yourself and others with good intentions, have been able to crack this boot issue and I revert back to the “force flash” approach. I have been able to boot the Hiren disk from the CDROM, but it gives me the same errors of unit identity that I got when I tried to do the flash upgrade from the command line of Win2K. This is the first time I have had an IBM flash not come up with the classic “proceed at your own risk with punishment of death to the technology should you fail” disclaimer. That at least gave you the opportunity to proceed understanding the risks.


#9

I’ve bypassed some pretty aggrevating security in the past, but it helps to have the computer at hand and a bottle of Bourbon nearby…

Because sometimes the sober ideas just don’t work.
Unfortunatly the alcohol fueled solutions are often not remembered…

Generally speaking if someone gets rid of computer hardware it’s very often for a good reason.
(and not simply because it’s outdated)

I wish you the best of luck

AD


#10

Good Day Allan, I have to say that I like your approach. In years gone by, I had found that the more the consumption of the bourbon, the more abstract the thinking… Go figure…


#11

What about destroying the data on the original harddisk (i assume you have a good Ghost copy) and just install Dos 6.22 on it using another computer. (Boot from a DOS floppy, fdisk the original hdd, removing all partitions and make a nice new dos one and format c: /s it)

Copy the bios flash tool and files on it and try if it will boot the harddisk when inserted in the original machine.


#12

where you found bios updates. i need for ibm 4846-e45 and I can only find the tochiba commerce on site. there I need user and password