I think my HP 640i is dead? I think

vbimport

#1

Its a lightscribe HP 640i pretty neat little thing for the cheap too. So I bought some CD-R lightscribe media and tried it out. Worked fine each time. Then one day it would not eject. The drive was being regonized by my computer but had to be manuall ejected. I can hear it try to eject but its just not ejecting. So obviously I manuall eject it and it comes out fine, and it closes fine. But it would eject when I want it to, it has to manually be ejected. The media now is not being recognized. Can anyone or anything help me?


#2

Try and reinstall the drive, maybe the computer is not recognizing it. You can also try uninstalling the secondary ide channell ( if that is where you have it. All you have to do to reinstall it is reboot, it will automatically recognized by XP and installed.


#3

The ejection problem indicates that something has obviously gone wrong with the drive ejection mechanism. The best way to deal with that is to send it back for repairs. This of course assumes that you are still within the warranty period for the drive. Otherwise, you can try opening the drive and seeing if anything is obstructing the ejection process. Sometimes a small lump of sand or something can get into one of the gears and cause it to jam a bit.

The problem you now have with the drive recognising media may be due to the same thing - the drive can’t quite close properly so the disc doesn’t get spun up. Try alan’s suggestion first to see if that solves this.