I think my 1016IM is...DEAD!

vbimport

#1

Hi all. I bought an Emprex (rebadged BTC) 1016IM earlier this year from Fry’s, and updated the firmware (currently on A07R). It was running fine for several months (burned about 100 DVD+Rs & CD-Rs or so), when all of a sudden it stopped recognizing any discs this week.

I can eject the drive, pop in any disc (blank or data-filled DVD/CD), close the drive, and the drive light will flash, but Windows keeps prompting me to “insert a disk into drive” when I try to access it via Windows Explorer.

I’ve tried blowing compressed air into the drive, swapping cables, and updating the firmware to the latest & greatest (A087, which went fine), but the drive will still not read any discs. There has been no change to my BIOS or Windows XP system, and Windows reports that the driver is installed properly. As a side note, my BTC BDV-316E DVD-ROM drive is not experiencing any problems.

Is there anything else I could try, or is this drive toast? And if it’s gone, what’s a good replacement drive for around $50-$60 bucks? I’d like to try a different brand this time.

Thanks!


#2

You might want to delete the drive from the device manager and power down. Windows should find it again after reboot.

If this won’t work, then I guess you’re stuck with a faulty drive.

Regards, Martin A


#3

Sounds like BTC quality alright.