I think i reformated my dvd burner

vbimport

#1

not quite sure its the drives problem as much as it is mine, but i put in a new usb flashdrive, and formated it and now the dvd drive(nec 3500ag) does not show up in my comp. I checked the device manager and it has an exclamation mark next to the drive, which in the properties said that the device driver could not be found. I then checked the usb device, to notice that it had drive letter d:. I tried to do a system restore to no avail. I believe i formatted the dvd drive. Is there any help for me?TY.


#2

Welcome to the forum. I have to admit I laughed when I saw your thread title, you can’t format/reformat a DVD Burner. So you can check that off of your list at least. :stuck_out_tongue:

I would just remove the usb drive, right click on your DVD Burner in device manager and select to ‘remove’ the drive, and restart your computer. The computer should recognize the drive and hopefully reassign the drive letter D: for you on the restart. Not sure why the USB drive ‘stole’ the drive letter D: in the process. If it does it again, you can reassign it a different drive letter.


#3

Better yet would be to uninstall the IDE controller (not the drive) and reboot.


#4

I tried both, the message in the properties of the nec 3500ag reads: "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. "Any ideas? I know that the driver is more firmware than software, so what is my issue?


#5

Moving to the Optical Drives forum.


#6

Wrong, a driver is just SOFTWARE.
Find out the error code and then search for it on the m$ support pages.


#7

run this

this will help out