I think i broke my 1620

vbimport

#1

my drive doesnt even open anymore. when i boot up, the green light flashes for a long time and it slows my start up time. same thing happens when i push the eject button. green light flashes for a while. it all started when i put in a dvd someone else burned, and then it hung up and i couldnt get it open. now it happens all the time. did i break my drive by upgrading firmwares? im using b7v9 right now and ive tried flashing backwards and forwards and nothing is working. please help.


#2

You said the drive won’t open cuz you played a dvd. Then you said you flashed firmwares back and forth…so I’m assuming that the dvd is still in the drive? If it wasn’t broken before, it might be now. Flashing with a disc inside the drive is bad.


#3

no, the disc is out. when i flash, i have no problems. the drive flashes red slowly, then fast, then program is done. then i hit ok and the drive flashes green again and does nothing. still wont open. and i try powering down and nothing works.


#4

Just Happen To Me This Morning. (BenQ Would Not Eject)
Burning Movie In Sonic RecordNow 4.61

Failed Half Way Thru Burn With This Error Message:

305 - 20/06/2005 4:06:39 AM |01| Job 1, Host:1 ID:2 (D: ) - Benq DVD DD DW1620 - Recording - Error -10 at Sector 1828656 - Disc Write Error - Command:2A Sense:03 ASC:0C ASCQ:00
207 - 20/06/2005 4:06:39 AM |01| Job 1 Round 1 Terminated - 0 Good Disc(s), 1 Bad Disc(s)
311 - 20/06/2005 4:06:39 AM |01| Job 1 Terminated with errors <<<<<<< 0 Good Disc(s), 1 Bad Disc(s) >>>>>>>
199 - 20/06/2005 4:08:42 AM |00| Sonic RecordNow DX Terminated

The Drive Would No Longer Eject.

Powered Down PC
Removed DVD For Drive Using The Pin Hole Eject.

Reboot PC
BenQ Flashing Green Light For A Long Time As PC Loads OS.
Drive Still Detected In OS
Drive Still Does Not Eject

Booted Into Safe Mode To Flash Firmware To Factory B7T9
Flash Successful
Drive Still Would Not Eject.

Removed Drive Out Of PC To Return To BENQ.
Tried BenQ Drive In My Test Bed PC On The Off Chance (Plus To Double Check)
Drive Now Ejects, Reads And Burns Media.
Put Drive Back Into Original PC All Is Sweet Again.
Go Figure :confused:


#5

Check PSU!


#6

Did you install any new programs? If so, maybe they dont like the drive.


#7

No New Software Davrio4
I Think Jake8131 Might Be On To Something Regarding PSU

The PSU Is Getting A Bit Long In The Tooth Enermax EG651P-VE
The Testbed Is Running Antec 550EPS12V PSU Only About 12 Months Old.


#8

Seems To Be Burning Ok (Touch Wood)



#9

These drives have been dropping like flies lately for no user related reason. One report from China points to a chip that is prone to early failure because if slight variations in power supply. I would send it back and hope the replacment is not from the same batch. Some users have had multiple failures. Good luck.


#10

do you know if this power issue and sudden death also affects the Philips rebadges? both mine were made in April btw


#11

The BenQ DW1620 Pro Was Manufactured Jan 2005
The Item Was Purchase On 28/04/2005

I Will Soon Replace PSU And Monitor The Situation Over The Next
Couple Of Weeks Til The BenQ DW1640 Pro Is Available In Australia.


#12

Most of what I have read seems to indicate DOM from October 2004 through some time in early 2005. The comment on the chip was from a source in China, I believe, and unfortunately, there was no mention of which drives these bad chips wound up in. An April date is fairly new so you probably have a better chance than most of us.

I wish theywould just recall these and get on to the 1640.