I think i bricked my DRU-800a

vbimport

#1

I tried to flash from KY01 to KY06, and of course the power took that as its signal to cut out on me.

Needless to say, the drive is not recognized at all by the bios any more. :sad:

Am I out of luck here? Is there some way I can resurrect this drive?


#2

in dos mode, use MtkFlash and the bin file from the codeguys site

http://codeworks.cdfreaks.com/cgmirror/firmwares.html


#3

Thanks!

Once I find a download link for MtkFlash that works, I will try it and post back.

As Rpc1.org is currently experiencing drunken robot related difficulties, is there a mirror anywhere that I can use to get MtkFlash?

Am I correct in assuming that xsf will not work as the dru-800a is not a serial flash?


#4

OK. I found a copy of mtkflash 1.69, google was good to me today.

I built a dr-dos boot disk, tossed the exe and the binfile on it.

powered on and waited for the bios to give up on the drive, and boot from floppy.

mtkflash 1 w /t /b ty06.bin

what kind of feed back should I be expecting at this point?
how long will it normally take to flash?

anyway, i hit ctrl c after it sat for over 30 min just blinking the cursor at me.:a

any other clues on what I’m missing here? anything special i have to do to the drive?


#5

[QUOTE=tildar;2057448]any other clues on what I’m missing here? anything special i have to do to the drive?[/QUOTE]
Switch off the PC, press the eject button and keep it pressed - do not release it, power the PC on, wait 10 seconds, release the eject button. Try again to flash. This method worked here with mtkflash 1.83c.


#6

OK, the eject button didn’t help.

-SO-

I took the drive to a different PC with a different Motherboard, which is harder to do in this office than it sounds, and the flash just worked the first time without a problem. :bigsmile:

For what it’s worth, the mb that DID NOT WORK is an INTEL DP965LT.

The one that DID WORK is an GIGA-BYTE GA-7DX.

Thanks for the help guys!!