I replaced a fried BIOS chip. Now Linux works, but Windows doesn't

vbimport

#1

The motherboard is a ASUS A7N8X-E Deluxe. I bought a SATA 2 drive, but it was not recognized by the RAID controller. It turned out the the latest ASUS BIOS did not include the (apparently necessary) onboard SiL RAID upgrade.

I learned that gamers had made a BIOS that included that upgrade. So I got one, and when I flashed it, it fried the motherboard.

I then bought a new BIOS chip, a chip removal tool, and put it in (w the latest ASUS BIOS, not the one I had before, and not the gamer one).

This seemed to work. And Puppy Linux off a CD worked fine.

But the computer tried to go into Windows, all it did was, it got to the Windows Logo which faded and then the computer rebooted

So I did a (non-OEM) “windows repair install”. The effect was that Windows now does not start at all (I get a BSOD, no logo).

My questions are

  • would a full Windows reinstall be a waste of time?

  • should I bother getting another chip (this time trying a different gamer BIOS) and see if that will finally recognize the SATA 2 ?

My fallback strategy is to get my backup BIOS flashed on on my old chip and go back to square 1.


#2

Welcome to the club redeyeblog :slight_smile:

Try running Memtest86+ http://www.memtest.org/ for one full pass. You can make a bootable CD or floppy.

You may need to make adjustments to either your ram timmigs, voltage, or cpu voltage to get your MB stable. I think your bios chip is good, its just a matter of gettings the settings in the bios stable.