I/O magic burner installation problem

vbimport

#1

I bought a I/O magic DVD+R drive from STAPLES on BF. I make it as a slave secondary IDE drive at my computer, and the initial CD-ROM as the primary secondary IDE drive. Everything is working well under window XP. However, I found recently CD-ROM read speed was very slow if I format hard disk and reinstall winXP. After sucessfully installation winXP, I found that the transfer mode for CD-ROM was PIO only, but the DVD burner was Ultra DMA mode 2. I can change the CD-ROM back to Ultra DMA mode 2. However, it went back to PIO again if I tried to format hard disk and reinstalled winXP. What is this problem? Does anyone has this situation before? Thanks!


#2

1st, I would dput my BenQ on sec “master” my cd-rom on sec slave. Make sure you jumper correctly!!!
Then, I would read these posts:
Look here:
http://www.cdrlabs.com/phpBB/viewtopic.php?t=7625
or Here:
http://www.cdrlabs.com/phpBB/viewtopic.php?t=9668
if still no joy, look here:
http://www.cdrlabs.com/phpBB/viewtopic.php?t=6645

That should get you going. Let us know how it goes.


#3

Thank for your reply. Actually I am able to change the transfer mode of CD-ROM back to Ultra DMA mode 2. I just want to know: is it necessary to set DVD burner to the master of secondary IDE drive? Anyway I will try it. Thank you very much!


#4

I had similar issue - go into your BIOS and check the setting for each drive. Be sure they are set to “AUTO” or “DMA” (depending on your BIOS). I found that my slave drives were actually set to “OFF”. The system booted up and recognized the drives but set them to PIO despite my attempts to set them to DMA within Windows XP.


#5

Glad to hear it was a simple solution.
It is not necessary to set BenQ to sec master, if you are having no problems.

From what I have read & garnered through the forums, the preferred setup is to have the BenQ as Master, regardless of what channel the drive is on. (the Primary master setting would apply if you had your OS on SATA HD drive(s) on SATA, & your opticals on your Primary/Secondary IDE channels).
I also believe that a senior poster claimed better performance if they did not have anything as slave device to their BenQ as master (this may be system specific). I have yet to confirm this on my own systems.