I/O error with iOmega dual DVD-RW

vbimport

#1

I can’t seem to find an answer to the question I have regarding my DVD burner, an iOmega dual DVD-RW. I backed-up tons of my movies with it, using DVD shrink and Nero. Suddenly one day, it stopped working. The CD-RW still worked but on a DVD, I couldn’t even back up data. It would still read DVDs but wouldn’t write them. It was still under warranty, so I sent back. They sent the same drive back telling me it was working. I tried it again. It would read and write CDs but still only read DVDs. I sent it back again, explaining the problem again. They then sent me a new one. I made a data DVD with no problems. I inserted a film which I had bought used from a rental outlet (!) and tried to copy it. The DVD burner ceased to function and would only read DVDs from then on. Is this copy protection software at work? Has my drive been irreparably damaged by some malicious copy protection software or is this able to be fixed. After I have successfully ripped a DVD with DVD shrink, my drive refuses to copy it citing an I/O error.

I live in Germany (Region 2). Any help would be much appreciated. Thanks.


#2

Welcome crassbrauer,

I moved your thread to this part of the forum.


#3

Well, I’ve searched the forum for an answer to this question and can’t seem to find one.


#4

To be sure that the drive is working, you may could test it in another computer?!


#5

Yes, I failed to mention that I did that with the old one. Due to the fact that the new one ceased to function properly the instant I tried to back up a film (a used rental DVD I’d purchased) is very suspicious, that is subsequent to having successfully burned a data DVD.