I/O error when trying to rip DVD

vbimport

#1

I have a DVD of the classic film “The Big Heat”, which I’ve been trying to copy. I have the latest (and last) version of dvd decrypter. I’ve also tried using it in conjunction with AnyDVD 2. Perhaps a newer version would help I suppose.

When I attempt to rip the dvd, it starts off fine. AnyDVD appears to remove the copy protection and DVD decrypter does not complain about any copy protection problems. When it gets to 22%, I come across an I/O error.

It says
I/O error
ScsiStatus 0x02
Interpretation: check condition

CDB: 28 00 00 07 E6 A1 00 00 01 00
Interpretation: Read (10) Sector: 517793

I set DVD decrypter to ‘ignore read errors’ but it still gets stuck at the same point.

Am I right in thinking this could be some form of copy protection? If so, how can I get around it? It’s a sony distributed DVD.

The disc itself has a few scratches on it, but I’ve copied ones that have been in a worse state before. The disc plays fine, although I haven’t played it all the way through on a computer. It could nonetheless still be damage that’s stopping it being copied.

It’s nothing to do with the DVD drive as it’s the same with both my drives (Sony 1615 and LG 4166B).


#2

Oops… I should’ve tried with a newer version of AnyDVD before posting this. Downloaded the trial version and it works fine, no more getting stuck at 22%! Excellent!


#3

Spoke a little too soon, dvd decrypter got past the error but didn’t entirely work properly. Got to 99% then said something like “invalid IFO error” or something. Dvd shrink seemed to encode it ok. I burned the resulting files to a dvd+r as usual and the disc isn’t readable by winDVD or PowerDVD, says “unsupported format” or nothing at all in the case of WinDVD.