I Need some help with LITE-ON DVDRW LDW-451S

vbimport

#1

Hi all,

I recently brought this drive for $175(australian), don’t know if this was good or bad but it looked and sounded good to me so I went ahead.

However after going through this forum and others I have tried LTNFLASH to make it region free and now my EEPROM is empty, the drive still sort of works, it can do some writing and reading, however getting lots of CRC errors from the files when trying to read, but this reading and writing can only happen if I run the dos flash program (can’t remember the exact name of it) like this

 flash181.exe 3 w gsb6.bin

after booting to pure dos mode, then when I reboot, my software can access the drive again but having many problems like I said above.

What I need is for someone with a matching drive to make a copy of their EEPROM and send it to me so that I can try that. I would be EXTREMELY GRATEFUL as $175 dollars is alot to me and I don’t want to have it die on me now.

Another thing is when I access the drive using LTNFLASH it says my drive is 1.0.0.0 F: and when I first ran the program it actually reported the drive by its name LITE-ON DVDRW LDW-451S. Now, before running the dos flash program like above it reports my drive as 2.0.0.0 F: and no software except Sonic DLA which allows me to use the drive like any other normal drive.

After partially restoring my drive using the dos flash program if I run LTNFLASH even once (without doing anything, just open and close), everything goes back to not working until I run it again.

Please, I really need to try someone else’s EEPROM, I know that they are different for every drive but I am willing to try anything.

HUGE THANKS TO ALL WHO HELP.

Actually what I really also need is a backup of the FLASH, if you use LTNFLASH then you can just backup the flash and then save the EEPROM and then send them to me. If you can help me, then post a reply saying so then we can work out how you can send them to me.

THANKS AGAIN.


#2

No, your EEPROM is not empty. If it was, then you would get the blinking orange light. LtnFlash cannot detect your drive because there is an ASPI driver installation problem. Use killaspi.bat to remove ASPI or else try some different versions of ASPI drivers.

http://aspi.radified.com


#3

Ok,

Correct, the ASPI drivers were not installed. Now they are and after a reboot, the drive is working as before, after another reboot, problem is back again.

ASPI drivers are still installed and working, but the problem is back, except this time there are some differences, not in hardware but my understanding.

Being the newbie that I am, I was not using the LTNFLASH tool properly, the first time when there was not data, this was because I never clicked the read button to read it. After the ASPI setup I ran LTNFLASH and clicked the read button, this time I got it and SAVED IT! And it is lucky that I did because now after the second reboot it will not read the EEPROM anymore, it will not even let me write the one I saved back to it.

So anyone understand this or have some advice for me.

thanks.


#4

Well, I am starting to think that this may be a OS problem, I am running Windows 2000 have installed ForceASPI, as stated already initially it worked, but once the pc was rebooted again everything went to hell.

I know that the drive is still accessible because dvd can be played from it by WinDVD and Sonic CinePlayer and Sonic DLA can write to it.

Does anyone else agree that this sounds like a software problem rather than a hardware one. I am even starting to think that there never was a problem with the drive at all!

Is there another flash program that doesn’t use ASPI to access the drive, I am assuming that the software that can use the drive do not rely on it and this is why they can still work. I just want to verify that there is indeed nothing wrong with the drive.

However one thing is for sure, the one time that LTNFLASH worked and I was able to save my EEPROM I tried to flash back to GSB6 firmware (I had installed GSB7 using mtkflash from dos) and it said my drive was not a 451S but I know that it is for sure and I think that changing the Region settings (made it region free) has made the checksum fail, does anyone know how to restore this so that the checksum will work. I never saved the EEPROM before changing it so I know I probably can’t, just wondering what you guys think.

thanks.


#5

I have a similar problem with my ASPI drivers. I’ve used KillASPI to delete them, then FroceASPI to install version 4.60 on my windows XP machine, but that didn’t seem to do the trick, burning applications, kprobe, and the official firmware installers from LiteOn are seeing the drive as 2.0.0.0 with nothing else.

Does anyone have any further suggestions?


#6

Use KillASPI to remove them, then do not reinstall ASPI at all.