I need a Virtualdub expert's help, I think

vbimport

#1

Can anyone help me figure this out? I’m extremely frustrated after 3 million tries at fixing this video. Here’s the deal…

I have some xvid’s that are wonderful quality, and all of them play great on my LiteOn LVD-2002, except for a few of them. I can’t even figure out what’s different about them, since they seem to be in sync when I play them on my PC. (However, they do appear a bit choppy on the PC, but not on the DVD player) But, when I burn them to a disc and try to watch them on my DVD player, the sound is off. I thought it might be because most of them are 48000Hz and the ones I’m having trouble with are 44100Hz, but I found another one that plays fine that is indeed 44100Hz too.

This is the info on one that won’t play correctly.

Video
4CC: XVID
Bitrate: 844 kb/s
Framerate: 23.976 FPS

Audio
Bitrate: 107 kb/s (53/ch x 2 ch) VBR
Fs: 44100 Hz

What the hell could be going on here? I’ve tried all kinds of things, but nothing seems to fix it. :confused: Anyone have any suggestions? :sad:


#2

Or maybe someone can recommend a forum that might be able to help?


#3

Don’t suppose you’ve tried saving a new AVI with CBR audio?

Here’s what I’d do with a choppy AVI, and I will presume it’s just your LiteOn that plays it out-of-sync:

Load in VirtualDubMPEG2 -> Video -> Error Mode -> Conceal errors and resume decoding at next keyframe -> O.K. -> Video -> Scan Video Stream for Errors. Then Video -> Full Processing Mode -> Compression -> XviD (bitrate somewhat less than the original if it’s a tight fit on a CD, since the audio bitrate will be slightly higher) -> Audio -> Full Processing Mode -> Compression -> Lame MP3 (48000Hz, 128kbps, CBR, Stereo). File -> Save as AVI. (This WILL degrade the AVI to some extent.) If the video is okay on your LiteOn, you could do Video -> Direct Stream Copy, instead of Full Processing Mode. But the audio should be CBR, which means Full Processing Mode.

VBR audio is often the problem with AVIs, just why the hell folks decide to be cute and encode them that way…well, your guess is as good as mine. Not usually a problem on a computer, but convert to MPEG2 and it is almost guaranteed to be buggered. And likely to be a problem on your LiteOn as well. If you also have a field order problem, you may need to swap fields in video filters. Smooth filter may help as well. But that’s what I’d try first, filters later if necessary. And if you’ve already tried all this, then I’m fresh out of ideas. :stuck_out_tongue:

Good luck, :wink: and you may want to ask your question here:

http://www.videohelp.com


#4

Ok, this sounds like it might be helpful. I don’t have vdubmpeg2. I guess I need to get that? (Is 1.5.10 the latest?) Damn! How many versions of vdub are there? I already have four! I was using MP3freeze, since it was the only thing that would seem to handle VBR’s.
But yeah, it’s just on the LiteOn that it’s out of sync. All the VBR’s at 48000 seem to be fine, but all of the ones at 44100 (except one) are way out of sync when I try them on the LiteOn.
I agree. VBR sucks! I’ve never really had any trouble until I ran across these. I don’t know exactly what I’m doing, but I did manage to get them into CBR mode, but it still was off for some reason. Can you tell me the correct way to extract audio, compress, and reinsert it into the video? Maybe I’m not doing it correctly? There just isn’t a tutorial for exactly what I’m trying to to, I guess. At least, I haven’t found one.

I’m not sure if I made it clear, but I want to keep them XVIDs, since all the episodes fit on one DVD that way, and they look great. I just need to figure out what’s wrong with these few episodes that aren’t in sync.

Ok, I tried opening this video with vdubmpeg2, and I get the same error as all the others. The only one that can open the VBR’s without the error is MP3 Freeze. I’m trying all the steps you listed above, though. Thanks for your reply. BTW, I did register at that forum earlier today, but there’s a 2 day waiting period to post anything, apparently.


#5

Bah! I tried all that and it’s out of sync even playing on the PC after that. I tried doing a direct stream copy of the video, and just encoding the audio, but it gives me an ACM error. :frowning:


#6

are you sure your audio stream is not something other than MP3, like Ogg or AC3…
Nandub may be better suited for handling these types of audio streams than VD.


#7

I just used VirtualDubMPEG2 as an example, and I’m most familiar with it. :wink: Daemonicus may be onto something. If you can open the file in VirtualDubMP3&VideoFreeze, try this:

File -> Open Video File -> Audio -> Full Processing Mode -> File -> Save WAV. Close. Open the file again -> Video -> Direct Stream Copy -> Audio -> WAV Audio (choose the WAV you extracted in the previous step) -> File -> Save as AVI. (If you try to compress the audio in this step, it MAY fail to render.)

Test the file in Media Player Classic. Is it in sync? If not, is it out a constant amount or does it gradually go out-of-sync? (This can be fixed in a separate step).

If it’s okay, open the new file -> Video -> Direct Stream Copy -> Audio -> Full Processing Mode -> Audio -> Compression -> (continue as previous post). Save as AVI. Burn this AVI on an RW if your player will accept it. How’s it play?

Good luck. :slight_smile:


#8

GSpot says it’s MP3, and Vdub says it’s Fraunhofer IIS. I can’t even extract the audio in Full Processing mode. It gives me the same ACM error. I can extract it in direct stream mode, but then isn’t it just an MP3 with a wav extension? One question…does “direct stream” mean I’m copying directly from the the video itself, in whatever format it is? Is that its only function? Or does it also add from an external source? The problem is, I think I know what I’m doing, but I’m not really sure if I’m doing what I think. :confused:
I’ve tried extracting the wav, then selecting it to add back in with full processing mode, but then I get a short squeal at the beginning and no audio after that. Nothing seems to work, darg blammit!

Well, I just tried Nandub, and it shows the ACM error if I even try to play it. Apparently, it doesn’t even support playing VBR? As far as I know, from what I’ve read, MP3 Freeze is the only one that can handle VBR audio without the ACM error. Excuse me while I go pound my head against the wall some more.


#9

Something’s not clear, you can open the file in VirtualDub MP3 & VideoFreeze? But you can’t save out a WAV file? I’d give it up at this point. :wink:

Really, is it worth the trouble? Anyway, indications are it’s the audio that’s causing the trouble, but you really should be able to extract it. So…maybe the AVI file header’s corrupt? Perhaps try repairing the header with BeSliced first, then see if you can do anything with the audio?

Oh, Direct Stream Copy is just that, and avoids degradation due to recompression. The purpose of what I suggested was to extract and fix the bad audio and remux it with the (good?) video.

Here’s the deal: If you’re pigheaded enough, and persistent enough, you’ll learn a hell of a lot fooling with this. But unless the material’s irreplaceable, this is going to be more trouble than it’s worth. It’s by no means uncommon for DLed AVI files to be buggered in some way. This is not for noobs, which is ironic, since it’s mostly noobs who want to know how to make their crummy (and probably illegal) downloads work. Or how to convert them. :eek: No offense intended or implied. Good luck. :stuck_out_tongue:


#10

No, I can save a wav file, but when I look at it in GSpot, it still says it’s an MP3 with a wav extension. Anyway, it’s worth the trouble because I can’t find another dnld that isn’t the same file, or worse. I’d love to be able to fix things like this. I could go rent the DVD, I guess, but it just pisses me off that I can’t get this fixed. I’ve figured out how to do a lot of things with vdub. This is just something I think I should be able to do. Yep, I’m pigheaded. But man, this one file is annoying the shit out of me. You know what it’s like to have two seasons of a show, in DVD quality XVids, and one freaking file doesn’t play right? It’s enough to drive me insane, especially when I’ve wasted countless hours dnlding several other files, trying to find one that works…to no avail.


#11

Try virtualdubmod. Select Streams, stream list, RIGHT click the stream, full processing, then select DEMUX.
If you can’t use full processing, just demux.
Load the demuxed audio into something like Goldwave, or Audacity, and save it again as .wav
At least that will give you an uncompressed CBR file to work with.


#12

I tried that and ended up with a 561M MP3, and Goldwave can’t even determine what kind of file it is.


#13

It’s a VBR mp3.
Make sure you have a good mp3 codec on your system. If you only have players that play mp3’s, that doesn’t mean you have a decoder for mp3 available to Goldwave.
Try right clicking the stream, then select save .wav


#14

Alright, I saved it as a wav. Now I’m attempting to add it back in and compress it to a Lame CBR MP3. I hope I’m doing this right. It’s different than the other vdub versions.

[Later] Well, it worked, but the sound is off even when I play it on the PC now. Damnit! This is pissing me off. :frowning: Everything I do that would seem that it should fix this, only makes it worse.


#15

Virtualdub allows for audio delay.
Select Audio, Interleaving, and delay it.
If the audio trails the video, you can enter a negative number (put a - in front).


#16

It is trailing it. I’ll see if I can sync it. I did that before, and it looked in perfect sync on the PC, but was still off on my DVD player. I don’t know what the hell the deal is. :frowning:


#17

There’s something weird about this, I think. I did that same thing as last time, and used a guestimate of 500ms. Well, it’s in perfect sync on the PC. What are the chances of that? That’s the same exact number I used before. I mean, first of all, what are the chances of it being an exact round number like that? Then, second, what are the chances I’d get it right on the first try? I’ll bet you it’s going to be off again when I try it on the DVD player.

[edit]Holy shit!!! It worked!!! Thank you so much for your help! I don’t know why that didn’t work on the other version, but I’m freaking ecstatic that it worked on this one! :wink: :bow:


#18

Some decoders automatically apply 1/2 second (500ms) delay, then other decoders remove this delay. The result is, it plays on the computer, but not on the burn.
If you reapply the delay before or during encoding/authoring, it works.
That’s why it’s (almost) always 500ms.


#19

I see. Hey, is there any way to disable the Xvid status window? I hate that thing. I wish it would just never come up. It’s really kind of useless to me. It’s more of an annoyance. There should be a way to disable it…a check box, or something.


#20

Convert vbr to synced cbr

Avi with vbr audio to avi with cbr audio keeping it in sync with the video using vdub

Overview: I use vdub twice to get non-skewed cbr audio/video.

The original avi is vbr audio which when converted directly to pcm with vdub skews the video and the audio out of sync. If the original was in mp3 cbr it would stay in sync when it was converted to pcm wave pr ?. I use vdub to do this by:

1 Open the vbr avi in vdub, getting sync skew warning message which I ignore.
2 I set video to direct stream copy and audio to full processing mode, audio to interleaving (in the drop down menu) and click OFF enable audio/video interleaving and then click OK. I then click in the audio drop down menu, audio, compression lame mp3 44100 hz, 128 kbps cbr, stereo, 15 kbs. Gspot had the original at 129 kbps. Then I save the avi.
3 This give you an avi file that Gspot shows as the audio = mp3 iso/mpeg, I then open this avi in vdub and convert it again; the audio to full processing mode, compression to mp3 lame 128 (again). The result when I save the conversion will be audio 128 mp3 mpeg l layer 3 CBR with sync OK which is the desired result.
4 I then open this avi in vdub again and change the mp3 compression to pcm wave. I save the wave for processing in Diamond Cut 5 or whatever program is your preference.