I killed my SN342F drive

vbimport

#1

Hi there

I did something really stupid, I updated my firmware of my DVD/CDRW combo in my laptop (Samsung Flashing GUI) from U200 to U205 which seem to work okay and then rebooted…dead drive :sad:

Now I’m stuck with a laptop without a drive and my model does not have a floppy drive to boot too either.

I’ve gone into the BIOS to see if that needed to be reset and no luck, no found.

Any ideas how to get this thing back on the road again?

chrome

BTW The flash utility didn’t have a ‘Dump’ option, so I’ll have to get the firmware back from their site.


#2

I’ve got a firewire enclosure which can house an optical drive and thought maybe I could use a DOS based flasher on a boot disc and attempt to flash it this way.

chrome


#3

Found the original firmware here:

http://www.alllaptops.co.uk/drivers/SN324F.ZIP

Source:

http://www.alllaptops.co.uk/toc.htm


#4

Okay, this is what I’ve found out so far…(Source Etna’s page at www.rpc1.org)

I should have used MKTflash to carry out the flash process (dump/install) instead of the Samsung native program.

chrome


#5

Well so far tried reflashing with different versions of MKTFlash and even tried the MKTflash C command to see if the drive was attached and I got the following message:

Err: Fail to initial IDE port please reboot PC

Not helpful LOL

I sent an email to Samsung Support in the UK and here’s their reply to me:

Quote:
[I]

Dear Chrome

Thank you for contacting Samsung Electronics.

[Solution]
In response to your query regarding the flash you performed on your V25
notebook’s optical drive, please be aware that we can offer no support
on this update. This update is not approved by Samsung, in fact we do
not recommend updating the firmware of any device unless you have been
advised to do so by Samsung.

I advise you to contact a repair centre, as we do not have any default
firmwares for optical drives available to end users. You can contact
Digicare on 08701125440 or Romtronics on 0208 421 0101.[/I]

The update in question was from Softpedia’s website listing a number of firmware updates for a number of Samsung products.

Anyway I’ll keep on trying!!!

chrome :stuck_out_tongue:


#6

Here’s where I got the download from:

General Samsung Firmware Updates

http://drivers.softpedia.com/get/FIRMWARE/Samsung/

My Drive Samsung SN324F:

http://drivers.softpedia.com/progDownload/Samsung-SNF-firmware-u-Download-9393.html

Link to the download:

http://www.samsungodd.com/Lib/popup/Download.asp?path=FW_FWDownload&fname=200412161838182631_U204ELS.BIN


#7

Don’t know if this will be any help, but I also killed my SN342F by flashing with the wrong firmware. I have however completely restored the original firmware and the drive works fine.
Here’s how :

Removed the DVD drive from the laptop - a time consuming process but the case comes apart relatively simply and the drive is held in by only two small screws.

Changed the connector on the drive with one from another working laptop (a Gateway 9300 in my case).

Removed the front panel from the drive to allow it to fit into the other laptop.

The other laptop can now see the drive in Windows but Samsung flash software will not allow an older version to be flashed.

Download the DOS flasher from www.samsungodd.com and flash the old firmware after booting into DOS.

Now fit everything back together !!!


#8

Hi there Peter

Thanks for the tip!!! :slight_smile:

I had read somewhere that you could load it up in another laptop and reflash again.

Samsung support in the UK, suks…all they could offer me was to return it to them and they would replace the drive.

Looking around the net I had considered a replacement drive ie:

£70 for a DVD/CDRW combo
£95 for a 8x DVDR

I do have a second V25 laptop so hopefully I’ll try it out on that drive if not I’ll see if I can convince someone to loan me one!!!

Thanks again!!!

chrome


#9

I had a customer with a similar problem. He brought in his notebook with an unresponsive drive. I hooked up a USB external drive, backed up his files to CDR, then reformatted and reinstalled XP. Fixed the problem just fine. If nothing else. you can use the USB external drive to re-flash if you find an older firmware flash utility. Good luck, and hope this helps.


#10

Try following, it helped me with my SN-324:

Open “regedit”

Remove the Upperfilters and Lowerfilters values by:

a) Expand the “HKEY_LOCAL_MACHINE” key (looks like a folder) by double clicking it.
b) Expand the “SYSTEM” Key
c) Expand the “CurrentControlSet” Key
d) Expand the “Control” Key
e) Expand the “Class” Key
f) Please look for a key containing the following string of letter and numbers: {4D36E965-E325-11CE-BFC1-08002BE10318}.

g) High light this key by left clicking once on it

h) On the right hand side you are looking for “Upperfilters” and “Lowerfilters”, once you find these please delete them by high lighting (left clicking on them once) and then right clicking on them and choosing “delete”

  1. Restart your computer.

  2. Your CD-ROM should be back.

This solution was found on the DELL Forum.


#11

Hi there

Thanks for your reply and instructions…unfortunately it didn’t seem to work for me.

Here’s a screendump of the files…my drive still doesn’t show up in the Control Panel :frowning:

http://img105.imageshack.us/img105/5357/sn324f5pa.jpg


#12

Ok, try following

Check the Windows XP/2000 Registry.
Click Start and then click Run.
The Run window appears.
In the Open: field, type Regedit and then click OK.
The Registry Editor window appears.
Click the plus (+) sign next to the following folders:

HKEY_CURRENT_USER
Software
Microsoft
Windows
CurrentVersion
Policies

Click to select the Explorer folder.
In the right-pane, check to see if an entry labeled NoDrives is present.
If this entry is listed, right-click the entry and then left-click Delete.
The Confirm Value Delete window appears.
Click Yes to confirm removal.
Close the Registry Editor window.
Restart the computer.


#13

Thanks again for your input.

I did follow your recent instructions and found the ‘NoDrives’ entry with an autorun function, which I did delete. Still no joy :frowning:

Not really had much luck with recovering this.

Regards

chrome


#14

What make of laptop is it built in?


#15

Another option (if you use a Dell System)

During boot enter CMOS and reset BIOS defaults.
Restart your computer and when the Dell logo appears on the screen, press [F2] to enter it. Hold [Alt] and [F] simultaneously or press [F9] to reset the BIOS to the factory default configuration. Press [Esc] or [F10] to save the changes and exit the BIOS.


#16

Have you recently installed a CD burning (copying) program? If so, try uninstalling it and then removing the entry for the drive within the Windows Device Manager and then restarting your system. The drive should be re-enumerated and this may correct the problem.


#17

Ghostman002, sorry for the delaying in getting back to you regarding this.

The drive is in a Samsung V25 laptop.

Any assistance in retrieving this drive would be helpful especially as Samsung’s CS, is awful :frowning:


#18

I made the horrible mistake of updating my firmware too. Funny thing is, I downloaded it from a samsung website (samsungodd.com) and thought I was following directions carefully. Updated from U200 to U205. I wish I had poked around the internet more first…

My drive still has power and it’ll spin if I put something in it, but I can’t get my computer to detect it.

I tried the regedit suggestions provided above, but those didn’t work. Help? Please?


#19

Sorry Masahiro :frowning:

I have the same problem, there is power and will spin just like you, but still not detecting it.

Hopefully someone can offer both us some further assistance!

Goodluck and let me know if you find out a way to save your drive!


#20

Well, here’s my sad perhaps inevitable follow-up question. If I want to buy a replacement drive, what will fit? I’ve been browsing at newegg.com … Is pretty much any slim drive going to work? Will I still be able to keep the original front panel?

Of course, I’d like drive replacement to be a last resort. But, I’m actually not terribly opposed to buying a new drive – the SN-324F was not working too well with me actually (particularly with DVDs)…