I have managed to break 2 drives -Help!

vbimport

#1

Hi,

Firstly, apologies if this thread is in the wrong place. I’ve just registered, as people here seem to know their stuff and I am kind of desperate.

I was reinstalling my PC and everything was working, when I decided to try and be clever and flash the firmware on my CD-RW drive. I used the wrong thing and now both my CD-RW (hl-dt-st cd-rw gce-8483b) and my DVD-RW (BenQ DW1620) are both recognized only by my PC’s BIOS. Windows sees what drives they are (i.e. names are correct), but says “This device is disabled. (Code 22). Click Enable Device to enable this device.” It is then unable to enable either drive.

Before I go and buy some new hardware - is there any way that I can get the drives “unflashed”?

Mark


#2

http://support.microsoft.com/kb/310123


#3

Thanks for the feedback - I have tried enabling, but the message I get is that Windows cannot enable the device…

It’s looking like I get to go shopping for some new hardware - after I have finished beating myself up for being so stupid.


#4

Basically, what you want to do is to connect only one drive at a time to your motherboard and see what happens. For example, the DVD-RW might be OK and the problem might be only due to the fact that it’s connected on the same IDE channel with a CD-RW brick.

In any case you can then try reviving one (or both) brick drives using official or unofficial firmware flashers. But this time make sure you use correct flashers and firmware images.


#5

That sounds like a plan. Is there any generic flashing software that would be good for both the LG and BenQ drives? I have had a look and I can find ones for NEC and Liteon, but nothing that I would be able to use. Is there a “one size fits all” application?

Sorry to ask so many basic questions. I have certainly learnt my lesson to only use correct flash images!


#6

I have managed to sort this out. I am not sure why what I did worked but it has.

What I did was:

  1. Tell the PC BIOS that there are no drives (Dell Dimension)
  2. Turn off PC and disconnect drives
  3. Turn on PC and start Windows
  4. Turn off PC and swap drives’ IDE connection - i.e. Drive that was connected to port 1 in port 2 and vice versa
  5. Turn on PC and tell it drivesz are there in BIOS
  6. Restart Windows

Dunno why, but this worked.

Thanks for feedback from the forum