I Did Everything And Still DMA is disabled...GOD!

Hello PPL…This is My First Post here…hope to find a solution to my problem

Well, as u can see i simply can’t get my CD-RW to DMA mode…windows from some unknown reasons is not doing it…

Model: GCE-8320B
Manufacturer: LG

AND PPL, when i say everything i mean EVERYTHING…
I have no Idea what should i be doing now…

Maybe I’m doing something wrong?

Anyway, I think the problem is somehow related to my BIOS settings…

My motherboard is Intel D845BG if it matters

Here Is A picture of my BIOS formation

BTW: I can’t change Multi-Tranfer Sector, PIO Mode and Ultra DMA when type is set to Auto…it’s chooses the settings on it’s own and locks them

you have dma set to disabled. sorry I didn’t read the bottom of your post,

Try setting it to USER as it says in the instructions at the top of your bios image

my DMA is enabled…

and here are my settings at the moment

Type- User
Multi-Transfer Sector- 16 Sectors
PIO Mode- Mode 4
Ultra DMA- Mode 5

Is something wrong ?

you said you tried everything, did you enable DMA in the device manager? is it available in the ide controllers? if not uninstall ide controller that the drive is on and reboot.Then enable in the control panel not the bios

Nice Avatar!

that was the first thing I tried to do…

then i started to seek for another ways to enable it…

BTW…I’m Sure my BIOS settings are right cause my CD-ROM (LG CRD-8522B)
is on the same settings as the GCE-8320B and Multi-Word DMA Mode 2 is enabled for it on windows…

so why CD-RW still stuck on PIO ?

Here are the drives intalled on my system

Primary IDE Master: Maxtor 6Y080P0 [Ultra DMA Mode 5]
Primay IDE Slave: WDC WD400EB-00CPF0 [Ultra DMA Mode 5]
Secondary IDE Master: LG CD-ROM CRD-8522B [Multi-Word DMA Mode 2]
Secondary IDE Slave: HL-DT-ST CD-RW GCE-8320B (PIO) arghhhhhhh

@ SMoKe MaN,

I know you have stated you have done everything to set your DMA but below is a Forum link that provides extensive information on setting DMA mode.

Suggest viewing the below Forum Posting and note Forum Member ireland’s (posting #4) comments concerning setting DMA.

http://club.cdfreaks.com/showthread.php?t=150240

Best Regards,
bjkg

I’ve read ireland’s post and i can assure you i tried everything…

from unistalling channels to hacking the registry…
and nothing worked…

EDIT:
I forgot to mention that i even formatted my drive and re-installed windows and still…same problem