I cant Install Directx 9.0c December 2005 dsound.inf

When I try install Directx 9.0c December 2005 Redlist I Envisage with this Error :

“An internal system error occurred.
Please refer to DXError.log and DirectX.log in your Windows folder to derermine problem.”

I several time download Directx 9.0c December 2005 and November 2005 but everytime I Envisage with this error

and when I go to DXError.log and DirectX.log see this Problem with dsound.inf :


[01/05/06 01:40:11] module: dsetup32(Sep 28 2005), file: setup.cpp, line: 6443, function: CSetup::InstallDirectXInfsFromInfSection

Installation of ‘C:\WINDOWS\System32\DirectX\DX113.tmp\dsound.inf - [DefaultInstall]’ failed.


01/05/06 01:40:11: dsetup32: Installation of ‘C:\WINDOWS\System32\DirectX\DX113.tmp\dpvoice.inf - [DefaultInstall]’ succeeded.
01/05/06 01:40:11: dsetup32: Installation of ‘C:\WINDOWS\System32\DirectX\DX113.tmp\dmusic.inf - [DefaultInstall]’ succeeded.
01/05/06 01:40:11: dsetup32: CSetup::ExecuteInf(): SetupInstallFromInfSection() failed, error = 5.
01/05/06 01:40:11: dsetup32: CSetup::ExecuteInf(): Unable to proceed C:\WINDOWS\System32\DirectX\DX113.tmp\dsound.inf:[DefaultInstall]. The file may be damaged.
01/05/06 01:40:11: dsetup32: CSetup::InstallDirectXInfsFromInfSection(): Installation of ‘C:\WINDOWS\System32\DirectX\DX113.tmp\dsound.inf - [DefaultInstall]’ failed.
01/05/06 01:40:11: dsetup32: SetupForDirectX: Restoring Backups
01/05/06 01:40:12: DXSetup: DSetupCallback(): Phase = 2, Steps = 0
01/05/06 01:40:15: dsetup32: Installation ended with value -9 = Internal or unsupported error
01/05/06 01:40:23: DXSetup: WM_APP_ENDINSTALL
01/05/06 01:40:23: DXSetup: ~CDXWSetup()

hey this is my first post and I’m sorry to say that I’m having the exact same problem, it all started when i tried to re-install Call Of Duty 2 and it wouldn’t complete the DirectX 9.0c setup with the same response…

In the process now of looking into it, have u downloaded service pack 2 for windows apparently thats fixes a lot of problems, i also tried loading DirectX from other sauces other games and such with no luck try that…

Sorry if this was no help but maybe some1 out there must know why this error is occuring :sad:

Hey Guys i had the same problem as you 2 and ive just resolved my problem, When i went to start run and typed in dxdiag i noticed at the bottom of the page there was no directx installed so i just reinstalled service pack 2 and the problem was fixed right away . Hope this fixes ur problems .

You might want to recheck the Directx 9.0c redist they have a 2006 version out.