I can't burn Primeon BD DL after updating burner firmware (Pioneer BDR-209DBK)


#1

Hi all,

The past week I bought one spindle of Primeon double layer blu-ray, I read good things about them, even people burning it with same burner that I have without problems.

DISCS REFERENCE: 2761311

MEDIACODE: RITEK-DR3-000

As soon as I received it tried to burn one disc, no problem at all, it seems to be a quality media. Then I was just curious if maybe there was a new firmware for my burner, several months without checking for a new one, and I guess it, there were new firmwares for latest Pioneer burners (I think), these models: BDR-211EBK, BDR-211UBK, BDR-209EBK, BDR-209UBK (BDR-2209), BDR-209DBK, BDR-S09XLB y BDR-S09XLT

My burner is the Pioneer BDR-209DBK, and my previous firmware 1.34, and the new one is 1.50 (updated Mar 2, 2018)

As you can suppose, I could not resist and updated my burner with the new firmware, and now I can’t burn Primeon blu-ray discs, I’m very dissapointed.

Please, I want to revert to the previous firmware, or any other way to solve this problem. I think firmware 1.50 is not properly tuned-up.

Kind regards

PS: I sent an e-mail to Pioneer in my country, and they gave my an e-mail that is not working -> pioneer-optical [at] trinitygroup [dot] cz

Very funny, you can see this e-mail here: http://www.pioneer-optical.eu/Selling_Spot.asp

An even more, there are another in a different section not working at all as well


#2

You can use DVRTool to downgrade:

Be sure to use the correct firmware for your drive!


#3

Thank you so much, I’m a newbie in this forum and really don’t know how to proceed, where can I download that tool?.

I have the right firmware I got it from the firmwares thread.

Kind regards


#4

So did it work, or do you need more info?


#5

Ritek dual layer BD-R discs sometimes have a huge variety of quality inside a single cakebox… did you try a disc from the bottom of the cake?

If you still want do downgrade, here is a download link

https://forum.cdrinfo.pl/attachments/f29/74521d1451663942-dvrtool-v1-0-firmware-flashing-utility-pioneer-dvr-bdr-drives-dvrtool_v1.02.zip


#6

Thank you so much dudes for your answers, yes finally I was able to revert my burner to the previous firmware using DVRTool v1.02 and I get the same problem !!

Yes @Vogelschreck, I tried second disc of the spindle when I updated to firmware 1.50 and faced the problem, and get same result so I was convinced that it was a firmware issue.

Thanks a bunch @Oinker for lighting my way in the beginning :slight_smile:

So I don’t recommend to purchase these discs.

Kind regards


#7

Ok.
Now with firmware 1.34 it works again?


#8

Glad I could help. :slight_smile:
But yeah, avoid RiCrap. :wink: Regarding dual layer just use Panasonic, Verbatim or CMC.


#9

The burner seems to be ok, I still have not try to burn different discs, I will check other Primeon discs from the spindle. And of course I will try Verbatim, the ones I’m used to.

It seems to me that first one of the spindle is the only one usable ROFL (Primeon discs)

Kind regards


#10

Ok, you still could try different speeds.
Or maybe your image file is corrupt? (if it is an image)

If you can buy MediaRange Dual Layer discs, buy these. They are even cheaper than Primeoen and have the same MID as Verbatim discs.


#11

Believe me, I tried differente speeds :grinning:

And I don’t suggest you to buy Mediarange DL, as you said, they have same MID that SOME Verbatim DL (20 disc spindle as far as I remember) so apparently are the same quality BUT NOT, believe me, something is different because if you burn at more than 2x you get a coaster. Aside from this, the Verbatim ones was possible to burn them at 2x on my previous burner BH16NS40, but not the Mediarange discs, I was forced to burn them at 4x as a minimum speed, and ALWAYS failed after (verifying) layer break.

I don’t recommend to buy Mediarange either (Mediarange MR-507)

Thanks for your advice

Kind regards


#12

Oh ok, then there are some bad batches available, too.
The ones I have, are very good.

Maybe you can only be safe with the expensive discs, real Verbatim or Panasonic.


#13

Hi again dudes!

Oh my !!! Shame on me!, the problem was not the firmware nor the Primeon discs, just the blu-ray I was trying to burn, it was not properly unprotected, despite BDinfo did not indicate nothing wrong, even playing the movie.

My mistake was trying to burn always the same blu-ray using Primeon discs, I burnt different ones with Verbatim but not this one . . .

Primeon discs seems to have a very decent quality by the way.

Kind regards