I broke my DW-D22A - Won't burn

vbimport

#1

Hi,

I seem to have managed to break my Sony DW-D22A burner after some botched updating. I tried updating it to BYX5 I believe, changing it to a Sony DRU-710A with the .exe installer. It installed and then on the inquiry it failed. After I realised it was botched and refused to do anything, I tried downgrading to the BYS3 firmware (or possibly BY03, I don’t remember), and it onced again botched. I restarted my computer and somehow it was working again. I burned the disks I needed to burn and then figured I could keep screwing around with it 'cause I could just backtrack again if something went wrong. I think I tried an unpatched BYX5 firmware this time and it failed, again…I reverted it the same way as before, except it wasn’t working this time. Since then I’ve been hopping around trying to find something that worked. Last night I tried to flash it with LtnFW hoping it would be a more direct approach and hopefully fix it. I flashed with BYS3 without updating the Boot Code first, and then once that didn’t fix it I tried it with updating the Boot Code. My drive still doesn’t burn DVDs, but reads them fine. I’ve used LtnFW to compare the firmware and it’s identicle, and now I’m totally out of ideas.

Here is the drive info from InfoTool, if you need the whole report let me know.

Drive Information
------------------
Drive                      : SONY     DVD RW DW-D22A  
Type                       : DVD±R/RW DL Recorder
Firmware Version           : BYS3
Buffer Size                : 2 MB
Date                       : ?
Serial Number
Vendor Specific            :   Nov17 ,2004        
Drive Letter               : D:\
Location                   : 3:3
Mechanism                  : Tray
Read Speed                 : 8.0 , 6.0 , 4.0 , 2.0 , 1.0  X
Write Speed                : 8.0 , 6.0 , 4.0 , 2.0 , 1.0  X

Read CD Text               : Yes
Return C2 Pointers         : Yes
Read CD-R                  : Yes
Read CD-RW                 : Yes
Read DVD-ROM               : Yes
Read DVD-RAM               : No
Read DVD-R                 : Yes
Read DVD-RW                : Yes
Read DVD+R                 : Yes
Read DVD+RW                : Yes
Read DVD+R DL              : Yes
Read BD-ROM                : No
Read BD-R                  : No
Read BD-RE                 : No
Read Digital Audio         : Yes
Read CD+G                  : Yes
Read VideoCD               : Yes

Write CD-R                 : Yes
Write CD-RW                : Yes
Write DVD-R                : Yes
Write DVD-RW               : Yes
Write DVD-R DL             : No
Write DVD+R                : Yes
Write DVD+RW               : Yes
Write DVD+R DL             : Yes
Write DVD-RAM              : No
Write BD-R                 : No
Write BD-RE                : No
Buffer Underrun Protection                                                                                                                                                                                                                                                                : Yes
Mount Rainier              : No
Modes                      : Packet, TAO, DAO, SAO, RAW SAO, RAW DAO, RAW SAO 16, RAW SAO 96, RAW DAO 16, RAW DAO 96

Region Protection Control  : RPC II
Region                     : 1
Changes User               : 4
Changes Vendor             : 4

Disc Information (D:\)
-------------------
Type                   : Blank DVD-R

Thanks for your time,
Matt


#2

Hi & welcome! :slight_smile:

Changing firmwares isn’t the solution to all and any burner problem. If InfoTool reports it correctly and it reads discs, I’d guess some software/driver problem is preventing you from burning.

The latest firmware for your drive is BYS6 by the way: http://www.cdr.cz/dvd_rekordery/sony/dru710a.html. This should allow you to burn currently available media.


#3

Hey,

Thanks for the reply and the firmware link, I wasn’t aware there was a BYS6. I installed it and the same thing happens, it ‘Programs’ 100%, then a minute or two into the ‘Inquiry’ it fails.

I understand that firmware upgrades won’t solve all my problems, it’s just that my drive would burn properly 85% of the time before I touched the firmware, so I’m almost positive that this is the problem. I’ve tried uninstalling the drive from windows then reinstalling it and then trying to update the drivers and still no luck.

Here’s my burn log if it is of any help :confused:


Windows XP 5.1
IA32
WinAspi: File 'Wnaspi32.dll': Ver=4.71 (0002), size=45056 bytes, created 16/07/2004 4:24:34 AM 
ahead WinASPI: File 'C:\PROGRA~1\Ahead
ero\Wnaspi32.dll': Ver=2.0.1.74, size=164112 bytes, created 26/10/2004 6:35:34 PM 
Nero Version: 6.6.0.15
Internal Version: 6, 6, 0, 15h
 (Nero Express)
Recorder:             <SONY DVD RW DW-D22A>     Version: BYS6 - HA 3 TA 3 - 6.6.0.15
 Adapter driver:      <>                        HA 3
 Drive buffer  :      2048kB
 Bus Type      :      default (0) -> ATAPI, detected: ?
CD-ROM:               <         56X CD-ROM      >Version: 6.5G - HA 0 TA 1 - 6.6.0.15
 Adapter driver:      <nvidesm>                 HA 0

=== Scsi-Device-Map ===
DiskPeripheral       : ST3120022A              3.54   nvidesm Port 0 ID 0  DMA: Off
CdRomPeripheral      : SONY    DVD RW DW-D22A  BYS3   nvidesm Port 0 ID 0  DMA: Off
CdRomPeripheral      :         56X CD-ROM      6.5G   nvidesm Port 0 ID 1  DMA: Off
CdRomPeripheral      : Generic DVD-ROM         1.0    d347prt Port 2 ID 0  DMA: Off

=== CDRom-Device-Map ===
 56X CD-ROM                E:   CDRom1
Generic DVD-ROM            F:   CDRom2
SONY DVD RW DW-D22A        D:   CDRom0
=======================

AutoRun : 1
Excluded drive IDs: 
WriteBufferSize: 83886080 (0) Byte
ShowDrvBufStat : 0
BUFE           : 0
Physical memory     : 1023MB (1048048kB)
Free physical memory: 497MB (509016kB)
Memory in use       : 51 %
Uncached PFiles: 0x0
Use Inquiry    : 1
Global Bus Type: default (0)
Check supported media : Disabled (0) 

14.3.2007
ISO compilation
3:02:40 PM	#1 Text 0 File Isodoc.cpp, Line 6314
	Iso document burn settings
	------------------------------------------
	Determine maximum speed : FALSE
	Simulate                : FALSE
	Write                   : TRUE
	Finalize CD             : TRUE
	Multisession            : FALSE
	Burning mode            : DAO
	Mode                    : 1
	ISO Level               : 1 (Max. of 11 = 8 + 3 char)
	Character set           : ISO 9660
	Joliet                  : TRUE
	Allow pathdepth more than 8 directories : TRUE
	Allow more than 255 characters in path  : TRUE
	Write ISO9660 ;1 file extensions        : TRUE
	
3:02:40 PM	#2 Text 0 File Reader.cpp, Line 127
	Reader running
	
3:02:40 PM	#3 Text 0 File Writer.cpp, Line 122
	Writer SONY     DVD RW DW-D22A   running
	
3:02:40 PM	#4 ISO9660GEN -11 File geniso.cpp, Line 3309
	First writeable address = 0 (0x00000000)
	
3:02:40 PM	#5 Text 0 File Burncd.cpp, Line 3231
	Turn on Disc-At-Once, using DVD media
	
3:02:40 PM	#6 Text 0 File DlgWaitCD.cpp, Line 269
	Last possible write address on media:  2298495 (510:46.45, 4489MB)
	Last address to be written:            1945551 (432:20.51, 3799MB)
	
3:02:40 PM	#7 Text 0 File DlgWaitCD.cpp, Line 281
	Write in overburning mode: NO (enabled: CD)
	
3:02:40 PM	#8 Text 0 File DlgWaitCD.cpp, Line 2477
	Recorder: SONY DVD RW DW-D22A, Media type: DVD-R
	 Disc Manufacturer: RITEKF - 1
	 Disc Application Code: 64, Disc Physical Code: 193
	
3:02:40 PM	#9 Text 0 File DlgWaitCD.cpp, Line 447
	>>> Protocol of DlgWaitCD activities: <<<
	=========================================
	
3:02:40 PM	#10 Text 0 File ThreadedTransferInterface.cpp, Line 830
	Setup items (after recorder preparation)
	 0: TRM_DATA_MODE1 ()
	    2 indices, index0 (150) not provided
	    original disc pos #0 + 1945552 (1945552) = #1945552/432:20.52
	    relocatable, disc pos for caching/writing not required/ required, no patch infos
	    -> TRM_DATA_MODE1, 2048, config 0, wanted index0 0 blocks, length 1945552 blocks [SONY     DVD RW DW-D22A]
	--------------------------------------------------------------
	
3:02:40 PM	#11 Text 0 File ThreadedTransferInterface.cpp, Line 1043
	Prepare recorder [SONY     DVD RW DW-D22A] for write in CUE-sheet-DAO
	DAO infos:
	==========
	 MCN: ""
	 TOCType: 0x00; Session Closed, disc fixated
	 Tracks 1 to 1:
	   1: TRM_DATA_MODE1, 2048/0x00, FilePos             0             0    3984490496, ISRC ""
	DAO layout:
	===========
	 __Start_|____Track_|_Idx_|_CtrlAdr_|_RecDep__________
	       0 |  lead-in |   0 |    0x41 | 0x00
	       0 |        1 |   0 |    0x41 | 0x00
	       0 |        1 |   1 |    0x41 | 0x00
	 1945552 | lead-out |   1 |    0x41 | 0x00
	
3:02:41 PM	#12 Phase 24 File dlgbrnst.cpp, Line 1832
	Caching of files started
	
3:02:41 PM	#13 Text 0 File Burncd.cpp, Line 4116
	Cache writing successful.
	
3:02:41 PM	#14 Phase 25 File dlgbrnst.cpp, Line 1832
	Caching of files completed
	
3:02:41 PM	#15 Phase 36 File dlgbrnst.cpp, Line 1832
	Burn process started at 8x (11,080 KB/s)
	
3:02:41 PM	#16 Text 0 File ThreadedTransferInterface.cpp, Line 2643
	Verifying disc position of item 0 (relocatable, disc pos, no patch infos, orig at #0): write at #0
	
3:02:41 PM	#17 Text 0 File DVDR.cpp, Line 2357
	Recording mode: Sequential Recording Mode
	
3:02:41 PM	#18 Text 0 File Mmc.cpp, Line 21663
	Set BUFE: Power-Burn -> ON , Adapt writespeed to disc : ON
	
3:02:41 PM	#19 Text 0 File DVDR.cpp, Line 2511
	Start write address at LBA 0
	DVD high compatibility mode: Yes
	
3:02:41 PM	#20 Text 0 File Cdrdrv.cpp, Line 8821
	---- DVD Structure: Physical Format Information (00h) ----
	Layer: 0, Address: 0 (0 h), AGID: 0; Length: 2050
	 Book Type: DVD-R   (2), Part Version: 5
	 Disc Size: 120 mm,      Maximum Rate: <not specified> (F h)
	 Number of Layers: 1,    Track Path: Parallel Track Path (PTP),  Layer Type: recordable
	 Linear Density:         0,267 um/bit,  Track Density:  0,74 um/track
	 Starting Physical Sector Number of Data Area: 30000 h (DVD-ROM, DVD-R/-RW, DVD+R/+RW)
	 End Physical Sector Number of Data Area:      0 h
	 End Sector Number in Layer 0:                 0 h (LBN: FFFD0000 h, 4193920 MB)
	 Data in Burst Cutting Area (BCA) does not exist
	  Start sector number of the current Border-Out: 0 h
	  Start sector number of the next Border-In:     0 h
	 Media Specific [16..63]:
	      00 60 00 10 20 30 40 50 - 00 00 00 21 00 00 00 00    .`...0@P...!....
	      00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00    ................
	      00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00    ................
	
3:03:05 PM	#21 SCSI -500 File Cdrdrv.cpp, Line 1436
	SCSI Exec, HA 3, TA 3, LUN 0, buffer 0x04690000
	Status:     0x02 (0x03, SCSI_ABORTED)
	HA-Status   0x10 (0x0A, SCSI_HASTAT_REQUEST_SENSE_FAILED)
	TA-Status   0x00 (0x00, OK)
	Sense Key:  0x05 (KEY_ILLEGAL_REQUEST)
	Sense Code: 0x26
	Sense Qual: 0x02
	CDB Data:   0x2A 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x20 0x00 0x00 0x00 
	Sense Data: 0xF0 0x00 0x05 0x00 0x00 0x00 0x00 0x00 
	            0x00 0x00 0x00 0x00 0x26 0x02 
	
3:03:09 PM	#22 Text 0 File Cdrdrv.cpp, Line 1288
	15:03:09.234 - SONY DVD RW DW-D22A\H3 T3 : Queue again later
	
3:03:13 PM	#23 SCSI -1076 File Cdrdrv.cpp, Line 1436
	SCSI Exec, HA 3, TA 3, LUN 0, buffer 0x04C30600
	Status:     0x04 (0x01, SCSI_ERR)
	HA-Status   0x00 (0x00, OK)
	TA-Status   0x02 (0x01, SCSI_TASTATUS_CHKCOND)
	Sense Key:  0x06 (KEY_UNIT_ATTENTION)
	Sense Code: 0x28
	Sense Qual: 0x00
	CDB Data:   0x2A 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x20 0x00 0x00 0x00 
	Sense Data: 0x70 0x00 0x06 0x00 0x00 0x00 0x00 0x0A 
	            0x00 0x00 0x00 0x00 0x28 0x00 
	
3:03:13 PM	#24 CDR -1076 File Writer.cpp, Line 311
	Disc changed
	
3:03:13 PM	#25 Text 0 File ThreadedTransfer.cpp, Line 228
	all writers idle, stopping conversion
	
3:03:13 PM	#26 Text 0 File ThreadedTransfer.cpp, Line 222
	conversion idle, stopping reader
	
3:03:14 PM	#27 Text 0 File DVDR.cpp, Line 2749
	EndDAO: Last written address was -1
	
3:03:14 PM	#28 Phase 38 File dlgbrnst.cpp, Line 1832
	Burn process failed at 8x (11,080 KB/s)
	

Existing drivers:
File 'Drivers\CDRALW2K.SYS': Ver=8.0.0.212 , size=2560 bytes, created 19/05/2006 5:16:24 PM 
File 'Drivers\ASPI32.SYS': Ver=4.71 (0002) built by: WinDDK, size=16512 bytes, created 16/07/2004 4:24:34 AM 
File 'Drivers\PXHELP20.SYS': Ver=3.00.33a, size=36528 bytes, created 24/08/2006 11:47:00 PM (Prassi/Veritas driver for win 2K)
File 'Drivers
videsm.sys': Ver=5.10.2600.0307 built by: WinDDK, size=20224 bytes, created 13/11/2002 3:10:00 AM (Adapter driver for src)

Registry Keys:
HKLM\Software\Microsoft\Windows NT\CurrentVersion\WinLogon\AllocateCDROMs : 0 (Security Option) 

Thanks again.


#4

Hi, welcome :slight_smile:

First of all you need to get DMA enabled from the looks of things ;)…there’s a link in my sig that will help you do that. :slight_smile:

Edit: I see you’re using nVidia IDE drivers, so I’m not sure that DMA reading is correct, on second look. Maybe uninstall those and use default M$ IDE drivers.

You’re also using Ritek F1 discs, so a change of media could also be an option, I’d recommend Verbatim. :slight_smile:


#5

I took a look at your guide and I don’t have any ‘Channel’ items in the section. All I have there is ‘NVIDIA nForce IDE Controller’. And how would I go about uninstalling these nVidia drivers? :stuck_out_tongue:

And yes, I know, these disks suck. I figured Memorex was decent quality (my old batch was working fine), but I picked these faster ones up and they’re really bad on game systems, lots of skipping no matter what speed I burn at. I’d buy new ones, but I still have way too many leftover and nobody I know wants them. Are Verbatim disks directly available to buy, or are they cloaked under other company names? (i.e. Memorex are Ritek disks).


#6

Hopefully someone can tell you how to uninstall the nVidia drivers, I don’t use them unfortunately.

As for Verbatim discs - yep, they always have a Mitsubishi Chemicals (Verbatim’s parent company) code, except for the Pearl White series, which can be Ritek or CMC I think. So steer clear of the Pearl Whites and you’re pretty safe. :slight_smile:


#7

Do you know of any (Canadian) stores that would carry them? Only one I’ve found is Future Shop and they don’t seem to have 8x -R. I’ll pick some up once I find someone to take my huge stack of RitekF1s…

Thanks for your advice though, hopefully someone will be able to guide me to fix my burner :slight_smile: I’m hoping…


#8

Ritek F1 is poorly supported in many drives, especially older ones like yours. Do you even get 8x burn speed available in Nero? Using BYX5 or CS0T from codeguys.rpc1.org should even give you 12x, if it’s included in firmware at all.

For the flashing problem, try doing it in Windows Safe Mode (so the nVidia drivers can’t interfere).

For reverting to M$ drivers first you have to determine which IDE Channel your drive is connected to in Device Manager. Then you may have the option to “Roll back driver” and if not select “Update driver” and manually choose “Standard PCI IDE driver” from the list (or similar, I’m not on XP right now). If all went well the “Driver provider” under Properties should read “Microsoft” afterwards.


#9

The flash still failed in safe mode :frowning: And I have no idea which IDE Channel my drive is on, I don’t even have any ‘Channel’ items in the ‘IDE ATA/ATAPI Controllers’ list in Device Manager.


#10

FutureShop’s the only shop I’m aware of (maybe you could start a new thread in the Blank Media Forum asking this, plenty of Canadians in there! :))…but if you can shop online there’s also www.blankmedia.ca :wink:


#11

Then uninstall the nVidia IDE drivers (chipset, not graphics if you have those) via Add/Remove Programs or by running the setup again.


#12

sigh I always have the hardest time fixing things…the only nVidia drivers listed in Add/Remove Programs are display and audio drivers.


#13

In Device Manager, where you see NVIDIA nForce IDE Controller, try to “Rollback driver” or alternatively choose “Update driver” and manually select (don’t let Windows search for it) “Standard Dual Channel PCI IDE Controller” + reboot. The Primary and Secondary IDE Channels should be back then. Verify you have “Driver provider” Microsoft.


#14

Alright, well, it successfully rolled the driver back to ‘Standard Dual Channel PCI Ide Controller’ and then rebooted. I then successfully flashed the drive to BYS6 and rebooted. Then I tried to burn my disk with nero and it failed the lead-in saying there was a ‘Power Calibration Error’. I then tried to burn it with DVD Decrypter. It too failed the lead-in with a ‘Power Calibration Error’, but it retried and then started to burn the image. It got to 88% and then the speed plumited to 0. It sat there for a good 5 minutes and then failed with a ‘Command Sequence Error’, making me a nice coaster.

I thank you for getting me this far though :slight_smile:


#15

Is this still with the Memorex/Ritek discs? Which burn speeds are available to you in Nero and which one did you select? Is the burner’s “Current transfer mode” shown as “Ultra DMA Mode 4” in Device Manager?


#16

Yes this is still the Ritek Memorex discs. They have worked in the past for me though. In Nero I have 4x, 6x and 8x available, and I chose 8x. In my Primary IDE Channel it says Ultra DMA Mode 5 and in my Secondary it says Ultra DMA Mode 2.


#17

“Ultra DMA Mode 2” says your burner is hooked up with an old 40-wire ribbon cable. Most modern drives benefit from (and some like Pioneer positively need) 80-wire, providing UDMA4.

Maybe your drive’s laser is getting weak, it’s a couple years old now. Try it with some better discs like Verbatim though and you can give 4x a go with the Memorex.


#18

<3 The burn worked when I tried it at 4x. I’ll give it a shot again in a bit at 8x with something else just to check if it was a freak occasion that killed it last time. I’d look into the ribbon but I need a whole new setup altogether, which I can’t afford 'cause I need a laptop for university :frowning: so I’m not going to bother fiddling with anything.

And yes, new discs are on the top of my to-do list, well, second on my list. First is finding someone who wants my 70 remaining Memorex discs :wink:

Thanks again for your help.


#19

Try uninstalling your nVidia IDE controllers using this method:

To get rid of that unwanted driver, device, or service:

  1. Open the “Start” menu and choose “Run…”

  2. Type in “cmd” (without the quotes) and click “ok”.

  3. At the cmd prompt, type in “set devmgr_show_nonpresent_devices=1” (without the quotes) and press enter. (Note that nothing seems to happen–this is ok. We are actually setting an environment variable which is going to help us to see hidden devices)

  4. On the next cmd prompt line, type in “devmgmt.msc” (without the quotes) and press enter. This will launch the Windows Device Manager Console.

  5. In the Device Manager Console, from the “View” menu, select “Show Hidden Devices”.

This process should allow you to see the hidden devices that you would not normally see and uninstall them.