I am unable to turn the camera on

vbimport

#1

We have followed the troubleshoot hints and removed the batteries and checked the connections


#2

[QUOTE=JennyAllen;2508786]We have followed the troubleshoot hints and [B]removed the batteries[/B] and checked the connections[/QUOTE]

PUT… THE … BATTERIES … BACK … IN :stuck_out_tongue:

Ahem…ok, but please check which way around they have to go…seriously!

Batteries fresh or fully charged?

Is this a new camera?

What brand and model?

…and welcome to the MyCE show :wink:


#3

It is a Cannon Legria HF200 - 1 week old we have checked the batteries and they are in the right way. The batteries are not fully charged but have some charge. We are unable to charge or do anything with it at this time


#4

[B]Two possible solutions[/B]

  1. The [B]power-on button[/B] for this particular model seems to be difficult to push to the “on” position. Please try this again…take care to push it far enough. Also, push and hold a couple of seconds.

  2. If all else fails, you may have to contact [B]Canon Service[/B] as there would appear to be a fault with the camcorder.

[ul]
[li]by email https://www.usa.canon.com/consumer/controller?act=SupportMailerAct&fcategoryid=269&modelid=17994
[/li][/ul]

[ul]
[li]toll-free technical support, please call 1 (800) 828-4040
[/li][/ul]

[B]Curious[/B]…why is it not possible to fully charge the battery???


#5

[QUOTE=JennyAllen;2508786]We have followed the troubleshoot hints and removed the batteries and checked the connections[/QUOTE]

Did you not read the owner/user manual how to operate the camera??? Instead you go to trouble shooting??? This is the part I don’t get??? Also the camera should come with charger base or plug you plug into the camera and charge the unit before using it if it is has rechargeable batteries.