I accidentally deleted my BenQ DW 1655 BCGB firmware!

vbimport

#1

[qanda]This thread is about the BenQ DW1655. Click here to see full specs[/qanda]I was having a lot of problems with my pc so I decided to do a format. I somehow deleted the firmware for my BenQ DW1655. I need the original BCGB firmware but I can’t find it anywhere. Each link I followed had some Chinese writing but no link for a download. The BenQ DW1655 sites that I found didn’t have BCGB firmware downloads on them. Right now, my computer is dead because I deleted a lot of files, including my System Restore Points.

A fast reply with a good link is so needed. . . no joke links PLEASE.

Hart


#2

http://download.cdfreaks.com/download/226

From this post that I just saw within the past day: http://club.cdfreaks.com/2183119-post15.html


#3

Hi Albert . . . thanks so much! I have it on a thumb drive and I’m heading downstairs to my computer to install it. I’ll be praying all the way there!


#4

I just tried to install the firmware but I got a message that said that “BCGB - No Device Found!.” I removed the cable from the drive’s port and reinserted it and did the same with the mobo connection, but nothing happened. I didn’t get a message that “New Hardware found.”

Could it have broken when I removed the firmware?


#5

Don’t know how I didn’t detect this before, but…

If you’re talking about drivers for the drive [which are a different thing from firmware], then you have nothing to download; the operating system uses generic drivers for all drives.

The firmware resides on the drive, and cannot be deleted by just doing a reformat.

Have you installed drivers for all other devices in your computer? Can you still open and close the drive? Are there any issues in device manager?


#6

My DVD drive used to be listed there. I’ve been having a lot of problems with my computer. A couple of days ago, I did a Repair of Windows but my settings kept changing. I thought I might have a Hijacker or a Trojan so I ran several anti-virus/trojan programs and HijackThis but they showed nothing. So I decided to do a complete format but I wanted to delete some of the files on the drive because some things remain on my drive after a format and I wanted it to be as clean as possible. I even copied files from another drive and then deleted them so that the old files were overwritten. I didn’t delete any files that were named BenQ. I was told to never update the drivers for it and I never have and I never had any problems with it. It worked great. I went into BIOS and set the DVD drive as first in boot priority and put my Windows disk in the DVD drive, but it booted straight to my desktop. I rebooted and the same thing happened. I don’t know why it’s doing this.

I just installed Windows Installer and a number of my other programs, drivers and codecs.

I also just tried to install BCGB but it still won’t install. If my os uses generic drivers for all drives and it’s not recognizing my BenQ, then something else is wrong too. It worked fine before I deleted all the files and programs before I tried to format.

I usually crop screenshots using MGI Photo Suite but it’s on a CD so I can’t install it. I’ve attached a screenshot of Device Manager where it shows that Audio Device on High Definition Audio Bus has a yellow question mark on it. I don’t know what the device is though.



#7

If your PC refuses to boot from the drive, then odds on it’s a hardware problem.

Have you tried a different IDE cable? It has been known for cables to go bad. If you could eject the tray to place the Windows disc in the drive, then there’s obviously power going to it.

If that fails to work, then the next thing I would suggest would be to try the BenQ in a different PC. :slight_smile:

Welcome to CDF, BTW :slight_smile:


#8

The drive door opens but it doesn’t read what’s on the disk. I gave my daughter my old CD drive. I’m going to remove it from her compuer and connect it to mine. Hopefully it’ll work and I can format my drive, which was what I was trying to do originally. Once it’s formatted, I’m hoping that My Computer will recognize the drive again.

I also lost my audio, which was the original reason for the format. I tried many fixes but none of them work. The speakers aren’t the problem. I connected my old speakers and they didn’t work either. After the format, I’ll know if these things were temporary or permanent.

When I boot up, I get a message from MS that says that it found a new piece of hardware but no drivers could be found for it. In Device Manager, there’s a yellow question mark on “Audio Device on High Definition Bus.” I don’t know why it’s looking for drivers for it. It was plug & play. Plug & Play is turned on in BIOS.


#9

[QUOTE=Hart;2184285]The drive door opens but it doesn’t read what’s on the disk. I gave my daughter my old CD drive. I’m going to remove it from her compuer and connect it to mine. Hopefully it’ll work and I can format my drive, which was what I was trying to do originally. Once it’s formatted, I’m hoping that My Computer will recognize the drive again.[/QUOTE]

When you plug the BenQ back into your PC (assuming it works in your daughter’s rig), I would still suggest changing the IDE cable - or at the very least, making sure all connections to the drive are in tightly.

Otherwise, you could very well end up with the same problem.

Something is preventing the PC (even at BIOS level) from recognising the drive. Since the power is OK, that just leaves the IDE cable - if that’s not working properly (or isn’t connected properly), then the PC cannot get info about the drive - and thus will not recognise it. :wink:

As for the audio thing, you may find that fixed once you format, reinstall the OS and all your mobo drivers - do visit your motherboard manufacturer’s site and get all the necessary drivers for your board before you wipe the drive and you should be fine. If not, I’m sure we can help you investigate further. But let’s deal with the BenQ issue first. :slight_smile:


#10

I’m going to use my cable when I connect my daughter’s CD drive. This way, I’ll know if it’s the cable. If the CD drive works, then I’ll use it to do the format and, like you said, everything will work properly. I don’t have a spare IDE cable. If the drive doesn’t work, I’ll have to get one. But I’m pretty sure that I messed it up when I deleted all the files when I was going to format. One or some of them might have been needed for the DVD drive. The audio is a different question. It stopped working out of the blue but, again, as you said, the format might fix that too. I’m hoping this is the case. If not, it’s probably because something happened to the on-board audio and I’ll have to buy an audio card. I only have an express port available so, if I have to buy one, I hope they sell ones that fix express ports.

I’ll let you know after I have my pc back up and running. Thanks for your suggestions :slight_smile:


#11

[QUOTE=Hart;2184547]But I’m pretty sure that I messed it up when I deleted all the files when I was going to format. One or some of them might have been needed for the DVD drive.[/QUOTE]

That wouldn’t affect the boot procedure or the drive being recognised at POST - in an ideal situation (all hardware working correctly and a bootable CD/DVD in the drive), you should be able to boot from your BenQ drive. :slight_smile:

Good luck - do let us know how you get on :iagree:


#12

I just connected my daughter’s CD drive to my computer, first using my cable and then using her’s. It’s not recognized in My Computer or Device Manager.

I really don’t want to ask this question, but could it be my mobo?


#13

It could be the motherboard

Are either of the drives show in the BIOS? If so, then it’s just something wrong with the installation of Windows [even if it is a fresh install]. If not, check to see if there are any BIOS settings that may be preventing its detection.

When you say you were having issues with your computer, what were some of the symptoms?


#14

Are either of the drives show in the BIOS?

Yes, both the CDROM drive and my main drive are shown in BIOS.

If so, then it’s just something wrong with the installation of Windows

Yes, I was going to do a format but wanted to delete as many files as possible because there are some files that remain on drive C after I format. I wanted to wipe it clean as much as possible. That’s when I deleted the files that are needed by my DVD drive.

I’ve attached pictures that I took when in BIOS, when my daughter’s CD drive was connected to my pc. I put my Windows disk in it and booted up but it went straight to Windows again, even though I have CD Drive as first in the Boot Sequence.

When you say you were having issues with your computer, what were some of the symptoms?

My problems started when I received some updates. The file wups isn’t removed from Windows but it’s removed from the Registry. MS gave me a wups batch file to install but it didn’t help. BITS and WMI were also not working. I first tried a Repair and it went along fine until I received Automatic Updates from MS, when it started to do the same thing. My computer also kept on changing my settings from x64 to x32 appearance. The last thing that made me decide to do a format was that I lost my audio. So I thought that a complete format would help but I first wanted to get rid of as many files as possible on drive C. After I deleted all the files that I could, I copied some videos over to the drive to overwrite the files that I deleted. When the drive was full, I deleted the video files and put my Windows disk in my DVD drive but it went straight to windows. Even when I didn’t have my DVD drive as first in boot sequence, I always got the prompt asking me if I wanted to boot up using the CD. This time I didn’t, so I changed the boot sequence in BIOS so that my DVD drive would be first in the boot sequence. When I booted up, it went straight to my desktop again, bypassing the BIOS setting.

The same thing happened when I connected my daughter’s CD drive.





#15

Another reason that I wanted to format is because I can no longer go to the MS update site to see if there are any updates. I was able to get Automatic Updates until one of them took wups out of my Registry. Once it did that, I could no longer get Automatic Updates. I also attached a notepad doc about the problems with wups. It also contains a link to the MS site. One of the updates takes wups out of my registry. If I knew which one, I wouldn’t install it.

Here are more photos that I took in BIOS and, some screenshots. I figured that a picture is worth 1,000 words and it’s better to see for yourself.

The third picture down shows that my Silver Classic settings change to Classic Settings. My taskbar has the Silver setting while Add/Remove Programs header shows Classic settings. Eventually, my taskbar reverted to Classic Settings. When I rebooted, everything was Silver settings for about 1/2 hour and then they went back to Classic settings.

For some reason, BIOS says that my floppy drive isn’t installed but I put a disk in it and it shows that it’s installed and working.

The BIG question here is, can I install Windows another way? Maybe copying the files onto floppy drives or a thumb drive? Or can I find out which files I need that I deleted that caused my DVD drive to stop being recognized in My Computer?






wups2 e.txt (2.16 KB)


#16

Since the BIOS isn’t seeing your optical drives, there’s nothing you can do to Windows to make it begin to see them again; it’s a hardware issue somewhere within your system, probably your motherboard. Deleting files in your operating system would not cause this issue.

Your floppy drive is enabled in your BIOS. It isn’t related to the Primary IDE, Master position; that should [theoretically] be the optical drive.

What are you system specifications? If it’s a brand name computer [Dell, HP, etc], what computer model is it? If it’s a home-built/self-built computer, what motherboard, power supply, and other devices were used to construct it?

Maybe try resetting your BIOS settings to their defaults. There should be an option to do that on the screen in the BIOS setup screen labeled “Exit”.


#17

I built my pc about 3 years ago:

[U]Computer Components[/U]

  • ASUS A8V-VM SE Socket 939 Micro ATX Motherboard - UDMA133, SATA (RAID)
    • VIA K8M890 + VT8237A
    • 2000/1600 HT/s
    • Dual-channel DDR400, Max 2GB
    • VIA Integrated Gfx in North Bridge K8M890
    • 1 x PCI-E X16, 1 X PCI-E X 1, 2X PCI
    • 2 *ATA133 ,2 x SATA
    • 10/100 LAN
    • 6-Channel audio
  • Seagate Barracuda 7200.10 SATA 3.0 Gb/s 320Gb hard drive (RAID array not set up)
  • AMD Athlon Gforce 8400 64 X2 4200+ Toledo 2.2GHz 2 x 512KB L2 Cache Socket 939 Processor
  • ARCTIC COOLING Freezer 64 Pro 92mm CPU Cooler
  • Corsair 620W PSU
  • Ballistix 2x1G RAM, 184-pin DIMM, 128MX64 DDR PC3200, Unbuffered
  • Envision EN9410e 19” LCD, 1280x1024 Resolution Monitor
  • BenQ DW1655 Lightscribe DVD+RW 16X8X16 DVD-RW 16X4X16 CDRW 48X48X32
  • MSI (nVidia GeForce 8400 GS) VGA NX8400GS-TD256EH RT Video Card
  • NORCO-4618 PCI-X / PCI eSATA / SATA II / SATA I 5-Port Controller Card RAID 0/1/5/10/JBOD
  • Belkin 3-port IEEE 1394 PCI Card

[U]Updated Drivers, Windows and Programs[/U]:

  • Windows XP Pro X64, SP2
  • NetFramework 2.0 Redistributable Pack for x64
  • NetFramework 3.0 Redistributable Pack for Windows XP
  • Asus Bios Update v 7020
  • ASUS PC Probe 2 v3.6
  • ASUS Update v7.09.02 Install Program for Windows 64bit
  • AMD Dual-Core Optimizer
  • nVidia 175.19 GeForce WinXP WHQL (x64 edition display drivers)
  • Realtek ALC883 Audio Driver V5.10.0.5296
  • Realtek High Definition Audio Driver R1.96
  • SCSI Pass Through Direct - SPTD v1.56 (64 bit)
  • SiI 3124 x64 1.1.13.0 logo (for SATA Controller Card)
  • SiI 3124 32-bit x 86 Windows BASE Controller Driver v1.3.20.0 logo (for SATA Controller Card)
  • SiI 3124 64-bit Windows SATARAID5 Driver v1.5.11.0
  • VIA Hyperion4in1 v456
  • VIA Hyperionpro v515a
  • VIA Hyperionpro v518a
    • INF V3.00A
    • AGP V4.60A
    • V-RAID V5.70A and RAID Tools v5.40
    • VIA IDE Falcon Storage Device driver v2.51A

#18

Maybe try resetting your BIOS settings to their defaults. There should be an option to do that on the screen in the BIOS setup screen labeled “Exit”.

HALLELUJAH !!!

My DVD drive is back :bow: Albert ! :clap: Well done!

I owe you my first born, but you’ll have to speak with her husband about it first, lol.

Thank you SO much. Hopefully, when I format, my audio will be back also.

I never would have thought of that in a million years. I am SO happy! My pc is my baby. I’m going to format now. I hope it works.

Any final words before I do it?


#19

Try loading your mobo audio drivers first.

Albert is going to be a daddy :eek: :bigsmile:


#20

Hi,

I just finished the format and installed most of my programs, codecs, filters, etc.

The first thing I did was install my Realtek audio driver and codec to see if the audio would come back but it didn’t. I installed Realtek AC’97 and Realtek High Definition Audio Driver. Then I installed my other codecs (DivX, Xvid, ffdshow, and GordianKnot Codec Pack) but none of it made a difference.

I followed Microsoft’s troubleshooter.

If your computer has a motherboard sound device and not an expansion sound card, make sure your sound device is turned on in your BIOS.

I did this and it’s turned on in BIOS.

Also

If your sound device is Plug and Play, and the Plug and Play BIOS in your computer is out-of-date or is not configured correctly, your computer might not recognize your sound device.
I didn’t have to do anything like this when I plugged in my old speaker or my new speakers. They worked without changing any settings in BIOS. BIOS is set to default. I updated the Realtek driver and codec and my speaker system still worked for about 8 months until a few days ago when it stopped. I didn’t change any settings. I was sleeping. The night before, it worked. When I woke up, I had no audio.

There is good news though. Prior to formatting, the adjustments for my audio were grayed out so that I couldn’t change anything. The settings are now available. I’ve adjusted them but I still have no sound.