Huge Benq 1620 problems

vbimport

#1

i have my benq 1620, installed it and it worked for the 1st dvd i burned, after that it gave me errors everytime when finalizing…and last time…it didnt even move from step one,(using nero vision express), it just kept trying, got up to 6h elapsed before i closed it…and now my rom tray, wont even open, my blank media is now stuck in the drive and im lost, ive tried updating the firmware…uninstalling etc…nothing works…also…when i 1st boot up it blinks twice with its green light but stops and goes nowhere…and it shows up as some generic one in device manager but its there at least…can someone please tell me what the heck is going on???


#2

I’m not sure what’s going on with your drive. But, I hope you didn’t flash the drive’s firmware when a disc was in the drive? There must be no media in the drive when flashing its firmware. Did you flash it with a disc still stuck inside the drive?


#3

ummm yes i did :frowning: my computer guy said it was fine :(…whats that do?


#4

I read a thread by code65536 that he flashed his drive without taking the disc out before he flashed his drive - nothing happened!!! so now he says he doen’t even take the disc out any more. If anyone whould know, he would!!!


#5

Straighten out a paper clip and push it in the small hole directly underneath the tray and it will slide out. This is a mechanical way of getting the tray out. It will not electronicaly start sliding one way or the other. You could try the button to see if it will load or eject. If it doesn’t you can manually push the tray back in. You will feel some resistance, that is normal. Get past this point before trying to determine what to do next.


#6

More than likely, updating a drive’s firmware with a disc in the drive will probably just make the firmware update not take. This is because the drive is busy reading/accessing the disc in it and so the firmware flash doesn’t get responded to. But, there’s also a slim chance that the drive got a messed up firmware flash (partial or something like that) so that the drive is now totally screwed up. Some people don’t believe that such is possible - a screwed up firmware flash while a disc is in the drive. But, I have talked to techs from various optical drive manufacturers who have told me that such has indeed happened before. It’s more rare because usually the drive will just not respond to the firmware flash instructions because it’s busy accessing the disc inside of it.

Anyhow, I’m really not sure how to go about troubleshooting your problems. Hopefully, others can respond that have more experience with your symptoms than I. But I’ll tell you one thing for sure, I would get another computer guy and darn fast! How can he tell you that flashing a drive with a disc in it is an okay procedure. That’s rolling dice on whether or not the update will take effect. That’s why optical drive makers tell you not to have media inside of your drive when flashing the firmware.


#7

ok thanks on that…im at work now and not sure if the opening thing will work i hope so…but off that topic… any suggestions on y windows only detects it as a generic drive…not a benq?


#8

Which EXACT drive model did you purchase - which brand, was it BenQ or a rebadged version, OEM or retail model, etc? Also, which exact firmware version is on the drive - or was on the drive when Windows read it as a generic drive?


#9

it was an xmas gift so im not sure on purchasing, as for it…it came with all benq software but does not say benq on the front…also its the dvd-rw 1620 g7p9…if that helps…any…im kind of computer slow :frowning: not exactly sure what u mean…


#10

Chances are the disc is misaligned in the tray or the tray is misaligned somehow.

The generic name thing: if you bought a bare drive it will have some concoction of pdvd [I forget the exact name]. If is a retail Benq it will show DW1620. The real key is the firmware version letters that start with a g being the generic/oem and b being the Benq firmware.

Your major problem right now is getting that disk out of the drive. Just take it one step at a time.


#11

Originally Posted by code65536

I used to be very careful about removing any discs prior to a flash. And then there was once when I accidentally forgot to do so, and to my surprise, nothing bad happened. And ever since then, I’ve never bothered to remove any discs before a flash, and it’s never caused me any problems…


#12

Well, like I said in my earlier post - techs from optical drive manufacturers (specifically Plextor and Teac) personally told me that they had cases where drives got a “screwy” flash. I think they said it was because the flash got interrupted by some cause. It’s like when flashing a BIOS on a motherboard that gets interrupted and cuases one’s BIOS to become toasted. That’s the analogy they gave me. I believe it was because some software interrupted the flash, or because someone accidently hit a key combo (I know some people are morons) that made the drive access the disc during the flashing procedure.

This was quite a few years ago and was relative to CD burners. Back then, I was using Plextor and Teac CD burners all the time and asked their techs why one couldn’t have a disc in the drive at the same time a firmware flash was being performed. I was told that probably nothing negative would happen. But, they said there was a small chance that an interruption could cause a messed up flash to occur and that they had seen a few cases where such had happened.

Anyhow, why would one want to chance such a thing? Just take any media out of your drive until the flash update is over and your system has rebooted. Why ask for possible trouble if it can be easily avoided? Maybe the newer drives have been made with a way to prevent such from now happening. I don’t know? But, most optical drive companies still tell you to have no media inside of the drive when flashing the drive’s firmware.

If anyone cares to use their own drive(s) for testing such out, by all means go right ahead. I would be curious to see the outcome, but not curious enough to test such with my drives. :bigsmile:


#13

my drive wont read the media it says none exists…but i know its in there.stuck…lost… :frowning:


#14

I just saw this on Teac Japan’s website. Under “Observe the following precautions in executing the B4S6WIN.EXE” notice that it says “Eject any media in the DV-W516G before executing the program”. It looks Teac is still issuing this warning for their drives, but I couldn’t find such a warning on either BenQ’s or Plextor’s websites. Maybe it’s only for certain drives, but I still wouldn’t chance it.



#15

If you can get that stuck disc out, you can then fix the firmware problem with the CVT flasher located on the unofficial firmware page.


#16

I had a similar problem:
I had a mechanical failure with my First BenQ drive (philips flashed to BenQ NOT with a disk in the drive though)

I crossflashed, then burned about 10 disks without a problem. Then I put a data CD into the drive. Next thing I know the drive tray opens with the disk still spinning and I smell some burning smell. After that the tray was done. The button didn’t work. Manually pushing it closed and opening it with the paper clip did nothing. XP registered the drive as a generic CD-Rom and would not read any disks at all. I flashed it to new firmware, crossflashed it back to philips firmware, physically removed the drive and let XP detect it again (generic CD-ROM) all with no results.

My solution…I returned the drive and got a new one which has been perfect ever since.
Good luck to you


#17

Ok !!!
I have done this before by accident. What you need to do first is get the disc out. You can try the manual eject and might even have to take the drive apart.

What I had to do next, is use the DB’s pure DOS flasher & CVT file to reflash the drive. Chenk the Un-Official BenQ Forum for the detailed programs and instructions.


#18

Kudos to beach-hobo ! That’s exactly it.
Lost disc can also happen if the computer is moved while a disc in in the drive.
My first cd drive, a Philips 1x was always suffering from “lost disc”. Yep, taking the drive apart is the way to get the disc out. The hairdryer can soften up the warranty-stopping label so that it will come off intact.
Or maybe the drive should just be RMA’d Yep. Exchanging the drive is the best idea.