HP DVD1140i is not recognized by Windows

vbimport

#1

I had the same problem as PCRMike (Hardware Problem: HP 1140i driver; Post #3, 27-04-2009). In fact, I bought two of these HP dvd1140i for my two desktops (HP Pavilion and Compaq Presario), both with Windows XP Home, and the device cannot be recognized in either PC! HP assured me that this DVD/RW would work with both of my PCs.

At StartUp, Windows Plug and Play sees it at first for a few seconds (Located new hardware…CD ROM…HP 1140…), and then Windows suddenly goes black and reboots! After this, Plug and Play no longer sees it at startup, and on my Device Manager there is yellow exclamation flag on my Secondary IDE Channel with a Code 39 Windows error (driver may be corrupted or missing).

I’ve been at this for weeks with HP and the device manufacturer, and they said it is a Windows problem because this internal DVD/RW drive should work using the Windows drivers. While I haven’t yet forked over the $50 for Microsoft’s Tech Support, I have updated everything from the Windows website; tried all the fixes for Code 39 errors; I re-seated the cable umpteen times (it has power and loads a DVD/CD, but then the light goes out after a few seconds); changed the placement of the Slave jumper; I tried Uninstall and Look for New Hardware; checked REGEDIT for Upper and Lower Filters (there were none); and every other fix I could find.

Any other suggestions?


#2

Hi and Welcome!

you already tried this: http://support.microsoft.com/kb/314060/ ?

Some more to check:
Proper cables - must be 80wired 18" (46 cm) flat ribbon cable. In doubt, replace them.
If the drives are the only ones on the cable, make sure the jumpers are set to Master position. The drive must then be connected to the black plug of the IDE cable.

Michael
P.S.: Please do not post the same question more than once. :cop:


#3

Thanks, Michael. And sorry about the repeated question. As a newcomer, I wasn’t quite sure how this works. If you notice, I originally posted my situation at the end of the original (4/09) thread, but then I realized how old that thread was, and I was afraid that my comment wouldn’t even be noticed by anyone, so I repeated it as a new question, just to make sure someone might see it.

Anyway, thanks for the suggestion. I did do everything on the Microsoft support site (Mr. Fixit, upper/lower registers, etc.), and none of that was successful. My ribbon cable is shared with my hard drive, so I cannot place the jumper on the DVD/RW in the “Master” position. Also, I doubt it is a bad cable, as the same problem is ocurring with two different PCs.

I’m planning on sending these drives back to HP, and will try my luck at Comp USA or some local retailer. So for anyone that now searches this Users Group with a problem concerning the HP dvd1140i DVD/RW, my advice is, “buyer beware.”

lmcgowan


#4

Try setting the drive to cable select instead of slave.


#5

Jethro,

Thanks. Actually, I first tried the jumper in “cable select” and that didn’t work, and then I tried it in the “slave” position. Just to be thorough, though, I think I’ll try setting it in the “master” position, and if that doesn’t work, I’ll try it with it completely removed!

lmcgowan


#6

Hi,[QUOTE=lmcgowan;2498895] My ribbon cable is shared with my hard drive, so I cannot place the jumper on the DVD/RW in the “Master” position. Also, I doubt it is a bad cable, as the same problem is ocurring with two different PCs.[/QUOTE]Is there an unoccupied IDE connector on the motherboard?
Haveing the optical drive connected to its own cable is better than to have it on the same cable as the HDD.

Michael


#7

Michael,

Thanks for being patient with my ignorance. You were right the first time. The ribbon cable is NOT shared with my hard drive; it is only connected to this DVD/RW drive. I see that it has a “master” plug (black) connector, which how it had been plugged in, and a “slave” plug (gray) connector, which was not connected to anything. I actually looked closer and saw the words “master” and “slave” inked onto the ribbon cable by these respective connectors. So I reset the jumper to “master” on the back of the DVD/RW drive and replugged the master connector, and then I changed the “board” end of the ribbon connector to the empty (blue) socket, instead of the original (black) socket on the board, but this still did not work. It looks good for a minute, as Windows sees the new hardware through Plug and Play, and identifies it as HP 1140, but then the screen blacks out and a reboot begins. Now my Device Manager says Code 39 error on the Primary IDE Channel.

lmcgowan


#8

And the same issue is present with your other computer also?

I would now uninstall the IDE controller that has the error indicator, reboot and let it reinstall. Perhaps there are newer chipset drivers available, too.

Another question: how old are these computers? Perhaps there are bad capacitors on motherboard or PSU.

Michael


#9

Got back on phone with HP to try and return these, and they balked when I told them the DVD ROM and DVD/RW drives previously installed in my 2 desktops just stopped working, and that is why I bought the two new ones from HP as replacements. He sent me back to HP Tech Support (for the 4th time!). But before I got through, I stumbled upon an HP tech article on their website that provides the most thorough discussion I’ve found yet. So I’m proceeding to go through these steps. Here’s the link:
HP and Compaq Desktop PCs – CD or DVD Drive is not Detected (Windows 98, ME, or XP)
For example, one of the steps is to remove all previouly installed CD or DVD burning software, which would be looking for the old drives and could cause conflicts. WIsh me luck!