HP DVD 940i - Serious Read and Burn Problems HELP PLEASE!

vbimport

#1

Hi,

I have a new Hewlett Packard DVD940i Writer purchased Dec 06 - I’m having real problems with this new installed DVD Writer. (Printed on HP Writer ID label, Model DVD 940i - H08. Manufactured Sept 2006)

It’s supposed to play/record to any type of disc and even has Lightscibe capabilities (Not tried that yet though) but I’m only having a 50% play success rate with some NEW purchased R2 Movies. “Pirates of the Carribean”/“Gladiator”/“TransAmerica” etc. the drive just won’t recognise these R2 discs even though they can be played on my old Pioneer A05 drive and my Panasonic DMR-EX75EB DVD Recorder. The message I receive through Nero Tools is “No Disc Inserted”, and a faint whining noise from the DVD drive itself. Although it will play R2 discs like “The Deerhunter” /“Ice Age 2” etc.

I have tried the HP helpdesk, waste of time, no response after 3 attempts.

I installed the Nero software that came with the unit and from the Nero website, downloaded all updates and the DVD940i is set to play Region 2. The HP website has no firmware updates on the DVD940i, the Firmware version displayed in Nero Tools says its 3H23. Does anyone know if this is the latest version ???. My old Pioneer worked a treat and would play all types of R2 movies.

The Jumper is set to “Master”, the same as the old replaced Pioneer writer. I have removed and reinstalled the unit and checked that all cable connections are secure

My Computer Information is:
Microsoft Windows XP (SP.2)
Intel Pentium 4 - 2.4 GHz
Memory Installed: 1.0GB RAM
SoundCard: SoundMAX Digital Audio
Video Capture Device: NVIDIA GeForce 4Ti 4200

Also I have found that trying to burn to Dual Layer discs is a 50/50 hit and miss success rate!. Sometimes burning will just abort on these types of disc. But I am having 100% success rate on burning to DVD-R at 16x speed and to CD at 48x speed.

What’s going on!!!, their must be a setting or a reason for these problems.

Does anyone else out their have this drive or similar problems to the ones that I am experiencing. :confused: Any advice or information would be greatly received as I am pulling my hair out trying to get the problems resolved. :sad:


#2

I just got my 940i last night and the 1st place I checked was CDFreaks. OK probably should have done it the other way round … anyway I saw your post among several others.

The firmware on my drive is the same as yours and HP has no updates for it yet.

A few posts say the HP dvd940i is a rebadged Lite-On 18A1H or close enough to flash it with that firmware and they claim success. I believe them but haven’t done it because so far all my media tests have been positive. But I haven’t tested it yet on DLs or DVD-RAM. One thing for sure is I’ll spend a little more money and get Verbatim or Taiyo Yuden DLs before I make those tests. If you didn’t already I recommend doing the same.

The 940i played parts of all my (small) collection of movies just fine but they are not as new as yours and I’m not R2 so I’m not much help there.

The 940i works with KProbe (I also have a Lite-On drive) which shows it has the SmartBurn function and it runs all the tests whereas my Pioneer DVR-109 can’t run the tests and wouldn’t show any FlashROM info. I don’t know if that means anything or not but KProbe seems to think the 940i is a Lite-On drive. The 940i also works with other programs that are suppossedly only for Lite-Ons like SmartBurn, BookType, etc.

KProbe ROM info shows :
FlashROM Manufacturer ID EF
FlashROM Device ID 14
FlashROM Type NEX(NX25P16)

BillM


#3

Hello, all!

I have the luxury of owning 3 of the HP dvd940i drives. Two of them read commercially pressed DVD’s flawlessy, while one is very fussy about reading commercially pressed DVD’s. I had about decided that the one drive issue was caused by a hardware failure, until I happened across the many comments from others saying that they were having the same problem.

While I understand the comments that the LiteOn drives are great writers, but not good at reading, I found that statement to be a bit defeatist. Why should these drives write all these different formats, but fail to read a commercial DVD? That indicates a fault with the drive that should be fixed. So, given that, I went “investigatin’.”

First, I used the Flash Utility from (codeguys.rpc1.org) and saved a copy of the EEPROM code, and the firmware from both the working and non-working drives. Then I downloaded Kprobe 2.5.2 and went looking at drive information.

I discovered that both of the working drives showed the following:
FlashROM Manufacturer ID: EF
FlashROM Device ID: 14
FlashROM Type: NEX(NX25P16)

The drive that was causing problems showed the following:
FlashROM Manufacturer ID: C2
FlashROM Device ID: 14
FlashROM Type: MXIC(MX25L1605)

All three drives listed the firmware revision as 3H23 (2006/09/02).

I also had identified one commercially pressed video DVD that would fail to read at all on the failing drive, but read perfectly on the other two. I used that my test source.

I obtained the latest firmware for the LiteOn LH-18A1H drive (version HL06). Using the Flash Utility, I flashed the failing drive with the HL06 firmware.

Next, I went to the Control Panel => System => Device Manager and uninstalled the failing drive. Then, I forced a rescan of hardware so that it would add the drive back in. This time (as expected) rather than seeing the drive as an HP dvd940i, it registered it as a LiteOn LH-18A1.

Last, I inserted the commercial DVD that was consistently failing, and voila!.. the drive read the DVD perfectly.

I compared the drive information before and after the reflash using the Kprobe Drive Info function, as well as the DVD Info Pro information (from Roxio Easy Media Creator 9 suite), and other than for the firmware revisions, and the identification of the drive, I can find no other differences.

Before the flash update, Kprobe Drive Info reported the firmware revision as:
DVD Writer 940d

After the flash update, Kprope Drive Info reported the firmware revision as:
DVDRW LH-18A1H.

While I have not done extensive testing yet, the reflashed drive is now reading commercial DVD’s without problems, and all other read and write functions appear to be working normally. I did reflash the drive with its original firmware, and tested again to see if the drive failed to read the commercial dvd (and it did fail.) I then reflashed the drive with the LiteOn firmware, and again tested it (and it read properly.) That confirms that the change in firmware corrected the issue.

For those of you encountering the “Commercial DVD Read Issue”, you may want to download Kprobe and see if the FlashROM information reported is the same as that reported by the failing drive I have. If so, then I would tend to think that there is something in the FlashROM chip or EEPROM code used on these drives, or something in a specific batch of drives produced at a particular facility that may be at fault.

FYI… I did try flashing both the EEPROM code and firmware from the good drive to the failing drive. Once I did that, I got the blinking green light and the drive was toast. I reflashed the drive with the original EEPROM code and firmware, and it was back to the original symptoms. Then, I tried flashing the firmware (only) from the good drive to the failing drive. This made no change whatsoever. The drive still failed to read the commercial dvd I was using as a test source.

My best guess at this point is that there is some compatability issue between the MX25L1605 FlashROM used in the drive, the EEPROM code used on this drive, and the HP 3H23 firmware. Of course, I can’t confirm this with just three drives to test. But I have my suspicions.

Hope you find this helpful. If you test this, and find that you have a drive with the same MX25L1605 FlashROM type, I’d be interested in hearing back if a flash to the LiteOn firmware resolves the read issues. If so, we can feed this info back to HP, and see if we can get an updated FW.

Other than this one issue, I love the dvd940i drives!

Best Regards,

Cap’n Sculley


#4

Where can I get the raw bin file for the LH 18A firmware? Everywhere I’ve looked for it it comes bundled in a executable file that tries to auto-detect my HP 940i and says it isn’t compatible.

This is my last gasp for this drive. I’m on my third one and all have suffered some sort of problem from not working at all to Lightscribe not working (which is the entire reason I chose this model.) If this doesn’t work it’s back to the store and HP goes back to only being a printer supplier for me. I am NOT impressed with the quality to date. Anyhow, if someone can point me to a bin file to try flashing I’d appreciate it.